LINUX.ORG.RU
ФорумAdmin

WinBind+Error


0

0

Привет ! Установил WinBind, настроил nss (использую securuty=domain) и сталкнулся с такой проблемой, при входе юзера, не прописанного на Samba система спрашивает пароль не пускает на шару или пускает по nobody. При этом: ./wbinfo -p - работает ./wbinfo -a имя%пароль - тоже нормально работает ./wbinfo -g - выдет что-то странное - 0xc0000001 ./wbinfo -u - тоже какие-то странности - 0xc0000017

При этом в логах Winbind [2003/03/03 12:30:21, 1] nsswitch/winbindd_user.c:winbindd_getpwnam(147) error getting user info for user '[SGTP]\[art]'

конфиг крайне простой: netbios name = server workgroup = sgtp server string = Samba Server max log size = 50 security = domain wins support = yes password server = DOM MULT * encrypt passwords = yes log level = 3 log file = /usr/local/samba/var/log.%m client code page = 866 character set = KOI8-R smb passwd file = /usr/local/samba/private/smbpasswd username map = /usr/local/samba/lib/smbusers

winbind uid = 10000-65000 winbind gid = 10000-65000 winbind separator = + winbind use default domain = yes winbind enum users = yes winbind enum groups = yes template homedir = /home/%D/%U template shell = /bin/sh winbind cache time = 5

add user script = /usr/sbin/useradd -d /home/sgtp/%u -g 99 -m -s /bin/false %u

С Уважением, Алексей.

anonymous

Re: WinBind+Error

При этом, если есть строчка add user - то все работает нормально, только в систему постоянно добаляются юзера, а ведь это неверно, если есть winbind, подскажите, в чем трабла ?

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.