LINUX.ORG.RU
ФорумAdmin

kernel 2.4.18 & pppd


0

0

Hello All !

есть RedHat linux 7.2
на ядре 2.4.18
и pppd 2.4.1-2 (судя по доке все друг к другу прекрастно подходит)

но в инет выйти не могу

pppd /dev/ttyS1 115200 connect "chat -f dial-script" crtscts defaultroute modem usepeerdns updetach

модем конектится 
pppd выдает: Serial connection established
и сразу за тем: Couldn't set tty to PPP discipline: Invalid argument

НАУЧИТЕ ЧТО ДЕЛАТЬ !!!! ????

С уважением .Alex

P.S. man pppd непомогло =(


Ответ на: Re: kernel 2.4.18 & pppd от Ruwa

Re: Re: kernel 2.4.18 & pppd

Hi Ruwa !

полезная штука лог =)))
вот что происходит во время попытки коннекта:

**** /var/log/messages **** BEGIN
...
Mar 29 19:11:55 ws-fas pppd[3066]: pppd 2.4.1 started by root, uid 0
Mar 29 19:12:24 ws-fas pppd[3066]: Serial connection established.
Mar 29 19:12:24 ws-fas modprobe: modprobe: Can't locate module tty-ldisc-3
Mar 29 19:12:24 ws-fas pppd[3066]: Couldn't set tty to PPP discipline: Invalid argument
Mar 29 19:12:25 ws-fas pppd[3066]: Exit. 
...
**** /var/log/messages **** END

так что причина найдена
теперь вопрос что же это такое tty-ldisc-3
и как его закомпилить в кернел

С уважением .Alex

a_fas ()

Re: kernel 2.4.18 & pppd

/usr/src/linux(x.x)/Documentation/Changes:
.......
PPP
...

If you build ppp support as modules, you will need the following in
your /etc/modules.conf file:

alias char-major-108 ppp_generic
alias /dev/ppp ppp_generic
alias tty-ldisc-3 ppp_async
alias tty-ldisc-14 ppp_synctty
alias ppp-compress-21 bsd_comp
alias ppp-compress-24 ppp_deflate
alias ppp-compress-26 ppp_deflate

Skor78 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.