LINUX.ORG.RU
ФорумAdmin

Проблема компиляций PHP-4.1.1 ?


0

0

Народ!
Подскажите что я делаю не так? При попытки выполнить следующюю команду
#./configure --with-mysql --with-apxs=/usr/local/apache/bin/apxs
далее
#make
вываливаются ошибки
....
Entering directory `/usr/src/php-4.1.1'
/bin/sh /usr/src/php-4.1.1/libtool --silent --mode=link gcc -I. -I/usr/src/php-4.1.1/
-I/usr/src/php-4.1.1/main -I/usr/src/php-4.1.1 -I/usr/local/apache/include -I/usr/src/php-4.1.1/Zend -I/usr/src/php-4.1.1/ext/mysql/libmysql -I/usr/src/php-4.1.1/ext/xml/expat -DLINUX=22 -DUSE_HSREGEX -I/usr/src/php-4.1.1/TSRM -g -O2 -prefer-pic -o libphp4.la -rpath /usr/src/php-4.1.1/libs -avoid-version stub.lo Zend/libZend.la sapi/apache/libsapi.la main/libmain.la regex/libregex.la ext/mysql/libmysql.la ext/pcre/libpcre.la
ext/posix/libposix.la ext/session/libsession.la ext/standard/libstandard.la ext/xml/libxml.la TSRM/libtsrm.la -ldl -lcrypt -lresolv -lm -ldl -lnsl -lresolv -lcrypt
stub.lo: file not recognized: File truncated
collect2: ld returned 1 exit status
make[1]: *** [libphp4.la] Error 1
make[1]: Leaving directory `/usr/src/php-4.1.1'
make: *** [all-recursive] Error 1
Обясните в чем дело и как мне обойти эту проблему.
Мне нужно что бы был установлен модуль libphp4.so

anonymous

Re: Проблема компиляций PHP-4.1.1 ?

Я бы на твоём месте собирал ба Апачу с ПХП заново, у меня такойже трабл был пока всё заново несобрал

anonymous ()

Re: Проблема компиляций PHP-4.1.1 ?

Я уже несколько раз пересобирал с Apache, наверное что то не так делаю. В руководстве по Apache и php все написанно понятно, делаю как там написано, но ошибки валятся. Причем разные версий Apache и php пытался ставить ;(

anonymous ()

Re: Проблема компиляций PHP-4.1.1 ?

Я уже несколько раз пересобирал с Apache, наверное что то не так делаю. В руководстве по Apache и php все написанно понятно, делаю как там написано, но ошибки валятся. Причем разные версий Apache и php пытался ставить ;(

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.