LINUX.ORG.RU
решено ФорумAdmin

Интернет работает, но не подключен

 , ,


0

1

Добрый день. Очень странно получилось, интернет на debian 10 работает, но nmcli пишет что нет подключения. Ещё и девайса нет.

NAME                   UUID                                  TYPE      DEVICE 
Ethernet connection 1  3915b357-ab1b-4867-a585-f3300cba2118  ethernet  -- (не горит зелёным)     
конфиг
[connection]
id=Ethernet connection 1
uuid=7916b317-ab1b-4867-a728-f3100csa2319
type=ethernet
autoconnect-priority=2
interface-name=enp2s0
permissions=

[ethernet]
mac-address=92:ES:49:6D:7C:DD
mac-address-blacklist=

[ipv4]
dns-search=
method=auto

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
ip6-privacy=0
method=auto


В Linux настроить сеть можно разными способами и через разные сервисы (службы).

Если брать Debian, то исторический настройкой сети занимался сервис networking, который настраивался через конфигурационный файл /etc/network/interfaces.

Параллельно существовал network-manager, который тоже мог настраивать сеть и у него были свои собственные файлы для настроек интерфейсов.

Сейчас есть systemd networkd, который близок к network-manager, но несколько отличается от него и имеет тоже свои файлы настроек.

Ну и сеть можно настроить просто введя командами.

ip add add IP/MASK dev IFACE
ip ro add default via GATE
echo "namserver IP" > /etc/resolv.conf

И если ты настроил сеть руками или отработал DHCP, то интерфейс уже сконфигурирован и network-manager не будет им управлять.

Что бы проверить, что интерфейсы сконигурированы смотри вывод команд:

ip a
ip r
cat /etc/resolv.conf
infomeh ★★ ()
Последнее исправление: infomeh (всего исправлений: 1)
Ответ на: комментарий от veyej

Посмотри вывод указанные команд.

Если ты его не конфигурировал, а просто добавил, то по умолчанию подразумевается автонастройка по DHCP.

Аналогично, если поднялся link и уже был запущен какой-либо сервис управления сетью, то там тоже по умолчанию подразумевается выполнить автонастройку по DHCP.

infomeh ★★ ()
Ответ на: комментарий от infomeh

Смотрел в конфигах /etc/network/interfaces [code] allow-hotplug enp2s0 iface enp2s0 inet dhcp [/code] с интернетом проблем нету, с виртулкой проблемы(без сети), сказали мне, чтобы я dhcp перезагрузил(прямо так), проверил что он включен(inet dhcp). подумал, что проблема потому что подключения нету в nm.

Со всем норм, девайс в ip a есть, браузер работает, в resolv.conf роутера адрес, потмоу что на нем выставлял dns сервер. А проблумы только с одной виртуалкой, остальные сеть имеют.

veyej ()
Ответ на: комментарий от veyej

А проблемы только с одной виртуалкой, остальные сеть имеют.

Вот про эти проблемы и нужно подробно написать. Какая система виртуализации используется, какая OS в виртуалке установлена, как именно организована сеть на виртуалке.

Serge10 ★★★★★ ()