LINUX.ORG.RU
ФорумAdmin

Не работает deny from all htaccess

 , ,


0

1

Доброго всем дня. Я новичок в администрировании Linux, внезапно возжелал проникнуться практическими знаниями. Прошу не кидаться тапками.

Собственно, сабж.Изначально прописал свой айпишник, получил доступ, был доволен ровно до того момента, как попробовал получить доступ с соседней машины, айпишник которой не был задекларирован в конфиге и должен был бы быть заденаен. Доступ был. Решил прописать в конфиге «deny from all» но доступ всё равно с обеих машин был.
После каждого изменения ребутал апач и нагиос, чтобы свежий конфиг подтянулся.
Апач перезапускаю командой systemctl restart httpd.service
Нагиос перезапускаю командой systemctl restart nagios.service

Ниже приведен файл конфига etc/httpd/conf.d/nagios.conf
Будьте добры, подскажите куда копать.

ScriptAlias /nagios/cgi-bin «/usr/local/nagios/sbin»

<Directory «/usr/local/nagios/sbin»>
# SSLRequireSSL
Options ExecCGI
AllowOverride None
<IfVersion >= 2.3>
<RequireAll>
Require all granted
# Require host 127.0.0.1

AuthName «Nagios Access»
AuthType Basic
AuthUserFile /usr/local/nagios/etc/htpasswd.users
Require valid-user
</RequireAll>
</IfVersion>
<IfVersion < 2.3>
Order allow,deny
# Allow from all
# Order deny,allow
Deny from all

AuthName «Nagios Access»
AuthType Basic
AuthUserFile /usr/local/nagios/etc/htpasswd.users
Require valid-user
</IfVersion>
</Directory>

Alias /nagios «/usr/local/nagios/share»

<Directory «/usr/local/nagios/share»>
# SSLRequireSSL
Options None
AllowOverride None
<IfVersion >= 2.3>
<RequireAll>
Require all granted
# Require host 127.0.0.1

AuthName «Nagios Access»
AuthType Basic
AuthUserFile /usr/local/nagios/etc/htpasswd.users
Require valid-user
</RequireAll>
</IfVersion>
<IfVersion < 2.3>
Order allow,deny
# Allow from all
# Order deny,allow
Deny from all

AuthName «Nagios Access»
AuthType Basic
AuthUserFile /usr/local/nagios/etc/htpasswd.users
Require valid-user
</IfVersion>
</Directory>

Ответ на: комментарий от anonymous

[root@filedrop conf]# httpd -v
Server version: Apache/2.4.6 (CentOS)

Изменил строки содержащие «Require all granted» на «Require all denied», изменений в работе после ребута не наблюдаю, вэб-морда все еще доступна.

ELatestark ()