LINUX.ORG.RU
ФорумAdmin

Перестал запускаться server 1c 8.3 (предприятие) в centos 6

 


1

1

Сегодня внезапно перестал работать сервер 1с 8.3 (Предприятие), выполняю для его запуска команду «service srv1cv83 start» (ос Centos 6) вижу такие дела:

Starting 1C:Enterprise 8.3 server:   Error: service failed to start!
FAILED

В файле сообщений системы /var/log/messages никаких строчек,связанных с 1с, не наблюдается. Для включения технологического журнала 1с cоздал файл /home/usr1cv8/.1cv8/1C/1cv8/conf/logcfg.xml, а в нем:

<?xml version="1.0" encoding="UTF-8"?>
<config xmlns="http://v8.1c.ru/v8/tech-log">;
  <log location="/var/log/1c" history="168">
    <event>
      <eq property="Name" value="PROC"/>
    </event>
    <event>
      <eq property="Name" value="SCOM"/>
    </event>
    <event>
      <eq property="Name" value="CONN"/>
    </event>
    <event>
      <eq property="Name" value="EXCP"/>
    </event>
    <event>
      <eq property="Name" value="ADMIN"/>
    </event>
    <event>
      <eq property="Name" value="QERR"/>
    </event>
    <property name="all">
    </property>
  </log>
</config>

Но при этом в /var/log/1c ничего не образуется при попытке старта. Права на запись в /var/log/1c у пользователя usr1cv8 имеются. Чтобы понять, почему не запускается 1с, нужны хоть какие-то логи, но их нет. Или все-таки где-то они есть?

Перезапуск как отдельных служб, так и всего сервера не дал успеха, поэтому прошу совета, куда копать

Те порты, что нужны для работы 1с, прослушиваются себе вполне - команда service iptables status дает в том числе:

8    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           multiport dports 1540,1541
9    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           multiport dports 1560:1591

Те порты, что нужны для работы 1с, прослушиваются… Интересно кто же их открыл ? ЗЫ. Потому и не запускается , кто то запустился раньше и открыл порты.

sova ★★ ()
Последнее исправление: sova (всего исправлений: 1)

С включением логов разобрался, если выбрать для записи папку не «/var/log/1c», а «/home/usr1cv8/log», то логи сразу пишутся. Сейчас буду смотреть что внутри

mav1 ()

Спасибо всем за советы, проблема решена следующим образом:

  1. остановлен полурабочий сервер
  2. удалена папка (вся) /home/usr1cv8/.1cv8/1C/1cv8, предварительно сохранил только подпапку внутри нее /conf/ с файлом настроек логирования
  3. запущен заново сервер. Он автоматически создал новый кластер, а в нем я уже создал заново базы средством клиента 1с
  4. работает
  5. сразу бекап папочки /home/usr1cv8/.1cv8/1C/1cv8 себе сделал

Метод наверное не самый лучший, по крайней мере сработало. Рагент не падает, клиент подключается, все нормально и не глючит

mav1 ()