LINUX.ORG.RU
ФорумAdmin

Broadcom 5720 и Intel 82574L не работают вместе.

 , , , ,


0

1

Приветствую! Имеется HPE Microserver gen10 с двумя Broadcom 5720. Так же была установлена Intel 82574L как дискретная NIC. И после установки последней linux не может работать с Broadcom'овскими сетевушками. Они включены в BIOS, видны через lspci, даже мигают когда подцепляешь к ним кабель. Но с ними совершенно невозможно теперь работать. То есть интерфейсы на этих двух карточках не поднимаются. Стоит вынуть Intel'овскую карточку и Broadcom'ы превосходно работают. Это как-то можно решить, или даже не трахать мозг себе?

lspci:

02:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection
03:00.0 Ethernet controller: Broadcom Limited NetXtreme BCM5720 Gigabit Ethernet PCIe
03:00.1 Ethernet controller: Broadcom Limited NetXtreme BCM5720 Gigabit Ethernet PCIe

dmesg | grep eth:

[    4.085328] e1000e 0000:02:00.0 eth0: (PCI Express:2.5GT/s:Width x1) 68:05:ca:a5:02:48
[    4.085406] e1000e 0000:02:00.0 eth0: Intel(R) PRO/1000 Network Connection
[    4.085481] e1000e 0000:02:00.0 eth0: MAC: 3, PHY: 8, PBA No: E46981-008
[   22.004156] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   24.416498] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx

dmesg | grep tg3:

[    3.944420] tg3.c:v3.137 (May 11, 2014)
[    3.955675] tg3 0000:03:00.0: phy probe failed, err -19
[    4.089109] tg3 0000:03:00.0: VPD access failed.  This is likely a firmware bug on this device.  Contact the card vendor for a firmware update
[    4.089415] tg3 0000:03:00.0: Problem fetching invariants of chip, aborting
[    4.099664] tg3 0000:03:00.1: phy probe failed, err -19
[    4.231807] tg3 0000:03:00.1: VPD access failed.  This is likely a firmware bug on this device.  Contact the card vendor for a firmware update
[    4.231965] tg3 0000:03:00.1: Problem fetching invariants of chip, aborting
[   24.871670] tg3 0000:03:00.0: phy probe failed, err -19
[   24.872879] tg3 0000:03:00.0: Problem fetching invariants of chip, aborting
[   24.903664] tg3 0000:03:00.1: phy probe failed, err -19
[   24.904865] tg3 0000:03:00.1: Problem fetching invariants of chip, aborting


  1. Обнови все прошивки всего до чего дотянешься. BIOS, UEFI, сетёвки, etc.
  2. Попробуй вставить эти сетёвки в другой сервер. Просто чтобы локализовать проблему либо до одной сетёвки, либо до материнки.
  3. Попробуй втыкать в разные PCIe порты.
  4. This is likely a firmware bug on this device. Contact the card vendor for a firmware update
im-0 ()

судя по похожим сообщениям в инете, рекомендуют вытащить оба драйвера в модули.
И попробовать менять последовательность их загрузок.

Atlant ★★★★★ ()
Ответ на: комментарий от im-0

Обновить прошивки попробую. Вынуть Broadcom'ы у меня нет возможности - они впаяные в мать. В наличии только два PCIe, пробовал ставить Intel'овскую в другой разъём - проблема остаётся.

Hg194 ()
Ответ на: комментарий от Hg194

Мне помог сброс настроек биоса при попытке завести 10Gb Ethernet в каком-то сервере.

vel ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.