LINUX.ORG.RU
ФорумAdmin

Не получается установить nut в Centos 8 (негде взять libupsclient.so.4()(64bit))

 ,


0

1

При попытке установить nut для UPS'a не получается подтянуть зависимости:

Error:
 Problem: package nut-2.7.4-24.el8.x86_64 requires libupsclient.so.4()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides pygtk2-libglade needed by nut-client-2.7.4-24.el8.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
Yum whatprovides libupsclient.so ничего не находит, выводит
Error: No Matches found
Как в 8-ой центос поставить этот nut? Или подскажите, пожалуйста, каким софтом работать с ИБП APC Smart-UPS 420?


для cтарых моделей apc (особенно с сом-протом) проще использовать apcupsd

vel ★★★★★ ()

У меня APC ES-700 подключен по usb и работает через apcupsd.

SergeySVold ★★★★ ()

При попытке установить nut для UPS'a не получается подтянуть зависимости:

Как ставится nut?

anonymous ()
Ответ на: комментарий от anonymous
sudo yum install nut                        [sudo] password for kt368:
Last metadata expiration check: 1:05:34 ago on Thu 03 Oct 2019 06:29:58 PM EEST.
Error:
 Problem: package nut-2.7.4-24.el8.x86_64 requires libupsclient.so.4()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides pygtk2-libglade needed by nut-client-2.7.4-24.el8.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
kt368 ()
Ответ на: комментарий от anonymous

Вот список включенных репозиториев:

yum repolist                                CentOS-8 - PowerTools            751 kB/s | 1.8 MB     00:02
Last metadata expiration check: 0:00:03 ago on Thu 03 Oct 2019 07:58:27 PM EEST.
repo id    repo name                                       statusAppStream  CentOS-8 - AppStream                            4,928
BaseOS     CentOS-8 - Base                                 2,713
PowerTools CentOS-8 - PowerTools                           1,473
*epel      Extra Packages for Enterprise Linux 8 - x86_64  1,735
extras     CentOS-8 - Extras                                   3
virtualbox Oracle Linux / RHEL / CentOS-8 / x86_64 - Virtu     1
[kt368@sweethome ~]$

kt368 ()
Ответ на: комментарий от anonymous

Пробую установить nut-client - не понимает где взять pygtk2-libglade:

[kt368@sweethome ~]$ sudo yum install nut-client
[sudo] password for kt368:
Last metadata expiration check: 2:35:37 ago on Thu 03 Oct 2019 06:29:58 PM EEST.
Error:
 Problem: conflicting requests
  - nothing provides pygtk2-libglade needed by nut-client-2.7.4-24.el8.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
[kt368@sweethome ~]$

kt368 ()
Ответ на: комментарий от anonymous

Нашёл про RHEL 8, в нем пакет pygtk2-libglade отсутствует (not distributed with RHEL 8): https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8/html...

Возможно из-за этого его и в репозиториях центоса нет. А как тогда его скомпилировать самому?

kt368 ()
Ответ на: комментарий от kt368

pygtk2-libglade needed by nut-client

Это же до какой степени нужно обкуриться, чтоб сделать такую зависимость!

nut - это маленький пакет. На кой хрен его бить так на части?

Мантейнер этого пакета идиот!

vel ★★★★★ ()
Ответ на: комментарий от kt368

Если умеешь собирать пакеты, дык собери.

Если отключить поддержку snmp,usb,cgi то будет зависить только от openssl и glibc

Будь готов к тому, что юнит для systemd может быть кривоват. Тут не так давно кто-то об этом плакался.

vel ★★★★★ ()
Ответ на: комментарий от vel

Мантейнер этого пакета идиот!

Я об этом ещё год назад говорил.

Будь готов к тому, что юнит для systemd может быть кривоват. Тут не так давно кто-то об этом плакался.

Это я, и не плакался, а матерился. Установка пакета это только начало проблем у ТС. Но это зачёт и «развитие», я считаю. В 7-ке хоть устанавливался нормально. И что-то у меня все меньше желание обновляться.

roiman ()
Ответ на: комментарий от roiman

Еще рано 8 использовать. Года через 2-3 будет готова.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.