LINUX.ORG.RU
ФорумAdmin

Вопрос по tac+ia


0

0

проблема у меня в следующем:
поставил такакс tac+ia-0.96pre9.3 , написал вот такой конфиг

#
# Configuration TAC_PLUS
#

#default authentication = db "/etc/tac_plus/users.db"
default authorization = permit

key = FGgh76HGHi

user = v3test
{
        name = "test user"
#       login = cleartext "23681111k"
        login = db "/etc/tac_plus/users.db"
        maxsess = 1
        service = ppp protocol = ip
        {
        addr = "212.22.93.2"
        }
        service = ppp protocol = vpdn { }

}

натравил на него циску, на циске поднят vpn-сервер, циска настроена и успешно работает с другим такаксом, а с этим не пускает пользователя v3test, в логах пишет:

Sat Aug  5 16:58:47 2006 [21984]: acl_verify: name = <v3test>
Sat Aug  5 16:58:47 2006 [21984]: cfg_getmember rets NULL
Sat Aug  5 16:58:47 2006 [21984]: acl_verify ret PERMIT
Sat Aug  5 16:58:47 2006 [21984]: cfg_getmember rets NULL
Sat Aug  5 16:58:47 2006 [21984]: cfg_getmember rets NULL
Sat Aug  5 16:58:47 2006 [21984]: pap-login query for 'v3test' Virtual-Access7 from 212.xx.xx.xx rejected
Sat Aug  5 16:58:47 2006 [21984]: cfg_getmember rets NULL

если в строках
#       login = cleartext "23681111k"
        login = db "/etc/tac_plus/users.db"
заменить login на pap то все начинает работать, но это меня настораживает так как должно все работать с логином, на старом такаксе версии 3.0.9 работает именно так, более того на другом сервере стоит такой же такакс (tac+ia) и там тоже в конфиге везде используется login и все работает, к тому же он игнорирует описания групп. Может кто знает в чем дело, подскажите пожалуйста, может у меня такакс как-нибудь не правильно собрался... ???
anonymous

Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.