LINUX.ORG.RU

QCA6174, Debian 9, Подключается но не работает.

 , ,


1

2

Здравствуйте, товарищи.

Ситуация:
Ноутбук Acer aspire A717-71G.
ОС: Debian 9.5 Stretch
И всё то на нём хорошо, кроме Wi-fi карты Qualcomm Atheros QCA6174

А именно:

Драйвер установлен, прошивка установлена, Wi-fi карта определяется, Network manager успешно подключает её к сети, и даже получает IP-адрес, но после этого данные не передаёт совершенно.

Другие ПК (в том числе на Debian Linux 8 и 9) и телефоны прекрасно подключаются к той же самой сети.

Оборудование: https://pastebin.com/cRe7YkE7

Ядро: 4.9.0-8-amd64 #1 SMP Debian 4.9.110-3+deb9u6 (2018-10-08) x86_64 GNU/Linux

apt search firmware-atheros:
firmware-atheros/now 20180825+dfsg-1~bpo9+1 all [установлен, локальный] Binary firmware for Atheros wireless cards

apt search firmware-linux:
firmware-linux/stable,stable,now 20161130-3 all [установлен] Binary firmware for various drivers in the Linux kernel (meta-package)

firmware-linux-free/stable,stable,now 3.4 all [установлен] бинарные микропрограммы различных устройств для ядра Linux

firmware-linux-nonfree/stable,stable,now 20161130-3 all [установлен] Binary firmware for various drivers in the Linux kernel (meta-package)

Сообщения «dmesg | grep ath10k»:
https://pastebin.com/H1j1bJK5

Сообщения dmesg при подключении к WiFi-сети:
https://pastebin.com/EW23ynfU

Собственно последние строчки из dmesg (IPv6: wlp2s0: IPv6 duplicate address fd01::525b:c2ff:fe7e:aa5 detected! ) меня и наводят на странные мысли.

Я пробовал отключить для карты IPv6 с помощью настроек NetworkManager'а и путём танцев с бубном, выразившихся в подключении/отключении соединения, выполнения dhclient, и подобных вещей, мне 1 раз удалось заставить её работать, но воспроизвести свою последовательность действий я уже не смог, и после очередного пробуждения из спящего режима всё опять вернулось в нерабочее состояние.

Что ещё можно предпринять для решения проблемы?

Ответ на: комментарий от hbars

Похоже нашёл причину проблемы.

Она была в том, что проводной адаптер после отключения провода продолжал висеть в состоянии «UP» и его интерфейс продолжал работать. В результате пакеты система пыталась отправлять через него и ничего не работало.

Назначил Network-manager'у управлять им, и всё стало работать.

Очень странная ситуация, но тем не менее.

MihanEntalpo ()

fd01::525b:c2ff:fe7e:aa5 это адрес автоконфигурации полученный из MAC адреса сетевой карты (EUI-64 https://habr.com/post/245323/). В данном случае у вас где-то дублируется MAC адрес. Попробуйте задать для этой сетевой другой MAC адрес.

gfh ★★ ()