LINUX.ORG.RU
ФорумAdmin

Перенаправление входящего траффика в локальной сети Mikrotik

 


0

1

ДАНО: От Двух провайдеров (ISP1-оптика, ISP2- с роутера Укртелекома 192.168.1.1)в Микротик заходит интернет. Оба канала имеют статический IP. Через утилиту NetWatch настроено переключение всего траффика на резевный ISP2 в случае падения основного канала ISP1.

ЗАДАЧА: Весь траффик, который приходит на ISP2 завернуть в локальную сеть например на 192.168.1.3 вне зависимости от того, работает ISP1 или нет.

PS.Простыми словами: Кучу ВПН клиентов хочу завернуть через резервный канал на 192.168.1.3

ПОДСКАЖИТЕ, в какую сторону копать?

Копать в сторону NAT и маркировки в Mangle.

Xoomoh ()

Весь траффик, который приходит на ISP2 завернуть в локальную сеть например на 192.168.1.3

Не уверен, что правильно понял задачу, но если Вы хотите все запросы, идущие на ISP2 из Интернета, завернуть на машину 192.168.1.3, то Вам нужно DNAT использовать.

Serge10 ★★★★★ ()

Через утилиту NetWatch настроено переключение всего траффика на резевный ISP2 в случае падения основного канала ISP1

Я так понимаю, подразумевается переключение маршрута

вне зависимости от того, работает ISP1 или нет

Оно и так не зависит

Простыми словами

С микротиком такой подход не срабатывает

BleakBeast ()
Ответ на: комментарий от BleakBeast

ip route add distance=1 gateway=1.1.1.1,1.1.1.1, 192.168.1.1

ISP_1 шлюз 1.1.1.1, IP 1.1.1.3 интерфейс vlan7 ISP_2 шлюз 192.168.1.1, IP 192.168.1.3 интерфейс SW2_23 Локальная сеть 192.168.2.1 -192.168.11.254

/ip firewall mangle add action=mark-connection chain=prerouting comment=Giga in-interface=vlan7 new-connection-mark=in-Giga passthrough=yes add action=mark-routing chain=prerouting connection-mark=in-Giga new-routing-mark=Giga passthrough=yes add action=mark-routing chain=output connection-mark=in-Giga new-routing-mark=Giga passthrough=yes

add action=mark-routing chain=output new-routing-mark=Giga passthrough=yes src-address=1.1.1.3

add action=mark-connection chain=prerouting comment=Tele in-interface=SW2_23 new-connection-mark=in-Tele passthrough=yes add action=mark-routing chain=prerouting connection-mark=in-Tele new-routing-mark=Tele passthrough=yes add action=mark-routing chain=output connection-mark=in-Tele new-routing-mark=Tele passthrough=yes add action=mark-routing chain=output new-routing-mark=Tele passthrough=yes src-address=192.168.1.3

/ip route add distance=1 gateway=1.1.1.1 routing-mark=Giga add distance=1 gateway=192.168.1.1 routing-mark=Tele

/ip firewall nat add action=masquerade chain=srcnat out-interface=vlan7 add action=masquerade chain=srcnat out-interface=SW2_23

/ip route rule add src-address=1.1.1.3/32 table=to-Giga add src-address=192.168.1.3/32 table=to-Tele add dst-address=192.168.2.0/24 table=main add dst-address=192.168.3.0/24 table=main add dst-address=192.168.4.0/24 table=main add dst-address=192.168.5.0/24 table=main add dst-address=192.168.6.0/24 table=main add dst-address=192.168.7.0/24 table=main add dst-address=192.168.8.0/24 table=main add dst-address=192.168.9.0/24 table=main add dst-address=192.168.10.0/24 table=main add dst-address=192.168.11.0/24 table=main add dst-address=192.168.100.0/24 table=main add routing-mark=Giga table=to-Giga add routing-mark=Tele table=to-Tele

/ip firewall mangle add action=mark-connection chain=prerouting comment=PCC dst-address-type=!local new-connection-mark=Giga-conn passthrough=no per-connection-classifier=both-addresses-and-ports:3/0 add action=mark-connection chain=prerouting dst-address-type=!local new-connection-mark=Giga-conn passthrough=no per-connection-classifier=both-addresses-and-ports:3/1 add action=mark-connection chain=prerouting dst-address-type=!local new-connection-mark=Tele-conn passthrough=no per-connection-classifier=both-addresses-and-ports:3/2

в правилах прописал, что все, что приходит на роутер на порт OpenVPN - заворачивать на 192.168.10.4 (на нем поднят OpenVPN сервер) вродь работает, но когда клиентом OpenVPN подключаешься по второму провайдеру - нестабильная связь и очень медленная скорость.

Уважаемые ГУРУ, подскажите, что не так делаю?

andriver ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.