LINUX.ORG.RU

Проблема с разрешением зависимостей

 , , ,


0

1

Здравствуйте!

При установке catalyst-libgl получаю запросы на удаление libglvnd и mesa. Соглашаюсь.

НО далее: «не удалось удовлетворить зависимости. unable to satisfy dependency 'mesa' required by catalyst-libgl».

Тогда я делаю следующее: pacman -Rdds mesa libglvnd

Пробую снова установить catalyst-libgl, но: «catalyst-libgl и libglvnd конфликтуют».

Как это исправить?

Ответ на: комментарий от TomJimJack

Свободный драйвер лучше?

Да, в случае старых gpu ~r600 - стабильнее, а для GCN карт еще и быстрее. Плюс catalyst потребует древнее ядро и иксы, тогда зачем ты arch ставил, боюсь тут даже debian9 не подойдет с его новым ядром 4.9.

Aber ★★ ()
Ответ на: комментарий от Aber

боюсь тут даже debian9 не подойдет с его новым ядром 4.9

Под ядро 4.4 его патчили, демаю и для 4.9 осилили бы, но вот с иксами всё сложнее, fglrx 1.18 хочет и ни версией больше.

redgremlin ★★★★★ ()
Ответ на: комментарий от TomJimJack

С mesa у тебя будет OGL4.4, хотя glxinfo будет продолжать писать ogl 3.3 все из-за отсутствия fp64, но эти вычисления не используются в играх, их часто программно в драйверах реализуют, чтоб пройти формальные требования. Карта не быстрая, для нативной скорости можешь посмотреть в сторону gallium nine (только для dx9 игр), но нужен патченый wine.

Aber ★★ ()