LINUX.ORG.RU
ФорумAdmin

Логи SQUID`а вроде в порядке, а он гад не работает...


0

0

Здравствуйте уважаемые админы, мне нужен ваш совет.

Вот решил поставить себе кеширующий проксик. Компельнул, настроил (вроде), а работать не хочет. Гляжу в cache.log Starting Squid Cache version 2.4.STABLE2 for i686-pc-linux-gnu... Process ID 747 With 1024 file descriptors available DNS Socket created on FD 5 Adding nameserver ххх.ххх.ххх.хх from /etc/resolv.conf Adding nameserver ххх.ххх.ххх.хх from /etc/resolv.conf Unlinkd pipe opened on FD 10 Swap maxSize 102400 KB, estimated 20480 objects Target number of buckets: 512 Using 8192 Store buckets Max Mem size: 8192 KB Max Swap size: 102400 KB Rebuilding storage in /usr/squid/cache (DIRTY) Using Least Load store dir selection Set Current Directory to /usr/squid/cache Loaded Icons. Accepting HTTP connections at 0.0.0.0, port 3128, FD 11. Accepting ICP messages at 0.0.0.0, port 3130, FD 12. WCCP Disabled. comm_udp_sendto: FD 5, 193.124.228.37, port 53: (101) Network is unreachable idnsSendQuery: FD 5: sendto: (101) Network is unreachable comm_udp_sendto: FD 5, 193.124.228.32, port 53: (101) Network is unreachable idnsSendQuery: FD 5: sendto: (101) Network is unreachable Ready to serve requests. вроде нормально. Уточнение: Сквид стартовал когда я еще в Интернет не законектился. При попытке из Netscape настроеного на сквид выйти в нет, ждет неимоверно долго, пока связь не обрывается.

Гляжу в access.log

1009548612.911 9 127.0.0.1 TCP_DENIED/403 0 GET http://www.yahoo.com/ - NONE/- -

тоесть броузер обслуживется, но вот это странное NONE.

пробовал запускать ./client http://www.yahoo.com выдет, после долгих раздумий загадочное ALARM CLOCK.

Что посоветуете?

anonymous

Re: кНЦХ SQUID`Ю БПНДЕ Б ОНПЪДЙЕ, Ю НМ ЦЮД МЕ ПЮАНРЮЕР...

оНУНФЕ НМ Й дмя ДНЯРСВЮРЭЯЪ МЕ ЛНФЕР 193.124.228.32, port 53

anonymous ()

Re: Логи SQUID`а вроде в порядке, а он гад не работает...

ДЮ ДЮ, ОКХГ /etc/resolv.conf, /etc/host.conf Х /etc/hosts(МЕ НАЪГЮРЕКЭМН) Б ЯРСДХЧ

Horez ()

Re: Re: Логи SQUID`а вроде в порядке, а он гад не работает...

Уверен что resolve.conf тут не причем т.к. я в squid.conf прописывал опцию "dns_nameservers ай_пи_адрес_DNS_провайдера" это заменяет обращение к resolve.conf. Но всеравно даю search домен_провайдера nameserver ххх.ххх.ххх.хх nameserver ххх.ххх.ххх.хх А вот все остальное. host.conf: order hosts, bind multi on

hosts (на машине пока нет сетевухи) 127.0.0.1 teebot localhost.localdomain localhost

вот это все

anonymous ()

Re: Логи SQUID`а вроде в порядке, а он гад не работает...

Вопрос снимается. Извините что побеспокоил все из-за моей невнимательности. Я сам разобрался.

Дело было в ACL там стандартные настройки сквида содержат запись

acl all src 0.0.0.0/0.0.0.0 (все айпи адреса и все сети)

а потом

http_access deny all

я просто дал себе право.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.