LINUX.ORG.RU
ФорумAdmin

buffer i/o error on device logical block

 ,


0

1

Доброго времени! Помогите пожалуйста в решении следующей проблемы. На сервере(HP Proliant BL460c G7) установлен esxi, к нему подключен lun (FC) схд (HP StorageWorks Enterprise Virtual Array 8400). Развернуты две vm, которые расположены на lun. Через день появляются следующие ошибки: Buffer i/o error on device dm-0, logical block 81156 sd 2:0:0:0: timing out command, waited 180s end_request: I/O error, dev sda, sector 1677352 На другой vm: XFS (dm-0): metadata I/O error: block 0x2578102 («xlog_iodone») error 5 numblks 64 sd 2:0:0:0: timing out command, waited 180s end_request: I/O error, dev sda, sector 1531336

При этом обе машины перестают реагировать на любые команды "-bash: /bin/ifconfig: Input/output error" или "-bash: fdisk: command not found"

Помогает только reset, после какое то время работает нормально.


Ответ на: комментарий от Deleted

При этом из vsphere client я могу открыть datastore. Правда last update 23.07.13

marrt ()

eva? они ещё живы? ЕМНИП, там active/passive контроллеры, это постоянный геморрой. Должен использоваться PSP fixed. На всякий случай проверь в vmware compatibility matrix

90% что проблема в этом. Также могут быть проблемные кабели, медиаконвертеры, или просто в определённое время запускается бекап, который забивает кэш и рушит производительность массива.

router ★★★★★ ()
Ответ на: комментарий от marrt

Необходимо будет найти массив в compatibility matrix и действовать в соответствии

router ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.