LINUX.ORG.RU
ФорумAdmin

radvd и OS X / Android

 , , ,


0

2

Решил сделать ipv6 в домашней сети.
Поставил radvd на роутере, клиенты Linux и Windows адрес получают и всё работает нормально, клиенты OS X и Android - нет.
Конфиг radvd:

interface br0
{
        AdvSendAdvert on;
        MinRtrAdvInterval 30;
        MaxRtrAdvInterval 100;

        prefix 2001:470:xxxx:xxxx::/64
        {
                AdvAutonomous on;
                AdvRouterAddr on;
        };

        RDNSS 2001:470:xxxx:xxxx::1
        {
        };
};
Кто виноват, что делать?

У меня было так:

interface eth0
{
	AdvSendAdvert on;
	AdvDefaultPreference high;
	AdvHomeAgentFlag off;
	prefix xxxxxxxxxx::/64
	{
		AdvOnLink on;
		AdvAutonomous on;
		AdvRouterAddr on;
	};
};
андроидов дома нэма, но в os x (10.7 и 10.9) работало 100% (про другие версии гарантировано не скажу я их только для тестирования держу). На яблофоне тоже работало и емнип на bb10 скорее всего тоже.

anc ★★★★★ ()
Последнее исправление: anc (всего исправлений: 1)
Ответ на: комментарий от anc

А с dnsmasq OS X адреса получает, хотя андроид всё так же нет.

enable-ra
dhcp-range=2001:470:xxxx:xxxx::1000, 2001:470:xxxx:xxxx::1ff, 64, 12h
#dhcp-range=::1000, ::1ff, constructor:br0, ra-stateless, 30m
dhcp-option=option6:dns-server,[2001:470:xxxx:xxxx::1]
С закомментированной строкой аналогично, только адресов OS X получает несколько.

gasinvein ★★★ ()
Ответ на: комментарий от gasinvein

Попробуйте slaac
dhcp-range=2001:470:xxxx:xxxx::1000, 2001:470:xxxx:xxxx::1ff, slaac, 64, 12h

С закомментированной строкой аналогично, только адресов OS X получает несколько.

Это нормально, т.е. правильно.
PS И скорее всего вы ошиблись в dhcp-range 1000 > 1ff

anc ★★★★★ ()
Ответ на: комментарий от gasinvein

Сделал так же, не работает. OS X 10.11.5

Этот даже для тестирования еще не ставил, так что сорри. У меня консервативная политика :)
Но вот что могу сказать точно, так как раз radvd туп как пробка, это c dnsmasq напрыгаться пришлось больше.
Хотя не исключаю проблем с бриджем, я его отдельно держу, т.е. eth0 (локалка) в него не включен. А в dnsmasq раздаю по отдельным интерфейсам dhcp-range=interface:br0,......

anc ★★★★★ ()
Ответ на: комментарий от gasinvein

Но всё же, что не так с radvd?

Незнаю :) У мне работало на radvd -v Version: 2.8
Изначально я на dnsmasq перенес для комфорта, а то как-то не аккуратно :) , а потом еще понадобилось /64 на подсетки порезать, для чего radvd не подходит однозначно.

anc ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.