LINUX.ORG.RU
решено ФорумAdmin

Mikrotik объединить 3+ офисов

 , ,


1

2

Есть офис со статическим внешним IP, к нему надо подключить 2+ офисов (динамические адреса), как сделать так чтобы трафик ходил во все стороны?

Головной Офис (ГО):
RouterOS v6.27
192.168.0.0/24
l2tp server:
l2tp1: Local Address 10.0.16.9, Remote Address 10.0.16.10
l2tp2: Local Address 10.0.16.11, Remote Address 10.0.16.12
ip-routes
192.168.88.0/24 gateway 10.0.16.10
192.168.2.0/24 gateway 10.0.16.12


Офис 1 (О1):
RouterOS v6.31
192.168.88.0/24
l2tp client
192.168.0.0/24 gateway 10.0.16.9


Офис 2 (О2):
RouterOS v6.31
192.168.2.0/24
l2tp client
ip-routes
192.168.0.0/24 gateway 10.0.16.11
192.168.88.0/24 gateway 10.0.16.11


Будем считать что Filter Rules все на accept

Трафик подсетей ГО <-> О1, ГО <-> О2 ходит нормально, а вот О2 -> О1 не проходит.

Прошу помочь, по факту нужно чтобы из всех сетей был доступен один комьютер в О1 (пусть будет 192.168.88.200), но самому хотелось бы знать еще как сделать чтобы в целом трафик можно было пускать между всеми офисами.

Не хватает маршрута у «Офис 1»: 192.168.2.0/24 gw 10.0.16.9
В качестве рекомендации - используй одну и ту же версию прошивки.

Deleted ()
Последнее исправление: darkpony (всего исправлений: 1)
Ответ на: комментарий от Deleted

В теории это логично чтобы пакеты из 88 шли в 2 нужно добавить, но т.к. в приоритете из 2 в 88 (через 0) то не стал добавлять маршрут, ну и он соответсвено тоже не рабочий, пока боюсь прошивки к одной версии привести

bogdan-zuy ()
Ответ на: комментарий от Turbid

Да тоже на это наткнулся, вообще не понял как это использовать, можно ли просто поверх имеющейся конфигурации это делать или нужно какие-то подготовительные работы. Оф. мануал, изобилует командами которые если не правильно будут применены «убьют» уже имеющуюся сеть, и вместо 1ого не рабочего офиса, получу 2а как минимум. Если есть возможность прошу ответить: можно ли ospf использовать по верх имеющейся структуры. ГЛ (l2tp server) О1 и О2 (l2tp client), нужно ли править имеющиеся маршруты?

bogdan-zuy ()
Ответ на: комментарий от Turbid

Сделал следующее:

На трех роутерах:
/interface bridge> add name=loopback
ip address add address=10.255.255.1/32 interface=loopback
/routing ospf instance> set 0 router-id=10.255.255.1

ГО:
/routing ospf network> add network=192.168.0.0/24 area=backbone
/routing ospf network> add network=10.0.16.0/24 area=backbone

О1:
/routing ospf network> add network=192.168.88.0/24 area=backbone
/routing ospf network> add network=10.0.16.0/24 area=backbone

О2:
/routing ospf network> add network=192.168.2.0/24 area=backbone
/routing ospf network> add network=10.0.16.0/24 area=backbone

дальше куда вести настройку не пойму, прошу помощи

bogdan-zuy ()
Ответ на: комментарий от Turbid

Огромное вам спасибо, это было то что нужно сделал прям по пунктам (раздел Описание работы протокола)

1. Включить (собственно сам включается)
2. Присвоить различные Router ID (по оф. документации я подумал что одинаковые должны быть)
3. Добавил отслеживаемые интерфейсы и сети

и все пошло как надо. Еще раз огромное спасибо.

bogdan-zuy ()
Ответ на: комментарий от bogdan-zuy

подскажите, а итоговым решением вам не сложно будет поделиться?

initoff ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.