LINUX.ORG.RU
решено ФорумAdmin

PPTP сервер openwrt

 


0

1

Добрый вечер! Кто ставил pptp север на openwrt? Установлено Attitude Adjustment 12.09.1, старенький D-link Dir620 D1. При попытке подключения роутер просто перезагружется...из-за чего может быть просто хз. Настройки аналогичные использовал раньше на tp-link, на той же версии АА. У кого есть идеи из-за чего может быть такое? Логи: 3:32:02 OpenWrt daemon.debug pptpd[2656]: MGR: Launching /usr/sbin/pptpctrl to handle client Mar 7 23:32:02 OpenWrt daemon.debug pptpd[2656]: CTRL: local address = 192.168.91.1 Mar 7 23:32:02 OpenWrt daemon.debug pptpd[2656]: CTRL: remote address = 192.168.91.102 Mar 7 23:32:02 OpenWrt daemon.debug pptpd[2656]: CTRL: pppd speed = 115200 Mar 7 23:32:02 OpenWrt daemon.debug pptpd[2656]: CTRL: pppd options file = /etc/ppp/options.pptpd Mar 7 23:32:02 OpenWrt daemon.info pptpd[2656]: CTRL: Client 192.168.0.1 control connection started Mar 7 23:32:02 OpenWrt daemon.debug pptpd[2656]: CTRL: Received PPTP Control Message (type: 1) Mar 7 23:32:02 OpenWrt daemon.debug pptpd[2656]: CTRL: Made a START CTRL CONN RPLY packet Mar 7 23:32:02 OpenWrt daemon.debug pptpd[2656]: CTRL: I wrote 156 bytes to the client. Mar 7 23:32:02 OpenWrt daemon.debug pptpd[2656]: CTRL: Sent packet to client Mar 7 23:32:02 OpenWrt daemon.debug pptpd[2656]: CTRL: Received PPTP Control Message (type: 7) Mar 7 23:32:02 OpenWrt daemon.debug pptpd[2656]: CTRL: Set parameters to 100000000 maxbps, 64 window size Mar 7 23:32:02 OpenWrt daemon.debug pptpd[2656]: CTRL: Made a OUT CALL RPLY packet Mar 7 23:32:02 OpenWrt daemon.info pptpd[2656]: CTRL: Starting call (launching pppd, opening GRE) Mar 7 23:32:02 OpenWrt daemon.debug pptpd[2656]: CTRL: pty_fd = 6 Mar 7 23:32:02 OpenWrt daemon.debug pptpd[2656]: CTRL: tty_fd = 7 Mar 7 23:32:02 OpenWrt daemon.debug pptpd[2656]: CTRL: I wrote 32 bytes to the client. Mar 7 23:32:02 OpenWrt daemon.debug pptpd[2656]: CTRL: Sent packet to client Mar 7 23:32:02 OpenWrt daemon.debug pptpd[2657]: CTRL (PPPD Launcher): program binary = /usr/sbin/pppd Mar 7 23:32:02 OpenWrt daemon.debug pptpd[2657]: CTRL (PPPD Launcher): local address = 192.168.91.1 Mar 7 23:32:02 OpenWrt daemon.debug pptpd[2657]: CTRL (PPPD Launcher): remote address = 192.168.91.102 Mar 7 23:32:02 OpenWrt daemon.debug pptpd[2656]: CTRL: Received PPTP Control Message (type: 15) Mar 7 23:32:02 OpenWrt daemon.debug pptpd[2656]: CTRL: Got a SET LINK INFO packet with standard ACCMs Mar 7 23:32:02 OpenWrt daemon.notice pppd[2657]: pppd 2.4.5 started by root, uid 0 Mar 7 23:32:02 OpenWrt daemon.info pppd[2657]: Using interface ppp0 Mar 7 23:32:02 OpenWrt daemon.notice pppd[2657]: Connect: ppp0 <--> /dev/pts/1 Mar 7 23:32:32 OpenWrt daemon.warn pppd[2657]: LCP: timeout sending Config-Requests Mar 7 23:32:32 OpenWrt daemon.notice pppd[2657]: Connection terminated. Mar 7 23:32:32 OpenWrt daemon.notice pppd[2657]: Modem hangup Mar 7 23:32:32 OpenWrt daemon.info pppd[2657]: Exit.

да и конф вроде уникальностью не блещет: debug logfile /tmp/pptp-server.log auth name «pptp» lcp-echo-failure 60 lcp-echo-interval 60 default-asyncmap mtu 1482 mru 1482 nobsdcomp nodeflate proxyarp #nomppc mppe required,no40,no56,stateless require-mschap-v2 refuse-chap refuse-mschap refuse-eap refuse-pap #ms-dns 172.16.1.1 #plugin radius.so #radius-config-file /etc/radius.conf

Ответ на: комментарий от anonymous

Короче к черту то что перезагружается...вроде проблема решилась сама неясно каким способом. Сейчас уже второй день работает норм. Вопрос еще один в другом: С lan клиент подключается без проблем, но уже из внешней сети проблемы.

1) порт 1723 redirect настроен

2) правило из wan в lan proto '47' настроен

Но при подключении получаю 619 ошибку «Не удается подключится к удален. комп. Порт закрыт»


В логах: Mar 9 22:58:45 OpenWrt daemon.debug pptpd[13283]: MGR: Launching /usr/sbin/pptpctrl to handle client

Mar 9 22:58:45 OpenWrt daemon.debug pptpd[13283]: CTRL: local address = 192.168.91.1

Mar 9 22:58:45 OpenWrt daemon.debug pptpd[13283]: CTRL: remote address = 192.168.91.102

Mar 9 22:58:45 OpenWrt daemon.debug pptpd[13283]: CTRL: pppd speed = 115200

Mar 9 22:58:45 OpenWrt daemon.debug pptpd[13283]: CTRL: pppd options file = /etc/ppp/options.pptpd

Mar 9 22:58:45 OpenWrt daemon.info pptpd[13283]: CTRL: Client 192.168.0.153 control connection started

Mar 9 22:58:45 OpenWrt daemon.debug pptpd[13283]: CTRL: Received PPTP Control Message (type: 1)

Mar 9 22:58:45 OpenWrt daemon.debug pptpd[13283]: CTRL: Made a START CTRL CONN RPLY packet

Mar 9 22:58:45 OpenWrt daemon.debug pptpd[13283]: CTRL: I wrote 156 bytes to the client.

Mar 9 22:58:45 OpenWrt daemon.debug pptpd[13283]: CTRL: Sent packet to client

Mar 9 22:58:45 OpenWrt daemon.debug pptpd[13283]: CTRL: Received PPTP Control Message (type: 7)

Mar 9 22:58:45 OpenWrt daemon.debug pptpd[13283]: CTRL: Set parameters to 100000000 maxbps, 64 window size Mar 9 22:58:45 OpenWrt daemon.debug pptpd[13283]: CTRL: Made a OUT CALL RPLY packet

Mar 9 22:58:45 OpenWrt daemon.info pptpd[13283]: CTRL: Starting call (launching pppd, opening GRE)

Mar 9 22:58:45 OpenWrt daemon.debug pptpd[13283]: CTRL: pty_fd = 6 Mar 9 22:58:45 OpenWrt daemon.debug pptpd[13283]: CTRL: tty_fd = 7 Mar 9 22:58:45 OpenWrt daemon.debug pptpd[13283]: CTRL: I wrote 32 bytes to the client.

Mar 9 22:58:45 OpenWrt daemon.debug pptpd[13283]: CTRL: Sent packet to client

Mar 9 22:58:45 OpenWrt daemon.debug pptpd[13284]: CTRL (PPPD Launcher): program binary = /usr/sbin/pppd

Mar 9 22:58:45 OpenWrt daemon.debug pptpd[13284]: CTRL (PPPD Launcher): local address = 192.168.91.1

Mar 9 22:58:45 OpenWrt daemon.debug pptpd[13284]: CTRL (PPPD Launcher): remote address = 192.168.91.102

Mar 9 22:58:45 OpenWrt daemon.notice pppd[13284]: pppd 2.4.5 started by root, uid 0

Mar 9 22:58:45 OpenWrt daemon.debug pptpd[13283]: CTRL: Received PPTP Control Message (type: 15)

Mar 9 22:58:45 OpenWrt daemon.debug pptpd[13283]: CTRL: Got a SET LINK INFO packet with standard ACCMs

Mar 9 22:58:45 OpenWrt daemon.info pppd[13284]: Using interface ppp1

Mar 9 22:58:45 OpenWrt daemon.notice pppd[13284]: Connect: ppp1 <--> /dev/pts/0

Mar 9 22:59:15 OpenWrt daemon.warn pppd[13284]: LCP: timeout sending Config-Requests

Mar 9 22:59:15 OpenWrt daemon.notice pppd[13284]: Connection terminated.

Mar 9 22:59:15 OpenWrt daemon.notice pppd[13284]: Modem hangup

Mar 9 22:59:15 OpenWrt daemon.info pppd[13284]: Exit.

Mar 9 22:59:15 OpenWrt daemon.err pptpd[13283]: GRE: read(fd=6,buffer=415c88,len=8196) from PTY failed: status = -1 error = Input/output error, usually caused by unexpected termination of pppd, check option syntax and pppd logs

Mar 9 22:59:15 OpenWrt daemon.err pptpd[13283]: CTRL: PTY read or GRE write failed (pty,gre)=(6,7)

Mar 9 22:59:15 OpenWrt daemon.debug pptpd[13283]: CTRL: Reaping child PPP[13284]

Mar 9 22:59:15 OpenWrt daemon.info pptpd[13283]: CTRL: Client 192.168.0.153 control connection finished

Mar 9 22:59:15 OpenWrt daemon.debug pptpd[13283]: CTRL: Exiting now Mar 9 22:59:15 OpenWrt daemon.debug pptpd[2318]: MGR: Reaped child 13283

я как понимаю проблемы в GRE? хоть и правило настроено. Ключевое слово «LCP: timeout sending Config-Requests» Настройки брал по примеру из http://wiki.openwrt.org/doc/howto/vpn.server.pptpd

Настройки firewall


config rule

option target 'ACCEPT'

option _name 'pptp'

option src 'wan'

option proto 'tcp'

option dest_port '1723'


config rule option target 'ACCEPT'

option _name 'gre'

option src 'wan'

option proto '47'


config redirect

option target 'DNAT'

option src 'wan'

option dest 'lan'

option proto 'tcp udp'

option src_dport '1723'

option dest_port '1723'

option name 'pptp-1723'

option dest_ip '192.168.0.1'


/etc/ppp/options.pptpd

#debug

logfile /tmp/pptp-server.log

auth

name «pptp»

lcp-echo-failure 60

lcp-echo-interval 60

default-asyncmap

mtu 1482

mru 1482

nobsdcomp

nodeflate

proxyarp

#nomppc

mppe required,no40,no56,stateless

require-mschap-v2

refuse-chap

refuse-mschap

refuse-eap

refuse-pap

#ms-dns 172.16.1.1

#plugin radius.so

#radius-config-file /etc/radius.conf


Что еще нужно firewall?

Rikutas ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.