LINUX.ORG.RU
решено ФорумAdmin

Кто юзал Asterisk + webrtc?

 , , , ,


0

1

Прошу поделиться историями успеха.

Собрал 13 Asterisk, последний Firefox+Cromium/Chrome - в итоге все регается и звонится прекрасно, разве что огорчает отсутствие передачи звука в оба конца.

Пока что нагуглил возможную проблему - параметр rtcp (rtcp-mux) которого нет в Asterisk и который хотят свежие версии файрфоксов и прочих.

Но Sofia (которая в Freeswitch) прекрасно передаёт звук через webrtc.

Можно ли как-то отрубить rtcp-mux или пропатчить Asterisk?

PS: тестил на sipml5

Моя история успеха - kamailio + chrome + jssip.

Krieger_Od ★★ ()
Ответ на: комментарий от Krieger_Od

Тоже читал про него, у меня вся телефония сейчас на asterisk. Freeswitch или kamailio конечно намного мощнее, но хотелось бы не собирать комбайны.

Сегодня наверное еще прогоню пару тестов. Спасибо.

invokercd ★★★★ ()
Ответ на: комментарий от invokercd

Freeswitch или kamailio конечно намного мощнее

Это разные, несравнимые вещи.

Krieger_Od ★★ ()
Ответ на: комментарий от Krieger_Od

Для sip они все подходят в роли софт-свитча. Хотя с kamailio я не работал, так что могу ошибаться.

invokercd ★★★★ ()

woohoo

Чуваки, похоже что всё-таки работает.

Asterisk 13.2: если ответить на звонок сразу - всё работает. Но стоит только немного задержаться - звука нет совсем.

Сначала в дебаге rtp было видно что вызываемый клиент юзает ice и в итоге rtp валит по неверному адресу. В общем отрубил я ice на клиентах (оба в одной сети, никаких натов), в дебаге rtp теперь адреса правильные, но звука все равно нет.

Вот когда снять всё по-быстрому (звук есть):

rtp debug: http://pastebin.com/EzfByCG5

sip debug: http://pastebin.com/1Y08yF5s

А теперь, когда ответ происходит секунд через 10 и звука нет вообще:

rtp debug: http://pastebin.com/TNnFkz6M

sip debug: http://pastebin.com/zG7pjcZD

rtp.conf

[general]
rtpstart=10000
rtpend=20000
icesupport=true
sip.conf
[general]
realm=192.168.88.251
udpbindaddr=192.168.88.251
transport=udp,ws,wss

[889]
type=friend
username=889
host=dynamic
secret=secret
encryption=yes
avpf=yes
icesupport=yes
context=default
directmedia=no
transport=udp,ws
force_avp=yes
dtlsenable=yes
dtlsverify=no
dtlscertfile=/etc/asterisk/keys/asterisk.pem
dtlsprivatekey=/etc/asterisk/keys/asterisk.pem
dtlssetup=actpass
nat=no
На FreeSwitch такой проблемы нет. Возможно у кого есть идеи?)

cast: zgen

invokercd ★★★★ ()

В общем проблема оказалась в протухшем sip стеке Asterisk, c pjsip все относительно завелось. Но pjsip все равно фуфло по сравнению с Sofia.

Пока переезжаю на FreeSwitch, планирую написать бэк к rest api что бы гонять статистику и управлялки.

invokercd ★★★★ ()
Последнее исправление: invokercd (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.