LINUX.ORG.RU
ФорумAdmin

grub2 и gpt

 , , , ,


1

2

Здравствуйте,

не получается поставить grub2 на диск с gpt

разбил диск так

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048           69631   33.0 MiB    EF02  
   2           69632          335871   130.0 MiB   0700  
   3          335872        52764671   25.0 GiB    0700

1 для grub 2 для /boot и 3 для /

ставлю grub2

grub-install --modules=part_gpt /dev/sda
grub-mkconfig -o /boot/grub/grub.cfg

и после перезагрузки с этого диска система не грузится ..


Ответ на: комментарий от GGUseR

Тогда ты неправильно ставишь. Первыым должен быть раздел ESP с FAT32 (EF00), который монтируется в /boot или /boot/efi. На него ставить grub2-efi.

Andrew ★★★ ()
Последнее исправление: Andrew (всего исправлений: 1)

ты всё сделал не правильно:

  • первый раздел должен быть FAT32;
  • он должен иметь флаги boot и esp;
  • он должен быть объёмом не менее 524.5 мегабайт (то есть >512MiB == >524.5MB);
  • grub2 нужно ставить не в /dev/sda, а в /dev/sda1;
  • ядро должно находиться в поле видимости граба (не обязательно).

а вообще, если у тебя UEFI, зачем тебе загрузчик?

funeralismatic ★★★ ()
Ответ на: комментарий от funeralismatic

сделал 1гб /dev/sdc1 в fat32

ставлю: grub-install --modules=part_gpt /dev/sda

ошибка: /usr/sbin/grub-bios-setup: error: unable to identify a filesystem in hostdisk//dev/sdc; safety check can't be performed.

делаю так:

grub-install --target=x86_64-efi /dev/sdc1

ошибки нет но всёравно не грузится..

через биос как я понял тоже можно грузить GPT

для этого нужен раздел с флагом bios_grub размером 2мб?

я делал такой раздел ставил груб

grub-install /dev/sdc

тоже не грузился в чём ошибка?

GGUseR ()
Ответ на: комментарий от MLP_Fan

попробовал rEFInd

у меня система стоит на 1ом диске

на 2ом создал раздел 1гб fat32 установил туда rEFInd после установки он написал что всё нормально

перезагрузился с этого диска и нечего... вроде всё правильно делаю... мб с железом проблемы или я чтото упускаю..

ставил на флешку rEFInd всё работает.. а на диске нет

GGUseR ()
Последнее исправление: GGUseR (всего исправлений: 1)
Ответ на: комментарий от anonymous

да он сам выставляет можно даже раздел не указывать (когда указываю раздел он ошибку выдаёт..) он сам 1 раздел заберает и флаг выставляет

имя поменял на grub результата нет

GGUseR ()

вместо того, чтобы страдать херней с этим монстрограбом, ставил бы на fat ядро и initrd. Добавляешь в bds boot record и поехал

parrto ()
Ответ на: комментарий от GGUseR

bds - что-то типа загрузчика, можно по клавише(esc) выбрать что загружать.
если линукс загружен через efi - юзай efibootmgr. Или можно добавить через bios settings. Параметры ядра можно указывать, работает.

parrto ()
Ответ на: комментарий от GGUseR

для этого нужен раздел с флагом bios_grub размером 2мб?

Нет. Это костыль для BIOS-систем.

Andrew ★★★ ()
Ответ на: комментарий от parrto

я изначально предлагал поциенту использовать EFI как загрузчик, но он, видимо, в документацию совсем не умеет.

funeralismatic ★★★ ()
Ответ на: комментарий от GGUseR

ставлю: grub-install --modules=part_gpt /dev/sda

и не выйдет.

через биос как я понял тоже можно грузить GPT

не понял. у тебя BIOS, а не UEFI, и ты хочешь запустить EFI-приложение? сформулируй конкретнее.

тоже не грузился в чём ошибка?

Secure Boot хоть догадался отключить?

funeralismatic ★★★ ()
Ответ на: комментарий от GGUseR

ошибки нет но всёравно не грузится..

Ты выбирал в диспетчере загрузок UEFI нужный загрузчик с пометкой UEFI? Покажи вывод:

efibootmgr

Andrew ★★★ ()
Последнее исправление: Andrew (всего исправлений: 1)

Корректно работать с gpt умеет только gdisk, а грузить gummiboot. Достаточно диск разбить на 2 раздела:
1. /boot(Fat32 с меткой ef00)
2. /
например

QIQuJIunn ★★ ()
Последнее исправление: QIQuJIunn (всего исправлений: 5)
Ответ на: комментарий от GGUseR

ставлю Windows UEFI

это и есть Secure Boot.

можно и с ним, но нужно подписать ядро. не буду описывать алгоритм действий, об этом уже имеется ряд статей в интернете.

funeralismatic ★★★ ()
Ответ на: комментарий от funeralismatic

Ну в режиме Другие ОС тоже не работает

после установки grub2

ещё нужно через efibootmgr добавлять пунк?

выполняю efibootmgr выдаёт ошибку

Fatal: Couldn't open either sysfs or procfs directories for accessing EFI variables. Try 'modprobe efivars' as root.

после modprobe efivars всёравно не работает

GGUseR ()
Ответ на: комментарий от GGUseR

Fatal: Couldn't open either sysfs or procfs directories for accessing EFI variables. Try 'modprobe efivars' as root.

Значит загрузка произошла в легаси-режиме.

Andrew ★★★ ()
Ответ на: комментарий от GGUseR

Чтобы прописать загрузчик в UEFI, нужно чтобы был доступ к нему, так что да. Есть вариант с EFI Shell и там вручную указать откуда что грузить, если EFI-загрузчик (grub-efi или что там у тебя) установлен как следует.

Andrew ★★★ ()
Последнее исправление: Andrew (всего исправлений: 1)
Ответ на: комментарий от GGUseR

Гугли в сторону EFI_STUB. Но там будет точно такая же проблема, т.к добавлять ядро в UEFI через efibootmgr надо будет.

Andrew ★★★ ()
Ответ на: комментарий от GGUseR

это мне нужно загрузится в UEFI чтоб установить UEFI?

то есть ты в легаси режиме пытаешься сделать ефи? >_<

всё, я ухожу, этот поциент неизлечим!

funeralismatic ★★★ ()
Ответ на: комментарий от GGUseR

а как без загрузчика грузить?

ты в efi добавляешь пункты через efibootmgr (не добавляешь в данный момент, ибо ты какой-то наркоман, раз из легасы пытаешься ефи тыкать, но сути не меняет). каждый пункт добавляешь. каждый пункт ссылается на efi-приложение. и едро должно быть таковым. и тогда ты можешь загружаться без загрузчика, выбирая при необходимости нужные пункты при загрузке компьютера, нажав Esc, F8 или что у тебя там. это просто. но ты даже не гуглил, раз задаёшь такой вопрос. а мог бы просто почитать.

funeralismatic ★★★ ()
Ответ на: комментарий от GGUseR

в первый день бог создал \efi\boot\boot{arch}.efi на esp разделе

parrto ()
Ответ на: комментарий от funeralismatic

я же правильно сделал

far32 с флагом EF00 в него поставил груб

после перезагрузки UEFI этот раздел не увидил

хотя ставил на флешку rEFInd и с неё UEFI грузится

GGUseR ()

ESP раздел не обязательно ставить первым. /boot на отдельном разделе не нужен. Нужно использовать не просто grub2, а grub2-efi.

anonymous ()
Ответ на: комментарий от Deleted

то-то она и не загружается после установки на ефи в большинстве случаев.

funeralismatic ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.