LINUX.ORG.RU
ФорумAdmin

Таймаут соединения по SMTP

 , ,


0

1

Всем привет. Настроили, вобщем, сервер, работал себе, и тут пригодилась отправка почты с сайта. Написал скрипт, а он в браузере отваливается по таймауту, 504. В консоли даю

# php opt/www/site.ru/mail.php
Всё отправляется, почта приходит. Иду дальше:
# jexec 12 php /opt/www/site.ru/mail.php
И тут висит долгое время. Причём в php переменная «SMTP» указывается как 127.0.0.1.
# jexec 12 telnet 127.0.0.1 25
Соединяется, связь есть, но почта всё равно не отправляется. Что интересно,
# jexec 12 ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
ping: sendto: Can't assign requested address
Но думаю, это мало касается проблемы, ведь с localhost проходит коннект.

Вот выдержка из rc.conf:

jail_siteru_rootdir="/opt/turma/site.ru"
jail_siteru_hostname="siteru"
jail_siteru_ip="127.0.0.3"
jail_siteru_interface="lo0"
jail_siteru_flags="-l -U root"

В какую сторону смотреть, что ещё глянуть?

Насколько я помню, локалхост с основной системы не будет доступен в jail. Покажи ifconfig на основной системе и в jail.

Что интересно

Ничего интересного. Пока не включишь raw sockets пинги не будут работать. Они там и не нужны.

iron ★★★★★ ()
Последнее исправление: iron (всего исправлений: 1)
Ответ на: комментарий от iron

Насколько я помню, локалхост с основной системы не будет доступен в jail.

Но как-то же telnet сработал из-под jail?

Покажи ifconfig на основной системе

# ifconfig
bge0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=8009b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,LINKSTATE>
        ether 11:11:11:11:11:11
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
        media: Ethernet autoselect (none)
        status: no carrier
bce0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=c01bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,VLAN_HWTSO,LINKSTATE>
        ether 44:44:44:44:44:44
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
        media: Ethernet autoselect
bce1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=c01bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,VLAN_HWTSO,LINKSTATE>
        ether 11:11:11:11:11:11
        inet 1.2.3.4 netmask 0xffffffc0 broadcast 1.2.3.5
        inet6 fe80::cad3:85ee:fee0:cd2%bce1 prefixlen 64 scopeid 0x3 
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
        media: Ethernet autoselect (1000baseT <full-duplex>)
        status: active
pflog0: flags=141<UP,RUNNING,PROMISC> metric 0 mtu 33152
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        options=3<RXCSUM,TXCSUM>
        inet6 ::1 prefixlen 128 
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0xb 
        inet 127.0.0.1 netmask 0xff000000 
        inet 127.0.0.3 netmask 0xffffffff 
        inet 127.0.0.2 netmask 0xffffffff 
        inet 127.0.0.5 netmask 0xffffffff 
        inet 127.0.0.4 netmask 0xffffffff 
        inet 127.0.0.6 netmask 0xffffffff 
        nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>

и в jail

# jexec 16 ifconfig
bge0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=8009b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,LINKSTATE>
        ether 11:11:11:11:11:11
        media: Ethernet autoselect (none)
        status: no carrier
bce0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=c01bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,VLAN_HWTSO,LINKSTATE>
        ether 11:11:11:11:11:11
        media: Ethernet autoselect
bce1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=c01bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,VLAN_HWTSO,LINKSTATE>
        ether 22:22:22:22:22:22
        media: Ethernet autoselect (1000baseT <full-duplex>)
        status: active
usbus0: flags=10001<UP> metric 0 mtu 0
usbus1: flags=10001<UP> metric 0 mtu 0
usbus2: flags=10001<UP> metric 0 mtu 0
usbus3: flags=10001<UP> metric 0 mtu 0
usbus4: flags=10001<UP> metric 0 mtu 0
usbus5: flags=10001<UP> metric 0 mtu 0
pflog0: flags=141<UP,RUNNING,PROMISC> metric 0 mtu 33152
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        options=3<RXCSUM,TXCSUM>
        inet 127.0.0.3 netmask 0xffffffff 

Пока не включишь raw sockets

/etc/sysctl.conf
security.jail.allow_raw_sockets=1

Оно? Стоит сейчас так.

leader32 ()
Ответ на: комментарий от leader32

Мдя, что-то я по утру туплю. Доступ к 127.0.0.1 из jail должен быть, проверил у себя с аналогичными настройками. Судя по pflog0, на сервере настроен фаервол. Может он отрезает подключение?

Оно? Стоит сейчас так.

И снова подозрение на фаервол.

iron ★★★★★ ()
Последнее исправление: iron (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.