LINUX.ORG.RU
ФорумAdmin

Установка Postfix 2.11.1

 


0

1

Здравствуйте!
Устанавливал Postfix 2.11.1 из исходников

#cd /tmp
#wget ftp://ftp.opennet.ru/pub/postfix/official/postfix-2.11.1.tar.gz
#tar zxvf postfix-2.11.1.tar.gz
#cd postfix-2.11.1
#groupadd postfix
#groupadd postdrop
#useradd -g postfix postfix
#aptitude purge ~iexim4 -y
#aptitude purge ~c
#sudo apt-get build-dep postfix
#make -f Makefile.init makefiles \
   'CCARGS=-DHAS_MYSQL -I/usr/include/mysql' \
   'AUXLIBS=-L/usr/local/mysql/lib -lmysqlclient -lz -lm'
#make
#make install
#postconf -m
#postfix check
#postfix start
Установился без проблем. Стартует и останавливается без проблем
#postconf start
#postconf stop

Проблема в том, что не создался файл /etc/init.d/postfix

#/etc/init.d/postfix start
-bash: /etc/init.d/postfix: No such file or directory

Подскажите, как его создать, пожалуйста?

Подскажите, как его создать, пожалуйста?

написать руками или попробовать подложить инит-скрипт постфикса из пакета

xfilx ★★ ()
Ответ на: комментарий от xfilx

+1

В пакете есть этот скрипт, поищи внимательно там куда раскрутил postfix. Автоматом обычно при установке не ложатся скрипты в init.d

alex_sim ★★★ ()
Ответ на: комментарий от rafaello

хотелось установить последнюю версию...

Нафига? Чего тебе не хватает в этой?

Но если очень хочется, то:

# echo "deb http://ftp.debian.org/debian wheezy-backports main contrib non-free" >> /etc/apt/sources.list
apt-get -t wheezy-backports install postfix
и будет 2.11.1

Если у тебя бубунта то ищи у них в бэкпортах. И вообще, отучивайся собирать из исходников, если нет достаточного опыта и реальной необходимости.

blind_oracle ★★★★★ ()
Ответ на: комментарий от blind_oracle

Нафига? Чего тебе не хватает в этой?

Я слышал, как один мужик говорил, что там малость наворотов поболее. В частности, новый параметр для TLS. А я хочу купить сертификат TLS, говорят для гугла он самое то...
Кстати, того мужика, если я не ошибаюсь, зовут Wietse Venema, хотя я лично с ним не знаком.

rafaello ()
Ответ на: комментарий от rafaello

В частности, новый параметр для TLS

Вау, что за параметр? У меня сертификат честный давно постфиксу скормлен и всё работает уже дофигалет как надо еще с версий 2.6 или около того. ЧЯДНТ?

blind_oracle ★★★★★ ()
Ответ на: комментарий от rafaello

Зачем оно сейчас? Им никто не пользуется, толку не будет. А когда будут пользоваться - как раз правильная версия подоспеет :)

blind_oracle ★★★★★ ()
Ответ на: комментарий от blind_oracle
# echo "deb http://ftp.debian.org/debian wheezy-backports main contrib non-free" >> /etc/apt/sources.list
apt-get -t wheezy-backports install postfix

Спасибо!!!
Помогло.

rafaello ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.