LINUX.ORG.RU
ФорумAdmin

Избитая тема, но ответа так и не нашел

 , ,


0

1

Есть сервер на debian, который должен работать как маршрутизатор. После настройки запускаю пинги с других устройств - проходят, все нормально. Но через минуту-две перестает работать. С чем это может быть связано?

Есть пара скриптов: 1 помечает пакеты

---------------------------------------------------------------

iptables -t mangle -A PREROUTING -m iprange --src-range 192.168.0.50-192.168.0.99 -d 0.0.0.0/0 -j MARK --set-mark 11

iptables -t mangle -A PREROUTING -i eth0 -d 0.0.0.0/0 -j MARK --set-mark 10

---------------------------------------------------------------

2 маршрутизирует

---------------------------------------------------------------

ip route add 192.168.0.0/23 dev eth0 src 192.168.0.50 table 11

ip route add x.x.x.x/x dev eth1.44 src 195.208.65.146 table 11

ip route add default via y.y.y.y dev eth1.44 table 11

---------------------------------------------------------------

ip route add 192.168.0.0/23 dev eth0 src 192.168.0.50 table 10

ip route add a.a.a.a/b dev eth1.42 src 195.208.65.150 table 10

ip route add default via c.c.c.c dev eth1.42 table 10

---------------------------------------------------------------

ip rule add iif eth1.42 table 10

ip rule add fwmark 10 table 10

ip rule add iif eth1.44 table 11

ip rule add fwmark 11 table 11

---------------------------------------------------------------

Связано с кривыми настройками. Очевидно же!

Yur4eg ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.