LINUX.ORG.RU
ФорумAdmin

XEN, бриджи и MTU

 , ,


0

1

Есть физический сервант с XEN'ом.
В нём крутятся несколько виртуалок, в том числе с самбой и почтовиком. А ещё гейтвей.
В гейтвей воткнута, помимо инета, вторая сеть.
При обращении из этой самой второй сети к самбовой шаре или почтовику пакеты дропает.
Проблема решается понижением MTU на клиенте до 1492.
На соседнем физическом сервере поднят KVM, трафик на него со второй сети идёт через ксеновую виртуалку-гейтвей.
Там, в качестве эксперимента, аналогичным образом поднята шара.
К ней обращения из второй сети идут без проблем.

MTU на всех интерфейсах хостовой машины XEN'a 1500.
Внутри виртуалок тоже.
Буду благодарен за соображения, что может быть с бриджами или самим ксеном.

Спасибо за внимание,

★★★★

Ответ на: Такое же поведение от jonnyquest

Давно началось такое?

Где-то с неделю назад.
Я сначала думал что самбу криво настроил.
Вскоре аналогичным образом отвалилась почта
Произошло это после апдейта/ребута серванта с ксеном.

Yustas ★★★★ ()
Последнее исправление: Yustas (всего исправлений: 1)
Ответ на: комментарий от Yustas

Частично помогло

Уменьшил третье значение: echo «4096 87380 174760» > /proc/sys/net/ipv4/tcp_rmem

Дропы отсутствуют около часа.

А у тебя tcpdump на машине где drop'ы случайно не показывает нечто вроде:

00:01:c1:00:00:00 > 01:80:c2:00:00:01, ethertype MPCP (0x8808), length 60: MPCP, Opcode Pause, length 46

?

jonnyquest ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.