LINUX.ORG.RU

Проблема с сетью

 , ,


0

1

Подскажите, почему перестала нормально работать сеть. Конфиг следующий:

инет -- сервер -- свитч -- wifi роутер
                         |
                         |
                         --комп с виндой

На серваке две сетевых - одна смотрит в инет (100 Mbit), вторая - в локалку (1000 Mbit). Свитч гигабитный, в компе с виндой сетевая гигабитная. В чем выражается проблема? В том, что по локалке все ходит замечательно, как только обращаюсь в инет - практически ничего не открывается, как ни странно, пролазят мелкие сайты типа первой страницы гугла или ya.ru. При том, если прицепиться к вайфаю, все замечательно работает. На серваке установлена гента:
Linux watcher 3.14.4-gentoodvb #1 SMP Fri May 16 16:47:53 EEST 2014 i686 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ AuthenticAMD GNU/Linux
конфиг ядра:

http://pastebin.com/zZ6LkXYz

tcpdump на интерфейсе:

http://pastie.org/9216433

Загрузился с лайв-сд минта, думал проблема в виндовых драйверах, но нет.

На серваке естественно nat-ом выпускаются клиенты наружу. Свитч перегружал, порты менял. Проблема не в свитче - тот же вайфай маршрутизатор пропускает трафик замечательно.

★★

Проблема с MTU ?

anonymous ()

Зачем при проблеме с сетью конфиг ядра? Давай уж конфиги ната и маршрутизации. Мелкие странички случайно не из кеша открываются?

stave ★★★★★ ()
Ответ на: комментарий от anonymous
watcher fletch # ip link show|grep mtu
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT 
2: wan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT qlen 1000
3: lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT qlen 1000
6: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN mode DEFAULT qlen 100
99: ppp0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc pfifo_fast state UNKNOWN mode DEFAULT qlen 3
Fletch ★★ ()
Ответ на: комментарий от stave

параметры ната и файрвола не менял. смотреть туда смысла нету, все работало нормально до последнего времени. Раз в неделю обновляю систему и (когда приходит) ядро.

Fletch ★★ ()
Последнее исправление: Fletch (всего исправлений: 1)

сервак в инет хорошо ходит? как во время проблемы загружен канал?

andrew667 ★★★★★ ()
Ответ на: комментарий от post-factum

Помогла опция --clamp-mss-to-pmtu. Провайдер устроил классический pmtu discovery black hole. А что даст отключение tcp timestamps?

Fletch ★★ ()
Ответ на: комментарий от Fletch

Когда-то сталкивался с проблемой, очень похожую на эту:

http://serverfault.com/questions/307376/many-different-tcp-timestamps-through...

Весь офис за НАТом не мог нормально коннектиться к мейл-серверу. После отключения TCP timestamps на маршрутизаторе отпустило.

post-factum ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.