LINUX.ORG.RU

2
Всего сообщений: 71

Почему подключается к WiFi через /etc/network/interfaces ?

Доброго времени, уважаемые форумчане, почтенный аноним!

После установки Devuan (SysVinit) оказалось, что Wicd - тормознутый и не надёжный, например, на ноутбуке Lenovo X552e не включает вайфай после загрузки: приходится запускать окно wicd из Notification Area на панели Xfce4, нажимать «Включить Wifi», коннектиться, интернета все равно нет, отключаться и коннектиться опять, только тогда есть интернет.

Проблема на этом ноутбуке устраняется строкой в /etc/default/grub GRUB_CMDLINE_LINUX=«modprobe.blacklist=ideapad_laptop» (в этой модели леново как-то инициализируются два драйвера вайфая, вызывая soft-блокировку rfkill).

Но wicd всё равно медленный, приходится ждать пока он отсканирует всё ненужное и покажет нужные кнопки подключения-отключения.

Поэтому wifi настроен в /etc/network/interfaces с wpa_supplicant.

Не понимаю, почему интернет поднимается, если сервис networking не добавлен в автозагрузку??

# cat /etc/network/interfaces
auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet static
	address 192.168.1.10
	netmask 255.255.255.0
	gateway 192.168.1.1
	wpa-ssid WiFiNetMyM9
	wpa-scan-ssid 1
	wpa-proto WPA2
	wpa-key-mgmt WPA-PSK
	wpa-psk mycutepasshashlyhash


# runlevel
N 2

# ls /etc/rc2.d/
README		     S02stop-bootlogd  S04cron	   S04rmnologin  S07rc.local
S01console-setup.sh  S02sudo	       S04dbus	   S04rsync
S02acpi-fakekey      S02uuidd	       S04exim4    S05elogind
S02lvm2-lvmpolld     S04acpid	       S04hddtemp  S05slim
S02rsyslog	     S04anacron        S04ntp	   S06bootlogs

# service --status-all
 [ + ]  acpi-fakekey
 [ + ]  acpid
 [ ? ]  alsa-utils
 [ - ]  anacron
 [ + ]  apparmor
 [ - ]  bootlogd
 [ - ]  bootlogs
 [ - ]  bootmisc.sh
 [ - ]  brightness
 [ - ]  checkfs.sh
 [ - ]  checkroot-bootclean.sh
 [ - ]  checkroot.sh
 [ - ]  console-setup.sh
 [ + ]  cron
 [ ? ]  cryptdisks
 [ ? ]  cryptdisks-early
 [ + ]  dbus
 [ + ]  elogind
 [ + ]  eudev
 [ + ]  exim4
 [ - ]  hddtemp
 [ - ]  hostname.sh
 [ ? ]  hwclock.sh
 [ - ]  keyboard-setup.sh
 [ - ]  killprocs
 [ ? ]  kmod
 [ - ]  live-config
 [ - ]  live-tools
 [ - ]  lm-sensors
 [ - ]  lvm2
 [ - ]  lvm2-lvmpolld
 [ - ]  mdadm
 [ ? ]  mdadm-waitidle
 [ - ]  mountall-bootclean.sh
 [ - ]  mountall.sh
 [ - ]  mountdevsubfs.sh
 [ - ]  mountkernfs.sh
 [ - ]  mountnfs-bootclean.sh
 [ - ]  mountnfs.sh
 [ ? ]  networking
 [ + ]  nfs-common
 [ - ]  nginx
 [ + ]  ntp
 [ - ]  openvpn
 [ - ]  pcscd
 [ - ]  procps
 [ - ]  rc.local
 [ - ]  rmnologin
 [ + ]  rpcbind
 [ - ]  rsync
 [ + ]  rsyslog
 [ - ]  screen-cleanup
 [ - ]  sendsigs
 [ + ]  slim
 [ - ]  stop-bootlogd
 [ - ]  stop-bootlogd-single
 [ - ]  sudo
 [ - ]  tor
 [ - ]  umountfs
 [ - ]  umountnfs.sh
 [ - ]  umountroot
 [ - ]  urandom
 [ + ]  uuidd
 [ - ]  wicd
 [ - ]  x11-common
# 

Подскажите, почему интерфейсы поднимаются, какой сервис за это отвечает?

 , , ,

znavko ()

Два интерфейса, два повайдера.

Добрый день! Почтарь крутится на старенькой слаке. Два интерфейса, один смотрит в локалку, второй в инет. Появился второй интернет канал. Хочу что-бы был резерв. Установил третью сетевую карту прописал в конфиг адреса второго провайдера.

# /etc/rc.d/rc.inet1.conf
# Config WAN1 Interface eth0:
IPADDR[0]="11.22.33.44"
NETMASK[0]="255.255.255.248"
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""

# Config WAN2 Interface eth1:
IPADDR[2]="22.11.66.77"
NETMASK[2]="255.255.255.0"
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config LAN Interface eth2:
IPADDR[1]="192.168.1.2"
NETMASK[1]="255.255.255.0"
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Default gateway IP address:
GATEWAY="11.22.33.1"

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"

Как видно из конфига, беда в том что один общий шлюз. Как сделать так, чтобы каждый интерфейс имел свой шлюз. В идеале конечно что-бы еще каждый интерфейс имел свои ДНС настройки. А то на данный момент ДНС настройки так-же общие. Берутся из resolv.conf

 , , ,

Humaxoid ()

Ругается демон dhcpcd в Арче

Добрый вечер! Пол года не обновлял арч, и вот решил это сделать сейчас. Все прошло гладко, вот только при каждой загрузке сервис dhcpcd начал ругаться не пойми на что. Вот вывод journalctl -p 3 -xb:

авг 22 06:50:14 arch64 dhcpcd[305]: script_runreason: Connection refused
авг 22 06:50:14 arch64 dhcpcd[305]: ipv6nd_applyra: Transport endpoint is not connected
авг 22 06:50:14 arch64 dhcpcd[305]: arp_free: Transport endpoint is not connected
авг 22 06:50:14 arch64 dhcpcd[305]: script_runreason: Transport endpoint is not connected
авг 22 06:50:14 arch64 dhcpcd[305]: main: control_stop: Transport endpoint is not connected
авг 22 06:50:14 arch64 dhcpcd[305]: ps_dostop: Connection refused
авг 22 06:50:14 arch64 dhcpcd[305]: ps_dostop: Connection refused
авг 22 06:50:14 arch64 dhcpcd[305]: ps_dostop: Transport endpoint is not connected
авг 22 06:50:14 arch64 systemd[1]: Failed to start dhcpcd on all interfaces.
░░ Subject: Ошибка юнита dhcpcd.service
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ 
░░ Произошел сбой юнита dhcpcd.service.
░░ 
░░ Результат: failed.

Очень странно, но интернет работает отлично, проводной, сайты пингуются. Я понятия не имею, что это за интерфейсы «ipv6_applyra» и как они настраиваются. Эта ошибка dhcpcd тормозит загрузку системы на целых 3-4 минуты! Хотелось бы спросить у вас совета по этому поводу и пофиксить ето.

 , , ,

aleksei2000 ()

непонятки с сетевыми интерфейсами в dts на ядре 5.4

«никогда такого не было и вот опять!»
в смысле, на ядре 4.4 нижеописаная проблема не наблюдается...

в dts-файле явно написано

aliases {                                                                    
    ethernet0 = &eth0;                                                       
    ethernet1 = &eth1;                                                       
};
...

eth0: ethernet0@ff700000 {                                               
    compatible = "altr,socfpga-stmmac", "snps,dwmac-3.70a", "snps,dwmac", "synopsys,dwmac-14.0";
    altr,sysmgr-syscon = <&sysmgr 0x60 1>;                               
    reg = <0xff700000 0x2000>;
    ...
}

eth1: ethernet1@ff702000 {                                               
    compatible = "altr,socfpga-stmmac", "snps,dwmac-3.70a", "snps,dwmac", "synopsys,dwmac-14.0";
    altr,sysmgr-syscon = <&sysmgr 0x60 2>;
    reg = <0xff702000 0x2000>;
    ...
}

но в половине случаев интерфейсы путаются и получается такая фигня:
[    6.557009] socfpga-dwmac ff702000.ethernet1 eth0: PHY [stmmac-1:01] driver [Micrel KSZ9021 Gigabit PHY]
...
[    6.743780] socfpga-dwmac ff700000.ethernet0 eth1: PHY [stmmac-0:04] driver [max24287++]



поскажите, пожалуйста, как вразумить систему?
// прибегать к созданию udev-правила, наверное, было бы некошерно... :-\

[upd]:
а иногда поднимается только один интерфейс, но и он с неправильным именем:
[    6.724040] socfpga-dwmac ff700000.ethernet0 eth1: PHY [stmmac-0:04] driver [max24287++]
[    6.732881] socfpga-dwmac ff700000.ethernet0 eth1: No Safety Features support found
[    6.740793] socfpga-dwmac ff700000.ethernet0 eth1: registered PTP clock
[    6.747500] socfpga-dwmac ff700000.ethernet0 eth1: configuring for phy/rgmii-id link mode
[    6.760773] socfpga-dwmac ff700000.ethernet0 eth1: Link is Up - 100Mbps/Full - flow control off

 , , , ,

metawishmaster ()

Iptables forwarding с eth0 port 111 на tun0 port 222

Вот правило пересылки пакетов от tun0 до eth0: /sbin/iptables -A FORWARD -i eth0 -o tun0 -j ACCEPT

Не могли бы вы помочь, что мне нужно добавить к этому правилу для пересылки всех пакетов, например, из интерфейса eth0 порта 111 в интерфейс tun0 порт 222?

 , , ,

kumarradj ()

не стартует ip4 только ip6

при включения роутера и компа запускаетя только ип6. надо заново переподключать сеть из трея чтобы повяился ип4.

Раньше как то настраивал в /etc/network/interfaces
но забыл
======================================
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback



auto enp10s0
iface enp10s0 inet static
address 192.168.1.31
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
=========================================
РАБОТАЕТ ИП6

ifconfig
enp10s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet6 1111111111:e82d:0:aab0:1965:8289:e1f3 prefixlen 64 scopeid 0x0<global>
inet6 11111:e82d:0:c1c6:6998:ff2e:b844 prefixlen 64 scopeid 0x0<global>
inet6 111111111111e:4bb4:7fb3 prefixlen 64 scopeid 0x20<link>
ether 00:33333333333 txqueuelen 1000 (Ethernet)
RX packets 3026 bytes 2209538 (2.2 MB)
RX errors 0 dropped 1 overruns 0 frame 0
TX packets 3256 bytes 584525 (584.5 KB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 17

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 1000 (Локальная петля (Loopback))
RX packets 1748 bytes 152932 (152.9 KB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 1748 bytes 152932 (152.9 KB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
==========================
переподключение работает ип6 ип4

enp10s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.1.31 netmask 255.255.255.0 broadcast 192.168.1.255
inet6 13221312
inet6 f123123123126998:ff2e:b844 prefixlen 64 scopeid 0x0<global>
inet6 12312324:7fb3 prefixlen 64 scopeid 0x20<link>
inet6 1231233:c1c6:6998:ff2e:b844 prefixlen 64 scopeid 0x0<global>
inet6 1231231231237e:251b:382a:e64c prefixlen 64 scopeid 0x0<global>
ether 00:223:22:c3:e5:02 txqueuelen 1000 (Ethernet)
RX packets 6940 bytes 7202328 (7.2 MB)
RX errors 0 dropped 1 overruns 0 frame 0
TX packets 5926 bytes 901742 (901.7 KB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 17

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 1000 (Локальная петля (Loopback))
RX packets 2354 bytes 206178 (206.1 KB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 2354 bytes 206178 (206.1 KB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

 

Talnah ()

Сетевуха включается/выключается сама по себе

На домашнем сервачке под управлением debian 9 работает minidlna, transmission, ну и пара сайтиков на рельсах для личного использования. По непонятным причинам сетевуха выключается, затем сама включается и т.д. В логах нашел:

Dec  9 10:16:58 server kernel: [38681.271913] r8169 0000:01:00.0 enp1s0: link down
Dec  9 10:17:00 server kernel: [38683.491904] r8169 0000:01:00.0 enp1s0: link up
Dec 10 23:15:53 server kernel: [171813.721318] r8169 0000:01:00.0 enp1s0: link down
Dec 10 23:15:55 server kernel: [171815.960916] r8169 0000:01:00.0 enp1s0: link up
Dec 10 23:15:56 server kernel: [171816.762148] r8169 0000:01:00.0 enp1s0: link down
Dec 10 23:15:58 server kernel: [171819.012221] r8169 0000:01:00.0 enp1s0: link up
Dec 10 23:17:44 server kernel: [171925.200097] r8169 0000:01:00.0 enp1s0: link down
Dec 10 23:17:47 server kernel: [171927.538255] r8169 0000:01:00.0 enp1s0: link up
Dec 10 23:31:58 server kernel: [172778.384806] r8169 0000:01:00.0 enp1s0: link down
Dec 10 23:32:00 server kernel: [172780.598695] r8169 0000:01:00.0 enp1s0: link up
Dec 10 23:32:01 server kernel: [172781.773747] r8169 0000:01:00.0 enp1s0: link down
Dec 10 23:32:03 server kernel: [172784.008100] r8169 0000:01:00.0 enp1s0: link up
Dec 10 23:32:12 server kernel: [172792.586515] r8169 0000:01:00.0 enp1s0: link down
Dec 10 23:32:14 server kernel: [172794.822961] r8169 0000:01:00.0 enp1s0: link up
Dec 10 23:32:15 server kernel: [172796.260644] r8169 0000:01:00.0 enp1s0: link down
Dec 10 23:32:18 server kernel: [172798.490310] r8169 0000:01:00.0 enp1s0: link up
Dec 11 09:56:49 server kernel: [210268.541493] r8169 0000:01:00.0 enp1s0: link down
Dec 11 09:56:57 server kernel: [210276.970128] r8169 0000:01:00.0 enp1s0: link up
Dec 11 09:56:58 server kernel: [210278.012069] r8169 0000:01:00.0 enp1s0: link down
Dec 11 09:57:00 server kernel: [210280.249588] r8169 0000:01:00.0 enp1s0: link up

Подскажите, такое поведение сетевухи исправить возможно?

 ,

sugresmax ()

ProxMox web

Установил ProxMox посмотрел (зашёл в web) все работает , радостный пошёл мороженку кушать.

Прихожу утром , искра - паника - безумие а веб то отвалился (захожу https://ip:8006) и ничего , и тут я набрал полную грудь воздуха и сделал service pveproxy restart но не помогло.

Покопал и наткнулся на тему promox, web интерфейс не открывается и там советуют вот такую штуку.

в /etc/apt/sources.list

добавил deb http://download.proxmox.com/debian/pve stretch pve-no-subscription

и потом сделать #apt update && apt dist-upgrade #service pveproxy restart.

Вопрос вот в чем ,бутнится ли proxmox после этого. Потому-что именно в данный момент это очень не желательно.

 , ,

Sharc ()

Debian 10 дублирует ip на 2 интерфейса

Привет. Поставил на чистую систему Debian 10. 2 интерфейса.

В interfaces оба прописаны статикой, один внешний, второй внутренний

Aug 22 01:29:49 kevin dhcpcd[501]: enp2s0: carrier acquired
Aug 22 01:29:49 kevin dhcpcd[501]: enp2s0: IAID 91:a2:4c:4a
Aug 22 01:29:49 kevin dhcpcd[501]: enp2s0: adding address fe80::e2ef:a259:4b26:2a2e
Aug 22 01:29:50 kevin dhcpcd[501]: enp2s0: rebinding lease of 93.95.160.222
Aug 22 01:29:50 kevin dhcpcd[501]: enp2s0: leased 93.95.160.222 for 36000 seconds
Aug 22 01:29:50 kevin dhcpcd[501]: enp2s0: adding route to 93.95.160.0/24
Aug 22 01:29:50 kevin dhcpcd[501]: enp2s0: adding default route via 93.95.160.1

и тут же

Aug 22 01:29:54 kevin dhcpcd[501]: enx109add4391d4: using static address 93.95.160.222/24
Aug 22 01:29:54 kevin dhcpcd[501]: enx109add4391d4: adding route to 93.95.160.0/24
Aug 22 01:29:54 kevin dhcpcd[501]: enx109add4391d4: adding default route via 93.95.160.1

Хотя на второй 192,168,1,1 стаикой прописано

dhcpd стоит тут же

Вот совсем игнорирует intefaces

И как-то странно rename работает в interfaces

 , ,

kevin2 ()

Отключить добавление маршрута на одном интерфейсе

Уважаемые GURU, подскажите плиз! Есть 2 интерфейса eth0 eth1, дефаулт роут идет через eth1. Оба интерфейса имеют разные адреса одной сети. При этом маршруты выглядят следующим образом:

1) 0.0.0.0 ... eth1

2) 192.168.0.0 ... eth0

3) 192.168.0.0 ... eth1

При этом 2 и 3 иногда меняются местами. Мне 2-й маршрут мешает, и конечно я его удаляю и все ок, но возможно ли отключить добавление этого маршрута именно для eth0?

P.S. Отключать интерфейс мне нельзя.

 , ,

Vasya23 ()

ubuntu игнорирует настройки dns

Приветствую. Мне нужно прописать гугловские сервера вместо провайдерских. В настройках network-manager стоит «DHCP adresess only» и ДНС-сервера гугла. Пробовал вставить в /etc/network/interfaces

auto enp9s0
iface enp9s0 inet dhcp
dns-nameservers 8.8.8.8

Толку нет.

 , ,

qx255 ()

Debian как свитч.

Доброго времени суток. Хочу сделать из Debian - свитч. Поставил две сетевые карты по 4 порта. Ситуация следующая: На интерфейс eth0 приходит LAN от маршрутизатора,интерфейс настроен как DHCP-client. На маршрутизаторе что подключен к eth0 стоит DHCP-Server. Нужно чтобы хосты, которые подключены к сетевухам Debian (enp1s0f0-enp1s0f3;enp3s0f0-enp3s0f3) также как и eth0 были в одной сети - DHCP-клиентами для роутера. Создал один бридж на все интерфейсы, но не помогло. Прошу помощи, и не кидатся тапками. Буду крайне благодарен.

 , , ,

tech_cerberus ()

Всё пингуется только при одном варианте шлюза

Изначально установщик преднастраивает интерфейс делая его динамическим (dhcp), я же пытаюсь сделать его статическим с некоторым ip (к примеру, 192.168.1.100), но ничего не выходит. Всё перелазил, ничего не помогало. Решил глянуть настройки, которые устанавливает dhcp и установил их в статическом (разве что IP-адрес хоста поменял) - и ура, всё заработало. Рабочий вариант:

auto enp0s3
iface enp0s3 inet static
address 10.0.2.x
netmask 255.255.255.0
gateway 10.0.2.2
Как пытаюсь сделать я:
auto enp0s3
iface enp0s3 inet static
address 192.168.1.100
netmask 255.255.255.0
gateway 192.168.1.1
При моём варианте у меня абсолютно ничего не пингуется, кроме самого хоста (насколько я понимаю, должен пинговаться хотя бы шлюз, но и он не пингуется). При попытках пинговать ничего не происходит, он просто начинает долго думать. Помогите, может нужно в каких-то других файлах что-то подправить или здесь что-то не то, сам я уже не знаю

 , ,

nedovolniiy ()

сенсоры, датчики...

Тут такое дело. Попала под крыло маленькая лаборатория. Есть повод многое автоматизировать. Но вот направление по датчикам, сенсорам и т.д. прошло мимо меня.

Где что почитать на эту тему?

Есть истории успеха? Что применяли? (железки, программы)

Хотелось снимать данные и манипулировать с помощью linux, провести webcam и удалённо что-то включать-выключать (именно, on/off), получать данные с сенсоров (температура, кол-во чего-то и т.д.).

P.S. Cast RTP

 , , ,

Deleted ()

Изменить имя интерфейса eth

Всем привет! Появилась потребность изменить интерфейсы в системе. МСВС 5.0. Раньше интерфейсы определялись по-порядку eth0,1,2,3. Теперь они определяются, как eth3,2,0,1. Думали сделать привязку ip к MAC и MAC к eth. В файл с конфой интерфейса добавляем строку:

mcedit etc/sysconfig/network-scripts/ifcfg-eth0
MACADDR=A0:36:9F:A2:75:16
с соответствующим MAC-адресом интерфейса.

И создаем UDEV-правило:

mcedit /etc/udev/rules.d/70-persistent-net.rules:
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="A0:36:9F:A2:75:16", ATTR{type}=="1", KERNEL=="eth*", NAME="eth3"
Но после перезагрузки ничего не происходит интерфейс не меняется с eth0 на eth3. Что я делаю ни так?

 , , , ,

Rayman24 ()

Скрип добавления маршрутов конфликтует с DHCP

Народ сильно не пинайте все мы когда-то были новичками!

Что имею. Поднятый SoftEther VPN

Что хочу Получать адрес по DHCP и чтобы при загрузке ОС добавлялись автоматически маршруты. Руками настраивать маршруты при каждой загрузке надоедает.

Мои настройки: /etc/network/interfaces

auto-hotplug vpn_se iface vpn_se inet dhcp

Пытался настроить маршруты через директорию /etc/network/ с поддиректорией if-up.d, тогда при перезагрузке ОС настраиваются маршруты из скрипта автоматически, а dhcp не выдает автоматом адрес.

Буду очень признателен за помощь

 , , , ,

Zemb ()

raise network interfaces

День добрый!
Есть сервер на debian 8. При старте и выключении системы очень долго происходит старт и остановка сетевых интерфейсов.
С такой бородой:
raise network interfaces ну и тут таймер бежит.
Раньше меня это не сильно напрягало, когда было всего несколько интерфейсов. Но завел уже порядка сотни vlan и этот процесс хоть и редкий, но реально затягивается надолго. Можно это как-то по уму решить, без костылей в виде правок таймаутов в systemd?

 ,

lasthappy ()

Сыплются дубы.

Добрый вечер. Суть такова. было две карточки. pci pci. первая pci сдохла.
ок, взял, выдернул её, поставил вместо неё pcie. пытаюсь зайти на вторую(ранее стоявшую pci), сыпется:
64 bytes from 192.168.12.10: icmp_seq=0 ttl=64 time=1134,372 ms (DUP!)
64 bytes from 192.168.12.10: icmp_seq=0 ttl=64 time=1134,425 ms (DUP!)
64 bytes from 192.168.12.10: icmp_seq=0 ttl=64 time=1134,626 ms (DUP!)
64 bytes from 192.168.12.10: icmp_seq=0 ttl=64 time=1134,820 ms (DUP!)
64 bytes from 192.168.12.10: icmp_seq=0 ttl=64 time=1134,983 ms (DUP!)
64 bytes from 192.168.12.10: icmp_seq=0 ttl=64 time=1135,180 ms (DUP!)
64 bytes from 192.168.12.10: icmp_seq=0 ttl=64 time=1135,343 ms (DUP!)
64 bytes from 192.168.12.10: icmp_seq=0 ttl=64 time=1135,541 ms (DUP!)
64 bytes from 192.168.12.10: icmp_seq=0 ttl=64 time=1135,741 ms (DUP!)
64 bytes from 192.168.12.10: icmp_seq=0 ttl=64 time=1135,899 ms (DUP!)
64 bytes from 192.168.12.10: icmp_seq=6 ttl=64 time=734,161 ms


есть подозрение, что systemd взял и обозвал сетевой интерфейс pcie-карточки так, что он совпал с второй(работающей).

есть идеи?

 , ,

darkenshvein ()

лайв сиди

доброго времени суток , нужно создать лайв сиди со сконфигурированной сетью , собирал его многими вариантами , в тч и через debootstrap + chroot и т д, так вот , как бы я его не собирал , как бы я не настраивал внутри сеть (нетворк менеджер , баш скрипты и многое другое) но все долой , после загрузки лайв сиди я вижу пересозданный файл /etc/network/interfaces , пробовал делать службу для сети систем ди , так же пробовал в rc5** закидывать настройки , даже если и удается перезаписать файл настройки интерфейсов сеть не поднимается , по сути нужно сделать лайв сиди в котором настроен pxe сервер , что не так я делаю не пойму,у кого есть советы ? зарание спасибо!!!!

 , , ,

echo_ ()

Слетают настройки сети

Доброго времени суток , собрал свой лайв сиди дебиан , сделал много настроек , осталась одна , нужно как то заставить его конфигурировать сеть , вот что должно быть в /etc/network/interfaces :

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto enp0s3
iface enp0s3 inet dhcp
auto enp0s8
iface enp0s8 inet static
address 192.168.0.1
netmask 255.255.255.0

добавляю . собираю образ и т д , в итоге после запуска получаю конфиг где есть только
auto lo
iface lo inet loopback
пытался даже каким то скриптом в автозапуск подпихнуть...не пашет...и еще момент , чисто для теста создал возле файла interfaces файл interfaces.new , добавил в него нужные данные и в нем все сохранилось , в итоге как я понял что система его перезаписывает(/etc/network/interfaces), как исправить такую проблему , кто вкурсе? зарание спасибо!!

 ,

echo_ ()