LINUX.ORG.RU

Новый драйвер от ATi


0

0

В международный женский день, компания ATi осчастливила всех владельцев видеокарт на её чипах, выпустив новый драйвер для ОС Linux.

Основные изменения:

1. Поддержка новых карт на чипах серии X800/X850 для AGP.

2. Улучшение\Расширение интерфейса OpenGL 2.0 (поддержка расширения Wrangler (GLEW) Library).

3. Поддержка полноэкранного сглаживания (FSAA) для карт на чипах Radeon 9500 и выше (включается через aticonfig).

Качаем как обычно.

>>> Подробности

Ответ на: Re: Новый драйвер от ATi от WFrag

Re: Новый драйвер от ATi

> Конфиги показать? Что ты мне сказки рассказываешь. В отличие от твоих слов обе мои машины вполне материальны.

А ну давай начинай. SATA контроллер jmicron jmb360. Давай конфиги. И заодно расскажи, когда твой ляликс NCQ начнёт поодерживать на чём-то, отличном от Intel.

lenin ()
Ответ на: Re: Новый драйвер от ATi от lenin

Re: Новый драйвер от ATi

> Конечно же недостаток. А какой разумный человек будет работать с ОС, в которой драйвера АТИ не работают ?

а WoW каким боком относится к "работать с ОС" ? =)

geek ★★★ ()
Ответ на: Re: Новый драйвер от ATi от lenin

Re: Новый драйвер от ATi

А почему дров для ляликс нет ? А потому что ядро постоянно ломают и ни у кого нет силд поддерживать всё это. Даже сами пингвины поломали ряд дров. Что работало в 2.4.20 и поломали в 2.4.21 - не работает и сейчас. Пример - софтверный RAID Promice PDC20267.

lenin ()
Ответ на: Re: Новый драйвер от ATi от lenin

Re: Новый драйвер от ATi

>А ну давай начинай. SATA контроллер jmicron jmb360. Давай конфиги. И заодно расскажи, когда твой ляликс NCQ начнёт поодерживать на чём-то, отличном от Intel.

Причем тут это? Я сказал, что У МЕНЯ все работает. Ты сказал, что я тебе сказки рассказываю. Я предложил показать СВОИ конфиги.

Пойми, я НЕ утверждаю, что Linux работает на ВСЕМ современном железе, я лишь указал, что твое обобщение, что Linux не работает на современном железе ВООБЩЕ - некорректно.

>SATA контроллер jmicron jmb360.

Оно? http://www.ussg.iu.edu/hypermail/linux/kernel/0601.3/1665.html

WFrag ★★★★ ()
Ответ на: Re: Новый драйвер от ATi от lenin

Re: Новый драйвер от ATi

Потому что всякие уроды спеки не дают. Скажите мне, что секретного в спеках к SDHCI (http://mmc.drzeus.cx/wiki/Linux/Drivers/sdhci)? Ан нет, пришлось ребятам трудолюбиво реверс-инженирить виндовые драйвера...

Если не работает - пиши баги, прояви интерес, помоги патчами в конце-концов. Не хочешь этого делать - до свидания, тебя на Linux никто не держит.

WFrag ★★★★ ()
Ответ на: Re: Новый драйвер от ATi от WFrag

Re: Новый драйвер от ATi

> Причем тут это? Я сказал, что У МЕНЯ все работает.

А МНЕ это пофик. Если для вас новое железо - это то, что совсем недавно с памойки принесли - это ваши проблемы и трудности. Реально новое железо на Linux не работает.

lenin ()
Ответ на: Re: Новый драйвер от ATi от lenin

Re: Новый драйвер от ATi

>А потому что ядро постоянно ломают и ни у кого нет силд поддерживать всё это

ага. а в nvidia работают титаны программирования. Наверное, разделение драйвера на бинарник и интерфейс к ядру - это что-то непостижимое для остальных железячников.

geek ★★★ ()
Ответ на: Re: Новый драйвер от ATi от WFrag

Re: Новый драйвер от ATi

> Потому что всякие уроды спеки не дают.

Потому что это такая практика сейчас. Так делают почти все. И я это не поддерживаю, но что делать ? Так сейчас заведено. Любая железка - программно-аппратный комплекс. Поддержка имеет дело и с железом и с ПО, а кому надо поддеживать непонятно кем писаное глюкло ? А почему не пишутся дравера от производителя - см. выше.

lenin ()
Ответ на: Re: Новый драйвер от ATi от lenin

Re: Новый драйвер от ATi

>А МНЕ это пофик.

Да, но ты сказал, что не работает ВСЕ новое железо. Ты нагнал.

>Если для вас новое железо - это то, что совсем недавно с памойки принесли - это ваши проблемы и трудности. Реально новое железо на Linux не работает.

Ноут V6F00VA - это старье с помойки, по-твоему?

Год назад я брал ECS A-939 (NForce4)/AMD64 3200+/NVidia GeForce 6600GT. Это тоже с помойки?

Ты лоханулся, дружок. Не работает конкретно ТВОЕ новое железо, не надо обобщать и увиливать, называя все остальное железо старым и с помойки.

WFrag ★★★★ ()
Ответ на: Re: Новый драйвер от ATi от geek

Re: Новый драйвер от ATi

> а в nvidia работают титаны программирования.

Кто-то имеет средства на PR акции, кто-то не имеет. Кто-то пиарится заказными статейками, кто-то драйверами для ляликса. Посмотрите на весь остальной мир - никто не может нормально поддерживать ляликс. Это невозможно.

lenin ()
Ответ на: Re: Новый драйвер от ATi от WFrag

Re: Новый драйвер от ATi

> Если не работает - пиши баги,

Пишу баги. Реакция - в среднем полгода. За это время закупается другое железо (старьё с помоек, чесслово), а купить новое, бывшее проблемное уже никого убедить невозможно.

lenin ()
Ответ на: Re: Новый драйвер от ATi от WFrag

Re: Новый драйвер от ATi

> Не работает твое железо - не используй Linux.

Была бы моя воля, за использования линукса отрезал бы яички. Щютка. Приходится работать и использовать Линукс.

lenin ()
Ответ на: Re: Новый драйвер от ATi от lenin

Re: Новый драйвер от ATi

Исходники модуля ядра - 7000 строк, 200Кб. Смешно, ей богу. Остальная часть (объектник) от ядра, по-видимому, не зависит (или очень слабо зависит), т.к все это хозяйство собирается под разные версии ядер.

WFrag ★★★★ ()
Ответ на: Re: Новый драйвер от ATi от WFrag

Re: Новый драйвер от ATi

> т.к все это хозяйство собирается под разные версии ядер.

А скока их, этих ядер-то ? Охренеешь, сколько их разных. Да ещё прибавь сюда всякие федоровы-пропатченые-посамое-немогу сборки. И с этим поддержке приходится дело иметь. В этих 7000 строк может столько работы содержаться, что никому мало не покажется.

lenin ()
Ответ на: Re: Новый драйвер от ATi от lenin

Re: Новый драйвер от ATi

Зачем гадать? Загляни и увидишь, что ничего сверествественного там нет. Да и само число говорит само за себя. 7000 строк это довольно маленький код. Буквально пара разработчиков.

WFrag ★★★★ ()
Ответ на: Re: Новый драйвер от ATi от lenin

Re: Новый драйвер от ATi

>И с этим поддержке приходится дело иметь.

быдлоконторы, ниасилившие написание дров под линукс могут просто открыть спецификации на железку.

geek ★★★ ()
Ответ на: Re: Новый драйвер от ATi от lenin

Re: Новый драйвер от ATi

> Посмотрите на весь остальной мир - никто не может нормально поддерживать ляликс. Это невозможно.

Так и запишем: слив защитан

anonymous ()
Ответ на: Re: Новый драйвер от ATi от geek

Re: Новый драйвер от ATi

> быдлоконторы, ниасилившие написание дров под линукс могут просто открыть спецификации на железку.

Ага. Ну-ну. С таким подходом, други, нормальных дров у вас не будет НИКОГДА. Нормальные люди делают всё для программиста, а ляликсоииды занимаются говнометанием. Ну и сидите без дров, умники хреновы. Хаааа.

lenin ()
Ответ на: Re: Новый драйвер от ATi от lenin

Re: Новый драйвер от ATi

> Ага. Ну-ну. С таким подходом, други, нормальных дров у вас не будет НИКОГДА.

лёнин, иди в жопу. Всё у нас есть и работает.

>Нормальные люди делают всё для программиста

пример "нормальных людей" в студию

geek ★★★ ()
Ответ на: Re: Новый драйвер от ATi от anonymous

Re: Новый драйвер от ATi

> А пока что от одного из тестеров Виста, американца, студента MIT, слышен только мат по поводу это глючного говна, которое от ХП ничем не отличается:)

А чем тебе XP на десктопе не угодил? Работает годами, не глючит, любой софт на выбор. У тебя, наверное, руки кривые, под ху^H^Hлинунух заточены, а у нормальных админов проблем нет.

anonymous ()
Ответ на: Re: Новый драйвер от ATi от lenin

Re: Новый драйвер от ATi

Веришь-нет, но лично этот человек для программиста не делает ничего. :)

Линус вон, добрая душа, даже исходники всем раздает :)

WFrag ★★★★ ()
Ответ на: Re: Новый драйвер от ATi от lenin

Re: Новый драйвер от ATi

> Ага, оно и видно. Особенно, есть и отлично работают драйвера АТИ.

ати и под твоим любимым виндовсом через жопу работают

>http://www.microsoft.com/billgates/

ты дебил? или ты всерьез считаешь, что билли пишет драйвера для виндовса?

geek ★★★ ()
Ответ на: Re: Новый драйвер от ATi от geek

Re: Новый драйвер от ATi

> ати и под твоим любимым виндовсом через жопу работают

Я хоть и не тот с кем ты разговариваешь, но поигрываю, бывает, в винде на 9600XT, брат во многое на машине игал, проблем нет. Поэтому может быть не нужно говорить о том, чего не знаешь ok?

anonymous ()
Ответ на: Re: Новый драйвер от ATi от anonymous

Re: Новый драйвер от ATi

>Поэтому может быть не нужно говорить о том, чего не знаешь ok?

когда я говорю о том чего не знаю - я молчу. ок? =)

geek ★★★ ()
Ответ на: Re: Новый драйвер от ATi от WFrag

Re: Новый драйвер от ATi

> Веришь-нет, но лично этот человек для программиста не делает ничего. :)

Лично он сделал интерфейс для драйверов, благодаряря которому даже некоторые драйвера от Windows NT 4.0 работают на Windows XP сейчас.

> Линус вон, добрая душа, даже исходники всем раздает :)

Кому нафик его исходники нужны. Их никто никогда не смотрел.

lenin ()
Ответ на: Re: Новый драйвер от ATi от const86

Re: Новый драйвер от ATi

> Вот когда виста выйдет да когда вопрос встанет, тогда-то и посмотрим. А сегодня разговоры о доминировании линукса на десктопе смахивают на взгляд через безнадёжно розовые очки.

Как там "сначала они тебя не замечают, затем игнорируют, затем высмеивают, затем вступают в борьбу и проигрывают". Последняя стадия скоро наступит. Ведь не так давно смеялись над корпоративным линуксом и вот он - получайте RHEL/SLES; никто не мог предположить, что линукс может тягаться с серьезными коммерческими UNIX-ами, которые сейчас почти все убиты линуксом; 1С под линукс считался фантастикой и вот он уже ходит и под вайн, а восьмерка будет нативной; считали Linux на десктопе такой же фантастикой - IBM переходит, в Германии SuSE очень популярен, SuSe давно уже предложила полноценную замену винды на десктопе... Через пару лет Linux может занимать до половины рынка десктопов, дальше - больше. Вспомнить NT 4.0 - запустить на ней игрушки было весьма сложно, она требовала в два раза больший объем ОЗУ для комфортной работы чем 9x, тем не менее из нее выросла дестопная мейнстрим ОС WinXP. Под Linux пока тоже ходят не все игрушки и OO с KDE работают медленней чем WinGUI и MSO, ноэто только пока... ничто не мешает линуксу повторить путь NT4.0->XP.

anonymous ()
Ответ на: Re: Новый драйвер от ATi от lenin

Re: Новый драйвер от ATi

>На виндах работает всё. Что не работает на виндах, то не работает нигде.

не надо гнать... на win2003 не работает maudio delta 10/10 к примеру, хорошо вовремя заметили...

PavelAnd ()
Ответ на: Re: Новый драйвер от ATi от lenin

Re: Новый драйвер от ATi

>Лично он сделал интерфейс для драйверов, благодаряря которому даже некоторые драйвера от Windows NT 4.0 работают на Windows XP сейчас.

Лично я не думаю, что лично он это сделал. :)

>Кому нафик его исходники нужны. Их никто никогда не смотрел.

Ну как же. Я вот лично добавил поддержку ACPI-ем своего ноута в ядро. Теперь у меня можно рулить всеми тремя LED-лампочками на клавиатуре (Bluetooth, Wi-Fi, Touchpad). :)

Без правки работала только Wi-Fi лампочка, так как модель не распознавалась и выбиралась дефолтная.

WFrag ★★★★ ()
Ответ на: Re: Новый драйвер от ATi от lenin

Re: Новый драйвер от ATi

>Лично он сделал интерфейс для драйверов, благодаряря которому даже некоторые драйвера от Windows NT 4.0 работают на Windows XP сейчас.

некоторые? тогда что ты тут плачешься, что ABI в ядре линуха меняется? Убей себя как можно скорее

geek ★★★ ()
Ответ на: Re: Новый драйвер от ATi от lenin

Re: Новый драйвер от ATi

>На виндах работает всё. Что не работает на виндах, то не работает нигде.

Ленин, упей себя ап стену. запусти не венде плиз iPhoto, iWeb и тд ) фсе у него работает...сказочник. а особбено хотелось бы посмотреть как на венде будет работать dashboard :)

bugzilla ()
Ответ на: Re: Новый драйвер от ATi от lenin

Re: Новый драйвер от ATi

>На виндах работает всё. Что не работает на виндах, то не работает нигде.

Я пацтулом! =8-D

MYMUR ★★★★ ()
Ответ на: Re: Новый драйвер от ATi от aknn

Re: Новый драйвер от ATi

(II) LoadModule: "fglrx" (II) Loading /usr/X11R6/lib/modules/drivers/fglrx_drv.so dlopen: /usr/X11R6/lib/modules/drivers/fglrx_drv.so: undefined symbol: __glXActiveScreens (EE) Failed to load /usr/X11R6/lib/modules/drivers/fglrx_drv.so (II) UnloadModule: "fglrx" (EE) Failed to load module "fglrx" (loader failed, 7)

что оно хочет?

anonymous ()
Ответ на: Re: Новый драйвер от ATi от anonymous

Re: Новый драйвер от ATi

> Вот у меня Radeon X700 в портах FreeBSD xorg-6.9 держит ее но только 2d only. Хотелось бы знать изменилось ли что либо?

Кому-то нужна фря на десктопе да еще и с 3D? А как насчет воплей "фря не для этого"? Странно если она для сервера, то почему я не вижу ни одного FreeBSD Enterprise Server, Oracle for FreeBSD, LVM, FreeBSD кластеров из списка top500.org? В топку такое.

anonymous ()
Ответ на: Re: Новый драйвер от ATi от lenin

Re: Новый драйвер от ATi

>Под венду работает всё ЖЕЛЕЗО, за исключением крайне специфичного.

Какое ж оно на .уй специфичное - звуковая карта с 10 in /10 out

причём на 2000 пашет, а на 2003 - нет

PavelAnd ()
Ответ на: Re: Новый драйвер от ATi от lenin

Re: Новый драйвер от ATi

> А что, пад ляликсом это работаить ?

Под линуксом работает SPARC, PowerPC, ... А под виндоус? Как замечательно обстоят дела с дрова под Windows XP64 - все есть, все работают?

anonymous ()
Ответ на: Re: Новый драйвер от ATi от lenin

Re: Новый драйвер от ATi

>Под венду работает всё ЖЕЛЕЗО, за исключением крайне специфичного.

Да взять к примеру, мою клаву...очень будет любопытно как венда асилит F13...f15...и кучу других кнопок, а в линухе пожалуйста....назначай как хочешь. Насчет топега, АТИ к радости или сожалению, нормально работает только на Маках...вот хз почему. Я конечно понимаю, что ты слепо веришь в голубое светлое будущее (намек на цвета МС)....но не которые железки (которые работают только под вендой) лучше бы индустрия ваабще бы никогда не производила на свет, это же и касается ATI.

bugzilla ()

Re: Новый драйвер от ATi

Чо-то вы фигню какую-то обсуждаете, лучше расскажите, как заставиьт собраться AGPGART, а то при установке последних дров (8.23.7) на ядро 2.6.15 не может скомпилиться AGPGART. Для предыдущей версии дров был патч, который это исправлял, а для этой версии что-то не могу найти. Или у всех всё компилится?

YOjick ()
Ответ на: Re: Новый драйвер от ATi от anonymous

Re: Новый драйвер от ATi

> Как замечательно обстоят дела с дрова под Windows XP64 - все есть, все работают?

MS не пишет драйвера. Если бы она взялась писать драйвера, ей мгновенно пришлось бы заниматься реверс-инжинирингом. Для корпорации, а не для пинераф, это непозволительно никак. Потому что такая вот мода сейчас не давать спеки. Это плохо, но такова ситуация и бороться с этим не может даже МС. Но МС не препятсвует написанию драйверов. Интерфейс меняется дай Бог раз в пять лет. А линуксоиды режут всё ежемесячно. Почусвуйте разницу.

> Под линуксом работает SPARC, PowerPC,

Да, ядро загружается. А вот теже драйвера АТИ, те, что свободные, про дрова от АТИ вообще молчу, никак-с.

lenin ()
Ответ на: Re: Новый драйвер от ATi от lenin

Re: Новый драйвер от ATi

>> лёнин, иди в жопу. Всё у нас есть и работает. >Ага, оно и видно. Особенно, есть и отлично работают драйвера АТИ.

lenin. АТИ дрова под винду не прямее линуксовых.

samy_volosaty ★★★★★ ()
Ответ на: Re: Новый драйвер от ATi от lenin

Re: Новый драйвер от ATi

>Что за карта ?

M Audio Delta 1010
www.midiman.com - производитель
нужна не для п...жа, а под конкретный проект 
15 одновременных каналов вывода 

PavelAnd ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.