LINUX.ORG.RU

Jitsi CORS | Nginx вываливается в 405 на постах

 , , , ,


0

1

Такие дела: везде где только можно в конфиге нгинкса написано:

add_header ‘Access-Control-Allow-Origin’ ‘https://domain’;
add_header ‘Access-Control-Allow-Credentials’ ‘true’;
add_header ‘Access-Control-Allow-Methods’ ‘GET,HEAD,OPTIONS,POST,PUT’;
add_header ‘Access-Control-Allow-Headers’ ‘Authorization,Content-Type,Accept,Origin,User-Agent,DNT,Cache-Control,X-Mx-ReqToken,Keep-Alive,X-Requested-With,If-Modified-Since,Access-Control-Request-Method,Access-Control-Request-Headers’;

И в сервере и в каждой локации.

На гет запросах всё норм, но к пост запросам корс хедеры не добавляются.
В результате получаем:

Access to XMLHttpRequest at ‘jitsi’ from origin ‘domain’ has been blocked by CORS policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource.

А как их добавить-то?

Гуглирование бесполезно, т.к. на всех говносайтах интернета обязательно где-нибудь засунута кнопка с надписью «post new comment» и фильтровать это говно гугль не умеет.

★★★★★

покажи конфиг, скорее всего не наследуется add_header в нужном месте.

вот так все работает збс:

server {
#...

    error_page 451 = @cors;
    if ($request_method = OPTIONS) {
        return 451;
    }

    location @cors {
        internal;
        add_header Access-Control-Allow-Origin *;
        add_header Access-Control-Max-Age 600;
        add_header Access-Control-Allow-Methods 'GET, POST, OPTIONS';
        add_header Access-Control-Allow-Headers 'Authorization, Content-Type, Origin, X-Requested-With, X-Captcha, X-TFA-Code';
        return 204;
    }

    add_header Access-Control-Allow-Origin * always;
    add_header Access-Control-Expose-Headers 'Date';

    proxy_set_header Host $host;
    proxy_set_header X-Real-IP $remote_addr;
    proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
    proxy_set_header X-Forwarded-Proto $scheme;

    location /api/info/ {
        proxy_pass http://localhost:8080;
    }
#...
}
drsm ★★ ()
Ответ на: комментарий от drsm

Было:

    add_header 'Access-Control-Allow-Origin' 'https://origin.domain';
    add_header 'Access-Control-Allow-Credentials' 'true';
    add_header 'Access-Control-Allow-Methods' 'GET,HEAD,OPTIONS,POST,PUT';
    add_header 'Access-Control-Allow-Headers' 'Authorization,Content-Type,Accept,Origin,User-Agent,DNT,Cache-Control,X-Mx-ReqToken,Keep-Alive,X-Requested-With,If-Modified-Since,Access-Control-Request-Method,Access-Control-Request-Headers';

Стало:

server {
    listen 80;
    listen [::]:80;
    server_name the.domain;

    location ^~ /.well-known/acme-challenge/ {
       default_type "text/plain";
       root         /usr/share/jitsi-meet;
    }
    location = /.well-known/acme-challenge/ {
       return 404;
    }
    location / {
       return 301 https://$host$request_uri;
    }
}
server {
    listen 443 ssl;
    listen [::]:443 ssl;
    server_name the.domain;

# Mozilla Guideline v5.4, nginx 1.17.7, OpenSSL 1.1.1d, intermediate configuration
    ssl_prefer_server_ciphers off;

    ssl_session_timeout 1d;
#    ssl_session_cache shared:SSL:10m;  # about 40000 sessions
    ssl_session_tickets off;

    add_header Strict-Transport-Security "max-age=63072000" always;

    ssl_certificate /etc/ssl/private/the.domain.pem;
    ssl_certificate_key /etc/ssl/private/the.domain.key;

    root /usr/share/jitsi-meet;

    # ssi on with javascript for multidomain variables in config.js
    ssi on;
    ssi_types application/x-javascript application/javascript;

    index index.html index.htm;
    error_page 404 /static/404.html;

    gzip on;
    gzip_types text/plain text/css application/javascript application/json image/x-icon application/octet-stream application/wasm;
    gzip_vary on;
    gzip_proxied no-cache no-store private expired auth;
    gzip_min_length 512;

    add_header 'Access-Control-Allow-Origin' 'https://origin.domain' always;
    add_header 'Access-Control-Allow-Credentials' 'true' always;
    add_header 'Access-Control-Allow-Methods' 'GET,HEAD,OPTIONS,POST,PUT' always;
    add_header 'Access-Control-Allow-Headers' 'Authorization,Content-Type,Accept,Origin,User-Agent,DNT,Cache-Control,X-Mx-ReqToken,Keep-Alive,X-Requested-With,If-Modified-Since,Access-Control-Request-Method,Access-Control-Request-Headers' always;

    location = /config.js {
        alias /etc/jitsi/meet/the.domain-config.js;
    }

    location = /external_api.js {
        alias /usr/share/jitsi-meet/libs/external_api.min.js;
    }

    #ensure all static content can always be found first
    location ~ ^/(libs|css|static|images|fonts|lang|sounds|connection_optimization|.well-known)/(.*)$
    {
        add_header 'Access-Control-Allow-Headers' 'Authorization,Content-Type,Accept,Origin,User-Agent,DNT,Cache-Control,X-Mx-ReqToken,Keep-Alive,X-Requested-With,If-Modified-Since,Access-Control-Request-Method,Access-Control-Request-Headers' always;
        add_header 'Access-Control-Allow-Origin' '*' always;
        alias /usr/share/jitsi-meet/$1/$2;

        # cache all versioned files
        if ($arg_v) {
          expires 1y;
        }
    }

    # BOSH
    location = /http-bind {
        proxy_pass      http://localhost:5280/http-bind;
        proxy_set_header X-Forwarded-For $remote_addr;
        proxy_set_header Host $http_host;
    }

    # xmpp websockets
    location = /xmpp-websocket {
        proxy_pass http://127.0.0.1:5280/xmpp-websocket?prefix=$prefix&$args;
        proxy_http_version 1.1;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "upgrade";
        proxy_set_header Host $http_host;
        tcp_nodelay on;
    }

    location ~ ^/([^/?&:'"]+)$ {
        try_files $uri @root_path;
    }

    location @root_path {
        rewrite ^/(.*)$ / break;
    }

    location ~ ^/([^/?&:'"]+)/config.js$
    {
       set $subdomain "$1.";
       set $subdir "$1/";

       alias /etc/jitsi/meet/the.domain-config.js;
    }

    #Anything that didn't match above, and isn't a real file, assume it's a room name and redirect to /
    location ~ ^/([^/?&:'"]+)/(.*)$ {
        set $subdomain "$1.";
        set $subdir "$1/";
        rewrite ^/([^/?&:'"]+)/(.*)$ /$2;
    }

    # BOSH for subdomains
    location ~ ^/([^/?&:'"]+)/http-bind {
        set $subdomain "$1.";
        set $subdir "$1/";
        set $prefix "$1";

        rewrite ^/(.*)$ /http-bind;
    }

    # websockets for subdomains
    location ~ ^/([^/?&:'"]+)/xmpp-websocket {
        set $subdomain "$1.";
        set $subdir "$1/";
        set $prefix "$1";

        rewrite ^/(.*)$ /xmpp-websocket;
    }
}

Теперь нгинкс вываливается в 405, но с хедерами
В location = /http-bind никакого эффекта вообще

Goury ★★★★★ ()
Ответ на: комментарий от Goury

на какой запрос?

фейлится OPTIONS походу, лол.

почитай это https://developer.mozilla.org/en-US/docs/Web/HTTP/CORS#Examples_of_access_control_scenarios (Preflighted requests)

тогда станет понятно что делает конфиг мой выше.

drsm ★★ ()
Последнее исправление: drsm (всего исправлений: 1)
Ответ на: комментарий от zolden

В error.log ничего релевантного, а access.log эта штука не включила (судя по конфигу) =( Как доберусь админить его снова — сообщу.

Хотя есть острое ощущение что это всё от моих кривых рук.

Goury ★★★★★ ()