LINUX.ORG.RU

В старом дистрибутиве AltLinux 7.0.5 не устанавливаются модули python-3.7.1 - libssl слишком старый

 , , ,


0

1

Доброго времени! Нужно авторизоваться на сайте с логином паролем, сохранить сессию, чтобы выполнять дальнейшие действия по заполнению форм. Но pip3 не находит нужные версии pickle, cookielib, http, обновление pip3 и python3 не происходит.

Система AltLinux 7.0.5 SPT, python3.

# lsb_release -a
LSB Version:	4.0:core-3.0-ia32:core-3.0-noarch:core-4.0-ia32:core-4.0-noarch:cxx-3.0-ia32:cxx-3.0-noarch:cxx-4.0-ia32:cxx-4.0-noarch:desktop-3.0-ia32:desktop-3.0-noarch:desktop-4.0-ia32:desktop-4.0-noarch:graphics-3.0-ia32:graphics-3.0-noarch:graphics-4.0-ia32:graphics-4.0-noarch:languages-3.0-noarch:languages-4.0-noarch:printing-3.0-noarch:printing-4.0-noarch
Distributor ID:	ALT
Description:	ALT Linux 7.0.5 SPT  (silo)
Release:	7.0.5
Codename:	silo

# uname -a
Linux o14 4.4.143-std-def-alt0.M70C.1 #1 SMP Wed Aug 8 18:08:02 UTC 2018 i686 GNU/Linux

# python3 --version
Python 3.3.1

# pip3 install --upgrade pip
DEPRECATION: Python 3.3 supported has been deprecated and support for it will be dropped in the future. Please upgrade your Python.
Requirement already up-to-date: pip in /usr/lib/python3.3/site-packages (10.0.1)
You are using pip version 10.0.1, however version 18.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

# pip3 install pickle
DEPRECATION: Python 3.3 supported has been deprecated and support for it will be dropped in the future. Please upgrade your Python.
Collecting pickle
  Could not find a version that satisfies the requirement pickle (from versions: )
No matching distribution found for pickle
You are using pip version 10.0.1, however version 18.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

Снесли pithon3.3 поставили с python.org последнюю: python-3.7.1 . Но без модуля ssl pip3 ничего не скачивает:

# pip3.7 install stdlib
pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available.
Collecting stdlib
  Retrying (Retry(total=4, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError("Can't connect to HTTPS URL because the SSL module is not available.")': /simple/stdlib/
  Retrying (Retry(total=3, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError("Can't connect to HTTPS URL because the SSL module is not available.")': /simple/stdlib/
  Retrying (Retry(total=2, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError("Can't connect to HTTPS URL because the SSL module is not available.")': /simple/stdlib/
  Retrying (Retry(total=1, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError("Can't connect to HTTPS URL because the SSL module is not available.")': /simple/stdlib/
  Retrying (Retry(total=0, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError("Can't connect to HTTPS URL because the SSL module is not available.")': /simple/stdlib/
  Could not fetch URL https://pypi.org/simple/stdlib/: There was a problem confirming the ssl certificate: HTTPSConnectionPool(host='pypi.org', port=443): Max retries exceeded with url: /simple/stdlib/ (Caused by SSLError("Can't connect to HTTPS URL because the SSL module is not available.")) - skipping
  Could not find a version that satisfies the requirement stdlib (from versions: )
No matching distribution found for stdlib
pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available.
Could not fetch URL https://pypi.org/simple/pip/: There was a problem confirming the ssl certificate: HTTPSConnectionPool(host='pypi.org', port=443): Max retries exceeded with url: /simple/pip/ (Caused by SSLError("Can't connect to HTTPS URL because the SSL module is not available.")) - skipping

В ответе сказано комплиировать с поддержкой ssl https://stackoverflow.com/questions/49094768/ssl-module-in-python-is-not-avai...

так и сделали. Отредактировали Setup но make жалуется на старую версию libssl:

# nano Python3.7.1/Modules/Setup
...
# Socket module helper for SSL support; you must comment out the other
# socket line above, and possibly edit the SSL variable:
#SSL=/usr/local/ssl
SSL=/usr/include/openssl
_ssl _ssl.c \
	-DUSE_SSL -I$(SSL)/include -I$(SSL)/include/openssl \
	-L$(SSL)/lib -lssl -lcrypto



# ./configure
# make 
...
gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall    -std=c99 -Wextra -Wno-unused-result -Wno-unused-parameter -Wno-missing-field-initializers -Werror=implicit-function-declaration   -I. -I./Include     -DUSE_SSL -I/usr/include/openssl/include -I/usr/include/openssl/include/openssl -c ./Modules/_ssl.c -o Modules/_ssl.o
./Modules/_ssl.c:74:6: error: #error "libssl is too old and does not support X509_VERIFY_PARAM_set1_host()"
./Modules/_ssl.c: In function ‘_ssl_configure_hostname’:
./Modules/_ssl.c:861:9: error: implicit declaration of function ‘SSL_get0_param’ [-Werror=implicit-function-declaration]
./Modules/_ssl.c:861:36: warning: initialization makes pointer from integer without a cast [enabled by default]
./Modules/_ssl.c:863:13: error: implicit declaration of function ‘X509_VERIFY_PARAM_set1_host’ [-Werror=implicit-function-declaration]
./Modules/_ssl.c:869:13: error: implicit declaration of function ‘X509_VERIFY_PARAM_set1_ip’ [-Werror=implicit-function-declaration]
./Modules/_ssl.c: In function ‘_ssl__SSLContext_impl’:
./Modules/_ssl.c:2988:23: error: ‘X509_CHECK_FLAG_NO_PARTIAL_WILDCARDS’ undeclared (first use in this function)
./Modules/_ssl.c:2988:23: note: each undeclared identifier is reported only once for each function it appears in
./Modules/_ssl.c:3093:5: error: implicit declaration of function ‘SSL_CTX_get0_param’ [-Werror=implicit-function-declaration]
./Modules/_ssl.c:3093:12: warning: assignment makes pointer from integer without a cast [enabled by default]
./Modules/_ssl.c:3099:5: error: implicit declaration of function ‘X509_VERIFY_PARAM_set_hostflags’ [-Werror=implicit-function-declaration]
./Modules/_ssl.c: In function ‘get_verify_flags’:
./Modules/_ssl.c:3397:11: warning: assignment makes pointer from integer without a cast [enabled by default]
./Modules/_ssl.c: In function ‘set_verify_flags’:
./Modules/_ssl.c:3410:11: warning: assignment makes pointer from integer without a cast [enabled by default]
./Modules/_ssl.c: In function ‘set_host_flags’:
./Modules/_ssl.c:3573:11: warning: assignment makes pointer from integer without a cast [enabled by default]
cc1: some warnings being treated as errors
make: *** [Modules/_ssl.o] Ошибка 1



# apt-cache show libssl
Виртуальный пакет libssl предоставляется следующими пакетами:
  libssl10 1.0.1u-alt0.M70C.1
  libssl7 0.9.8zh-alt0.M70C.1
You should explicitly select one to show.
E: Package libssl is a virtual package with multiple providers.

подскажите, как можно обойти?

Система AltLinux 7.0.5 SPT

Вообще-то такой дистрибутив поставляется с техподдержкой. Там говорят что-нибудь? Может какие-то рекомедации наработаны.

AS ★★★★★ ()
Ответ на: комментарий от AS

Щас я окажу техподдержку . Она состоит в совете не пользоваться ALT Linux.

Автор вопроса всё делает примерно правильно, но у него могла возникнуть проблема из-за того, что Python версии 3.3. Программы на Python могут быть несовместимы со слишком старыми версиями Python. Вообще-то, и с самыми последними версиями тоже. Автору следует поставить более новую версию Python, скорее всего, 3.6 (она сейчас самая распространённая), а если в хранилище ALT Linux такой нет, то поставить из дистрибутива на официальном сайте Python или Python Anaconda.

Partisan ★★★ ()
Ответ на: комментарий от Partisan

Partisan, шёл бы ты со своими советами в пешее эротическое. И вот почему. Наличие СПТ уже сразу подразумевает определённую аттестацию рабочего места/сервера/разное. Твой совет - это вероятная потеря этой самой аттестации со всеми вытекающими для организации проблемами. Какими? Ну это уже от организации зависит и от того, чем занимается конкретное устройство.

Ну а если СПТ, всё же, просто так, то да, можно обновить до бранча с новым Python.

AS ★★★★★ ()
Ответ на: комментарий от vvn_black

спасибо, vvn_black. окружением, версиями еще не балуюсь.

просто удалил старый питон `apt-get remove python3-module-pip python3`, кстати под AltLinux нет ни apt-get purge ни apt-file, ни apt list installed...

далее установка python3.7.1 с багом https://bugs.python.org/issue32401 ModuleNotFoundError: No module named '_ctypes' Makefile:1108: recipe for target 'install' failed

сделали так https://stackoverflow.com/a/46590942 :

# apt-get  install libffi libffi-devel
# apt-get install zlib zlib-devel
# apt-get install gcc-c++-common gcc4.7-c++

# # pwd
/home/user/Загрузки/Python-3.7.1

# ./configure
# make
# make install
...
if test "xupgrade" != "xno"  ; then \
	case upgrade in \
		upgrade) ensurepip="--upgrade" ;; \
		install|*) ensurepip="" ;; \
	esac; \
	 ./python -E -m ensurepip \
		$ensurepip --root=/ ; \
fi
Looking in links: /tmp/.private/root/tmprejhk7v8
Collecting setuptools
Collecting pip
Installing collected packages: setuptools, pip
Successfully installed pip-10.0.1 setuptools-39.0.1


# python3 -v
-bash: /usr/bin/python3: Нет такого файла или каталога
# whereis python3
python3: /usr/lib/python3.3 /usr/local/bin/python3.7 /usr/local/bin/python3.7m-config /usr/local/bin/python3.7-config /usr/local/bin/python3 /usr/local/bin/python3.7m /usr/local/lib/python3.7 /usr/include/python3.3m

# python3.7 --version
Python 3.7.1

# whereis pip
pip: /usr/bin/pip /usr/local/bin/pip3.7

# pip3.7 --version
pip 10.0.1 from /usr/local/lib/python3.7/site-packages/pip (python 3.7)



но проблема не ушла

# pip3.7 install pickle cookielib http
pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available.
Collecting pickle
  Retrying (Retry(total=4, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError("Can't connect to HTTPS URL because the SSL module is not available.")': /simple/pickle/
  Retrying (Retry(total=3, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError("Can't connect to HTTPS URL because the SSL module is not available.")': /simple/pickle/
  Retrying (Retry(total=2, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError("Can't connect to HTTPS URL because the SSL module is not available.")': /simple/pickle/
  Retrying (Retry(total=1, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError("Can't connect to HTTPS URL because the SSL module is not available.")': /simple/pickle/
  Retrying (Retry(total=0, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError("Can't connect to HTTPS URL because the SSL module is not available.")': /simple/pickle/
  Could not fetch URL https://pypi.org/simple/pickle/: There was a problem confirming the ssl certificate: HTTPSConnectionPool(host='pypi.org', port=443): Max retries exceeded with url: /simple/pickle/ (Caused by SSLError("Can't connect to HTTPS URL because the SSL module is not available.")) - skipping
  Could not find a version that satisfies the requirement pickle (from versions: )
No matching distribution found for pickle
pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available.
Could not fetch URL https://pypi.org/simple/pip/: There was a problem confirming the ssl certificate: HTTPSConnectionPool(host='pypi.org', port=443): Max retries exceeded with url: /simple/pip/ (Caused by SSLError("Can't connect to HTTPS URL because the SSL module is not available.")) - skipping

comoestasyan ()
Ответ на: комментарий от comoestasyan
# pip3.7 install pickle
...
Retrying (Retry(total=0, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError("Can't connect to HTTPS URL because the SSL module is not available.")': /simple/openssl/

> pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available
Could not fetch URL https://pypi.org/simple/pip/: There was a problem confirming the ssl certificate: HTTPSConnectionPool(host='pypi.org', port=443): Max retries exceeded with url: /simple/pip/ (Caused by SSLError("Can't connect to HTTPS URL because the SSL module is not available.")) - skipping

не помогает:

# apt-get install openssl openssl-devel libssl10 libtls
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Последняя версия openssl уже установлена.
Выбрано libssl-devel для 'openssl-devel'
Последняя версия libssl-devel уже установлена.
Последняя версия libssl10 уже установлена.
Последняя версия libtls уже установлена.
0 будет обновлено, 0 новых установлено, 0 пакетов будет удалено и 0 не будет обновлено.

подскажите, как закачать модуль pip3.7 openssl и куда?

comoestasyan ()
Ответ на: комментарий от comoestasyan

не помогло https://tecadmin.net/install-python-3-6-ubuntu-linuxmint/#

# apt-get install build-essential checkinstall Чтение списков пакетов... Завершено Построение дерева зависимостей... Завершено E: Невозможно найти пакет build-essential

# apt-cache search checkinstall gphotoframe - Gnome Photo Frame

# apt-cache search essential libCoinFlopCpp - Shared libraries of COIN-OR FLOPC++ libCoinFlopCpp-devel - Development files of COIN-OR FLOPC++ ...blahblahblah...

comoestasyan ()
Ответ на: комментарий от comoestasyan

окружением, версиями еще не балуюсь

Судя по твоим действиям, ты рискуешь сломать не только дистрибутивный питон, но и весь свой альт.

Что может быть проще, установить нужное окружение в хомяк и экспериментировать с ним, но нет, мы не ищем лёгких путей? )

vvn_black ★★★★★ ()
Ответ на: комментарий от comoestasyan

apt-get purge

Есть apt-get autoremove, но ещё до Сизифа даже не дошёл.

apt-file

есть apf и epm, которые умеют то же самое.
https://www.altlinux.org/FAQ

ни apt list

А что он должен делать?

AS ★★★★★ ()
Последнее исправление: AS (всего исправлений: 1)
Ответ на: комментарий от anonymous
# pip3.7 install stdlib
pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available.
Collecting stdlib
  Retrying (Retry(total=4, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError("Can't connect to HTTPS URL because the SSL module is not available.")': /simple/stdlib/
  Retrying (Retry(total=3, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError("Can't connect to HTTPS URL because the SSL module is not available.")': /simple/stdlib/
  Retrying (Retry(total=2, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError("Can't connect to HTTPS URL because the SSL module is not available.")': /simple/stdlib/
  Retrying (Retry(total=1, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError("Can't connect to HTTPS URL because the SSL module is not available.")': /simple/stdlib/
  Retrying (Retry(total=0, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError("Can't connect to HTTPS URL because the SSL module is not available.")': /simple/stdlib/
  Could not fetch URL https://pypi.org/simple/stdlib/: There was a problem confirming the ssl certificate: HTTPSConnectionPool(host='pypi.org', port=443): Max retries exceeded with url: /simple/stdlib/ (Caused by SSLError("Can't connect to HTTPS URL because the SSL module is not available.")) - skipping
  Could not find a version that satisfies the requirement stdlib (from versions: )
No matching distribution found for stdlib
pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available.
Could not fetch URL https://pypi.org/simple/pip/: There was a problem confirming the ssl certificate: HTTPSConnectionPool(host='pypi.org', port=443): Max retries exceeded with url: /simple/pip/ (Caused by SSLError("Can't connect to HTTPS URL because the SSL module is not available.")) - skipping

вопрос установки модуля openssl для python3.7 вручную актуален

comoestasyan ()
Ответ на: комментарий от comoestasyan

тут найден ответ https://stackoverflow.com/questions/49094768/ssl-module-in-python-is-not-avai...

но Python3.7/Modules/Setup:


# Socket module helper for SSL support; you must comment out the other
# socket line above, and possibly edit the SSL variable:
#SSL=/usr/local/ssl
#_ssl _ssl.c \
#	-DUSE_SSL -I$(SSL)/include -I$(SSL)/include/openssl \
#	-L$(SSL)/lib -lssl -lcrypto

Извините, не могу понять, есть ли разница между ssl и openssl

# whereis ssl
ssl:
# whereis openssl
openssl: /usr/bin/openssl /etc/openssl /usr/include/openssl /usr/share/man/man1/openssl.1.gz

что вписывать?

comoestasyan ()
Ответ на: комментарий от comoestasyan
# pwd
/usr/include/openssl

# ls
aes.h       cms.h       ebcdic.h    kssl.h         opensslv.h  rsa.h        symhacks.h
asn1.h      comp.h      ecdh.h      lhash.h        ossl_typ.h  safestack.h  tls1.h
asn1_mac.h  conf_api.h  ecdsa.h     md2.h          pem2.h      seed.h       ts.h
asn1t.h     conf.h      ec.h        md4.h          pem.h       sha.h        txt_db.h
bio.h       crypto.h    engine.h    md5.h          pkcs12.h    srp.h        ui_compat.h
blowfish.h  des.h       e_os2.h     mdc2.h         pkcs7.h     srtp.h       ui.h
bn.h        des_old.h   err.h       modes.h        pqueue.h    ssl23.h      whrlpool.h
buffer.h    dh.h        evp.h       objects.h      rand.h      ssl2.h       x509.h
camellia.h  dsa.h       hmac.h      obj_mac.h      rc2.h       ssl3.h       x509v3.h
cast.h      dso.h       idea.h      ocsp.h         rc4.h       ssl.h        x509_vfy.h
cmac.h      dtls1.h     krb5_asn.h  opensslconf.h  ripemd.h    stack.h


где искать сокет ssl ?

comoestasyan ()
Ответ на: комментарий от comoestasyan

не помогло

Python3.7/Modules/Setup такой:

# Socket module helper for SSL support; you must comment out the other
# socket line above, and possibly edit the SSL variable:
#SSL=/usr/local/ssl
SSL=/usr/include/openssl
_ssl _ssl.c \
	-DUSE_SSL -I$(SSL)/include -I$(SSL)/include/openssl \
	-L$(SSL)/lib -lssl -lcrypto

но ошибка make - слишком старый libssl:

# .configure
# make
...
gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall    -std=c99 -Wextra -Wno-unused-result -Wno-unused-parameter -Wno-missing-field-initializers -Werror=implicit-function-declaration   -I. -I./Include     -DUSE_SSL -I/usr/include/openssl/include -I/usr/include/openssl/include/openssl -c ./Modules/_ssl.c -o Modules/_ssl.o
./Modules/_ssl.c:74:6: error: #error "libssl is too old and does not support X509_VERIFY_PARAM_set1_host()"
./Modules/_ssl.c: In function ‘_ssl_configure_hostname’:
./Modules/_ssl.c:861:9: error: implicit declaration of function ‘SSL_get0_param’ [-Werror=implicit-function-declaration]
./Modules/_ssl.c:861:36: warning: initialization makes pointer from integer without a cast [enabled by default]
./Modules/_ssl.c:863:13: error: implicit declaration of function ‘X509_VERIFY_PARAM_set1_host’ [-Werror=implicit-function-declaration]
./Modules/_ssl.c:869:13: error: implicit declaration of function ‘X509_VERIFY_PARAM_set1_ip’ [-Werror=implicit-function-declaration]
./Modules/_ssl.c: In function ‘_ssl__SSLContext_impl’:
./Modules/_ssl.c:2988:23: error: ‘X509_CHECK_FLAG_NO_PARTIAL_WILDCARDS’ undeclared (first use in this function)
./Modules/_ssl.c:2988:23: note: each undeclared identifier is reported only once for each function it appears in
./Modules/_ssl.c:3093:5: error: implicit declaration of function ‘SSL_CTX_get0_param’ [-Werror=implicit-function-declaration]
./Modules/_ssl.c:3093:12: warning: assignment makes pointer from integer without a cast [enabled by default]
./Modules/_ssl.c:3099:5: error: implicit declaration of function ‘X509_VERIFY_PARAM_set_hostflags’ [-Werror=implicit-function-declaration]
./Modules/_ssl.c: In function ‘get_verify_flags’:
./Modules/_ssl.c:3397:11: warning: assignment makes pointer from integer without a cast [enabled by default]
./Modules/_ssl.c: In function ‘set_verify_flags’:
./Modules/_ssl.c:3410:11: warning: assignment makes pointer from integer without a cast [enabled by default]
./Modules/_ssl.c: In function ‘set_host_flags’:
./Modules/_ssl.c:3573:11: warning: assignment makes pointer from integer without a cast [enabled by default]
cc1: some warnings being treated as errors
make: *** [Modules/_ssl.o] Ошибка 1



# apt-cache show libssl
Виртуальный пакет libssl предоставляется следующими пакетами:
  libssl10 1.0.1u-alt0.M70C.1
  libssl7 0.9.8zh-alt0.M70C.1
You should explicitly select one to show.
E: Package libssl is a virtual package with multiple providers.
comoestasyan ()
Ответ на: не помогло от comoestasyan

отсюда для архитектуры 586 ничего не ставится https://packages.altlinux.org/en/Sisyphus/srpms/openssl1.1/get

# ls
libcrypto1.1-1.1.0i-alt1.i586.rpm            old
libcrypto1.1-debuginfo-1.1.0i-alt1.i586.rpm  openssl-1.1.0i-alt1.i586.rpm
libssl1.1-1.1.0i-alt1.i586.rpm               openssl-debuginfo-1.1.0i-alt1.i586.rpm
libssl1.1-debuginfo-1.1.0i-alt1.i586.rpm     openssl-engines-1.1.0i-alt1.i586.rpm
libssl-devel-1.1.0i-alt1.i586.rpm            openssl-engines-debuginfo-1.1.0i-alt1.i586.rpm
libssl-devel-static-1.1.0i-alt1.i586.rpm     Python-3.7.1

# rpm -i *.rpm
ошибка: неудовлетворенные зависимости:
	debug(ld-linux.so.2)   нужен для libcrypto1.1-debuginfo-1.1.0i-alt1
	debug(libc.so.6)   нужен для libcrypto1.1-debuginfo-1.1.0i-alt1
	debug(libdl.so.2)   нужен для libcrypto1.1-debuginfo-1.1.0i-alt1
	debug(libpthread.so.0)   нужен для libcrypto1.1-debuginfo-1.1.0i-alt1
	debug(libz.so.1)   нужен для libcrypto1.1-debuginfo-1.1.0i-alt1
	openssl < 1.1.0i-alt1 конфликтует с libssl-devel-1.1.0i-alt1
	libssl-devel > 1.0.1u-alt0.M70C.1 конфликтует с openssl-1.0.1u-alt0.M70C.1
	glibc-devel-static   нужен для libssl-devel-static-1.1.0i-alt1
	libssl-devel < 1.1.0i-alt1 конфликтует с openssl-1.1.0i-alt1
	openssl > 1.0.1u-alt0.M70C.1 конфликтует с libssl-devel-1.0.1u-alt0.M70C.1
	/usr/lib/debug/lib/ld-linux.so.2.debug   нужен для openssl-debuginfo-1.1.0i-alt1


# rpm -i libcrypto1.1-1.1.0i-alt1.i586.rpm
файл /etc/openssl/openssl.cnf из устанавливаемого пакета libcrypto1.1-1.1.0i-alt1 конфликтует с файлом из пакета libcrypto1
comoestasyan ()
Ответ на: комментарий от comoestasyan

pip3.7 install stdlib

Ты или тупой как пень или очень толстый. Не надо ничего устанавливать. Ты с какого раза понимаешь, чтобы я сразу N строчек написал?

anonymous ()
Ответ на: комментарий от comoestasyan

под pip3.6 тоже ничего не находит, связанное с сетью. И это похоже на баги, так как пытается подключить модуль 'Request', хотя такого нет, есть Requests.

# pip3.6 install --upgrade pip
Collecting pip
  Downloading https://files.pythonhosted.org/packages/c2/d7/90f34cb0d83a6c5631cf71dfe64cc1054598c843a92b400e55675cc2ac37/pip-18.1-py2.py3-none-any.whl (1.3MB)
    100% |████████████████████████████████| 1.3MB 1.7MB/s 
Installing collected packages: pip
  Found existing installation: pip 10.0.1
    Uninstalling pip-10.0.1:
      Successfully uninstalled pip-10.0.1
Successfully installed pip-18.1


# pip3.6 install request
Collecting request
  Using cached https://files.pythonhosted.org/packages/b8/13/b88a65f14470f3e17d72a1a930f173b36717c211685dbbadfc2e5ba21303/request-1.0.2.tar.gz
Collecting get (from request)
  Downloading https://files.pythonhosted.org/packages/dc/bd/264e65844b66e2b5fa829f3f6c526056ee14a0508fb6b454e0af4105a21c/get-1.0.3.tar.gz
Collecting post (from request)
  Downloading https://files.pythonhosted.org/packages/7f/ea/ddf22395dcee7a45b7ab7564a087725cafc778f421268814cd8a5ec9ffdf/post-1.0.2.tar.gz
Requirement already satisfied: setuptools in /usr/local/lib/python3.6/site-packages (from request) (39.0.1)
Collecting query_string (from get->request)
  Downloading https://files.pythonhosted.org/packages/be/2d/719132c49c715743afff3781e04489cd21189914a563b56837f891fd02ac/query_string-1.0.2.tar.gz
Collecting public (from query_string->get->request)
  Downloading https://files.pythonhosted.org/packages/0e/45/1a8ab7780a60b8dbfd030b3b8d8515f80f4ff5c6a1b39f4fcb956575f421/public-2.0.1-py2.py3-none-any.whl
Installing collected packages: public, query-string, get, post, request
  Running setup.py install for query-string ... done
  Running setup.py install for get ... done
  Running setup.py install for post ... done
  Running setup.py install for request ... done
Successfully installed get-1.0.3 post-1.0.2 public-2.0.1 query-string-1.0.2 request-1.0.2

# pip3.6 install requests
Collecting requests
  Downloading https://files.pythonhosted.org/packages/f1/ca/10332a30cb25b627192b4ea272c351bce3ca1091e541245cccbace6051d8/requests-2.20.0-py2.py3-none-any.whl (60kB)
    100% |████████████████████████████████| 61kB 361kB/s 
Collecting idna<2.8,>=2.5 (from requests)
  Downloading https://files.pythonhosted.org/packages/4b/2a/0276479a4b3caeb8a8c1af2f8e4355746a97fab05a372e4a2c6a6b876165/idna-2.7-py2.py3-none-any.whl (58kB)
    100% |████████████████████████████████| 61kB 1.8MB/s 
Collecting urllib3<1.25,>=1.21.1 (from requests)
  Downloading https://files.pythonhosted.org/packages/8c/4b/5cbc4cb46095f369117dcb751821e1bef9dd86a07c968d8757e9204c324c/urllib3-1.24-py2.py3-none-any.whl (117kB)
    100% |████████████████████████████████| 122kB 1.3MB/s 
Collecting certifi>=2017.4.17 (from requests)
  Using cached https://files.pythonhosted.org/packages/56/9d/1d02dd80bc4cd955f98980f28c5ee2200e1209292d5f9e9cc8d030d18655/certifi-2018.10.15-py2.py3-none-any.whl
Collecting chardet<3.1.0,>=3.0.2 (from requests)
  Using cached https://files.pythonhosted.org/packages/bc/a9/01ffebfb562e4274b6487b4bb1ddec7ca55ec7510b22e4c51f14098443b8/chardet-3.0.4-py2.py3-none-any.whl
Installing collected packages: idna, urllib3, certifi, chardet, requests
Successfully installed certifi-2018.10.15 chardet-3.0.4 idna-2.7 requests-2.20.0 urllib3-1.24

# pip3.6 install http
Collecting http
  Using cached https://files.pythonhosted.org/packages/e3/91/a9260805e532e33df273b8f7dffad5c51693f8f9ba5f86bedcf42a7f22eb/http-0.02.tar.gz
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/.private/root/pip-install-iuib9kvw/http/setup.py", line 3, in <module>
        import http
      File "/tmp/.private/root/pip-install-iuib9kvw/http/http/__init__.py", line 17, in <module>
        from request import Request
    ImportError: cannot import name 'Request'
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/.private/root/pip-install-iuib9kvw/http/

# pip3.6 install cookielib
Collecting cookielib
  Could not find a version that satisfies the requirement cookielib (from versions: )
No matching distribution found for cookielib

# pip3.6 install pickle
Collecting pickle
  Could not find a version that satisfies the requirement pickle (from versions: )
No matching distribution found for pickle

# pip3.6 install stdlib
Collecting stdlib
  Could not find a version that satisfies the requirement stdlib (from versions: )
No matching distribution found for stdlib

# pip3.6 install http
Collecting http
  Using cached https://files.pythonhosted.org/packages/e3/91/a9260805e532e33df273b8f7dffad5c51693f8f9ba5f86bedcf42a7f22eb/http-0.02.tar.gz
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/.private/root/pip-install-itm48umf/http/setup.py", line 3, in <module>
        import http
      File "/tmp/.private/root/pip-install-itm48umf/http/http/__init__.py", line 17, in <module>
        from request import Request
    ImportError: cannot import name 'Request'
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/.private/root/pip-install-itm48umf/http/


# 
# pip3.6 install http
Collecting http
  Using cached https://files.pythonhosted.org/packages/e3/91/a9260805e532e33df273b8f7dffad5c51693f8f9ba5f86bedcf42a7f22eb/http-0.02.tar.gz
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/.private/root/pip-install-19e1t0f2/http/setup.py", line 3, in <module>
        import http
      File "/tmp/.private/root/pip-install-19e1t0f2/http/http/__init__.py", line 17, in <module>
        from request import Request
    ImportError: cannot import name 'Request'
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/.private/root/pip-install-19e1t0f2/http/
# 
# nano /tmp/.private/root/pip-install-19e1t0f2/http/http/__init__.py
# pip3.6 install cgi
Collecting cgi
  Could not find a version that satisfies the requirement cgi (from versions: )
No matching distribution found for cgi
# pip3.6 install urllib
Collecting urllib
  Could not find a version that satisfies the requirement urllib (from versions: )
No matching distribution found for urllib
# pip3.6 install ftplib
Collecting ftplib
  Could not find a version that satisfies the requirement ftplib (from versions: )
No matching distribution found for ftplib
# pip3.6 install pathlib
Collecting pathlib
  Downloading https://files.pythonhosted.org/packages/ac/aa/9b065a76b9af472437a0059f77e8f962fe350438b927cb80184c32f075eb/pathlib-1.0.1.tar.gz (49kB)
    100% |████████████████████████████████| 51kB 311kB/s 
Installing collected packages: pathlib
  Running setup.py install for pathlib ... done
Successfully installed pathlib-1.0.1
# 
comoestasyan ()