LINUX.ORG.RU

На машине Debian установлен IDEA, машина в той же сети что и сервер. IDEA не видит xdebug. Как исправить?

 , , , ,


1

2

Добрый день! С работы могу присоединиться к серверу дома. Все ок. xdebug работает как часы. Из дома не работает. Выдает

waiting for incoming connection with ide key

Настройки в Средах дома и на работе одинаковые.

Настройки сервера uname -a

Linux HomeMiniServer 3.16.0-4-amd64 #1 SMP Debian 3.16.39-1+deb8u2 (2017-03-07) x86_64 GNU/Linux
nano /etc/php5/apache2/php.ini
...
zend_extension=xdebug.so
xdebug.remote_host=92.121.61.47
xdebug.remote_enable=1
xdebug.remote_connect_back=1
xdebug.idekey=HomeMiniServerKey
xdebug.remote_port=9009
xdebug.remote_handler=dbgp
xdebug.remote_autostart=1
xdebug.profiler_enable=1;
xdebug.profiler_output_dir="/var/www/profiler"
xdebug.profiler_enable_trigger=1
nano /etc/php5/conf.d/20-xdebug.ini пусто

настройки в домашней машине и IDEA uname -a

Linux HOME-PCL 4.9.0-1-amd64 #1 SMP Debian 4.9.6-3 (2017-01-28) x86_64 GNU/Linux
iptables -L -n -v
Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination    
netstat -tnlp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name    
tcp        0      0 127.0.0.1:63342         0.0.0.0:*               LISTEN      1961/java           
tcp        0      0 0.0.0.0:20080           0.0.0.0:*               LISTEN      1961/java           
tcp        0      0 0.0.0.0:9009            0.0.0.0:*               LISTEN      1961/java           
tcp        0      0 127.0.0.1:5939          0.0.0.0:*               LISTEN      848/teamviewerd     
tcp        0      0 127.0.0.1:631           0.0.0.0:*               LISTEN      409/cupsd           
tcp        0      0 0.0.0.0:10137           0.0.0.0:*               LISTEN      1961/java           
tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      1080/exim4          
tcp        0      0 127.0.0.1:9050          0.0.0.0:*               LISTEN      645/tor             
tcp        0      0 127.0.0.1:6942          0.0.0.0:*               LISTEN      1961/java           
tcp        0      0 127.0.0.1:58846         0.0.0.0:*               LISTEN      1827/python         
tcp        0      0 0.0.0.0:58433           0.0.0.0:*               LISTEN      1827/python         
tcp6       0      0 :::80                   :::*                    LISTEN      649/apache2         
tcp6       0      0 ::1:631                 :::*                    LISTEN      409/cupsd           
tcp6       0      0 ::1:25                  :::*                    LISTEN      1080/exim4          
tcp6       0      0 :::58433                :::*                    LISTEN      1827/python   

IDEA 67ac1740d1b8.png

982ea77bd238.png

9ddd3a0aa95b.png

2d7086fa3e0a.png

e9afbd82c2ee40fa803b68f6c0e27480.png

23b2e160c940447c875e80638bb1d452.png

настройки роутера где 192.168.1.10 сервер 192.168.1.20 пк

4e32477eaa3e4627b486bdcf8180396b.png

ping и телнет проходит. Не могу понять почему не срабатывает xdebug?

Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.