LINUX.ORG.RU

После ребута php fcgi не работают: ошибка 502

 ,


0

1

Уважаемые экстрасенсы, чтобы вам было немного яснее, я сегодня поднял сервер и запустил сайты. у меня есть лог моих действий в блоге тлито, если кому надо.

на данный момент я ребутнул сервер и сайты открывают только статичные файлы, а пхп - дают ошибку 502. хотя до ребута я был щаслив. но мне не понравилось что 800Мб памяти съедено из 1024 и я решил ребутнуть. как мне опять получить щастья?

конфигурация: дебиан nginx + php5-fpm

я после ребута на всякий случай сделал service php5-fpm restart, а потом рестартил нгинкс - не помогло.

вот что у меня есть для вас:

# netstat -tupln | grep LISTEN
tcp        0      0 0.0.0.0:555            0.0.0.0:*               LISTEN      243/sshd        
tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN      716/mysqld      
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      292/nginx.conf  
tcp        0      0 0.0.0.0:25              0.0.0.0:*               LISTEN      925/master      

по-моему тут чего-то не хватает, до ребута таблица была длиннее.

конфиг хоста (сайта такого еще пока нет):

# cat tli.co
server {
    listen                  80;
    server_name             tli.co *.tli.co;
 
    set 	            $main_host		'tli.co';
 
    if ($host != $main_host) {
        rewrite             ^(.*)$              http://$main_host$1     permanent;
        break;
    }
 
    access_log              /var/log/nginx/tli.co.access.log;
    error_log       	    /var/log/nginx/tli.co.error.log;
 
    root                    /var/www/$main_host/www;
    index                   index.php index.html index.htm;
 
    location ~* ^.+\.(ico|htm|html|txt|jpg|png|gif|css|js)$ {
        access_log          off;
        autoindex           off;
        expires             30d;
        add_header          Cache-Control       'public';
    }
 
    location / {
        try_files           $uri    $uri/    /index.php?$args;
    }	
 
    location ~ \.php$ {
        include             /etc/nginx/conf.d/fastcgi_params.conf;
 
        fastcgi_param       SCRIPT_FILENAME  	/var/www/$main_host/www$fastcgi_script_name;
        fastcgi_param       DOCUMENT_ROOT       /var/www/$main_host/www;
 
        fastcgi_param       PHP_ADMIN_VALUE     upload_tmp_dir=/var/www/$main_host/tmp/upload;
        fastcgi_param       PHP_ADMIN_VALUE     session.save_path=/var/www/$main_host/tmp/sessions;
    }
 
    location ~ /\. {
	deny                all;
	access_log          off;
	log_not_found       off;
    }
}

nginx.conf:

user  www-data www-data;
worker_processes  1;
worker_priority	-20;

error_log  /var/log/nginx/error.log warn;
pid        /var/run/nginx.pid;


events {
    worker_connections  1024;
}


http {
    include       /etc/nginx/mime.types;
    default_type  application/octet-stream;

    log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
                      '$status $body_bytes_sent "$http_referer" '
                      '"$http_user_agent" "$http_x_forwarded_for"';

    client_max_body_size 12m;
    access_log  off; #/var/log/nginx/access.log  main;

    sendfile        on;
    #tcp_nopush     on;

    keepalive_timeout  65;

    server_names_hash_max_size	1024;
    server_names_hash_bucket_size	128;

    #gzip  on;

    fastcgi_temp_path	/var/cache/nginx/temp/fastcgi;
    proxy_temp_path	/var/cache/nginx/temp/proxy;

    charset	utf-8;
    index	index.php index.html index.htm;

    #include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;
}

# cat /etc/nginx/conf.d/fastcgi_params.conf

fastcgi_pass    unix:/var/run/php5-fpm.sock;
fastcgi_index   index.php;
 
fastcgi_split_path_info 		^(.+\.php)(/.+)$;
 
fastcgi_param   PATH_INFO        	$fastcgi_path_info;
 
fastcgi_param   QUERY_STRING            $query_string;
fastcgi_param   REQUEST_METHOD          $request_method;
fastcgi_param   CONTENT_TYPE            $content_type;
fastcgi_param   CONTENT_LENGTH          $content_length;
 
fastcgi_param	SCRIPT_NAME		$fastcgi_script_name;
fastcgi_param	REQUEST_URI		$request_uri;
fastcgi_param	DOCUMENT_URI		$document_uri;
fastcgi_param	SERVER_PROTOCOL		$server_protocol;
 
fastcgi_param  	SCRIPT_URI         	$scheme://$host$request_uri;
 
fastcgi_param	GATEWAY_INTERFACE	CGI/1.1;
fastcgi_param	SERVER_SOFTWARE		nginx;
 
fastcgi_param	REMOTE_ADDR		$remote_addr;
fastcgi_param	REMOTE_PORT		$remote_port;
fastcgi_param	SERVER_ADDR		$server_addr;
fastcgi_param	SERVER_PORT		$server_port;
fastcgi_param	SERVER_NAME		$server_name;
 
fastcgi_param   Host                    $host;
fastcgi_param   HTTP_X_REAL_IP          $remote_addr;
fastcgi_param   HTTP_X_FORWARDED_FOR	$remote_addr;
 
fastcgi_param   Range                   "";
fastcgi_param   Request-Range           "";
 
fastcgi_buffer_size                     128k;
fastcgi_buffers                         4       256k;
fastcgi_busy_buffers_size               256k;
fastcgi_temp_file_write_size            256k;
 
fastcgi_connect_timeout                 600;
fastcgi_send_timeout                    600;
fastcgi_read_timeout                    600;

что у меня не запущено или не настроено. и заодно как это и в какой очередности добавить в автозагрузку. как я понимаю автозагрузка это /etc/init.d и туда надо ссылки делать или баш-скрипты?


Дык php-fcgi сам себя не запустит.

Смотри в сторону spawn-fcgi или вообще переезда на lighttpd, который сам умеет запускать.

Radjah ★★★★★ ()
Ответ на: комментарий от Radjah

помоему я им не пользовался пока настраивал сервер. но может быть среди всех команд что-то и было. но мне конечно это не разобрать

tlito ()
Ответ на: комментарий от tlito

простите за беспокойство. просто я делал по рекомендациям https://romantelychko.com/blog/1303/ и не успел выучить их.

оказалось одна небольшая строка настроек влияла:

в файле /etc/nginx/conf.d/fastcgi_params.conf автор гида написал имя сокета с www:

fastcgi_pass unix:/var/run/php5-fpm.www.sock;

и помоему у меня он тоже был с www но после рестарта опять пришлось его менять. после смены (добавления www) и рестарта nginx все сразу заработало. пробую ребутить опять.

tlito ()
Ответ на: комментарий от tlito

после ребута все сразу работает. не надо ничего рестартить или запускать.так что на тему спавна вы предлагали то что мне не надо. а мне надо минимум занимать сервер чем-либо и максимум оптимизировать

tlito ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.