LINUX.ORG.RU

Apache 2 Web интерфейс Freepbx + rtorrent

 


0

0

Всем привет. Установлен FreePBX с вебинтерфесом на Apache2. Хочу поставить rTorrent c вебинтерфейсом RuTorrent. Вроде поставил, в папке /var/www/ лежит папка rutorrent, мне надо её опубликовать что бы заработало. В /etc/apache2/site-available создал файл rutorrent.conf из стандартного:

<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /var/www/rutorrent
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/rutorrent/>
Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory «/usr/lib/cgi-bin»>
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

создал на него ссылку в /etc/apache2/site-enabled. Перезапустил apache и не работает. Пытаюсь подключится к 192.168.1.28/rutorrent он не подключается. Хотя когда просто на http://192.168.1.28 захожу он добавляет: http://192.168.1.28/admin/config.php. Я так понял где то надо адресацию поменять, не могу понять где. Спасибо!

Ответ на: комментарий от PawkaSml

у тебя корень тут

DocumentRoot /var/www/rutorrent
ты за ходишь на 192.168.1.28/rutorrent, он ищет в /var/www/rutorrent/rutorrent

anonymous
()
Ответ на: комментарий от anonymous

Спасибо большое. Теперь всё ок. Работает!

PawkaSml
() автор топика
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.