>Exceptions as part of the type system means you have to catch every imaginable exception that might be thrown. This makes it hard to rapidly prototype or quickly test out several methods of solving a problem.
быдло. Я не обязан обрабатывать все. А богатая иерархия исключений неотъемлемая часть языка.
># Everything is in objects and must be buffered, even those things that don't really need to be buffered or in objects.
# There's int types and Integer objects, float types and Float objects. So you can have efficient data types, or object-oriented data types. Wouldn't it be better to make your object-oriented types efficient?
идиот. Все эффективно, все универсально.
>"Object-oriented programming is an exceptionally bad idea which could only have originated in California." --Edsger Dijkstra
не хер цитировать одного маразматика, твою тупость это не скроет.
>я про Absurd, которому шаблоны мешали, хотя он ими и не пользовался =)
Я ими пользуюсь - бородатое волосатое чмо умеет выкручивать руки хорошо. В общем-то по моим постингам это было понятно - я писал что "не хочу их видеть".
> String.downcase? Who calls it "downcase?" It's called
"lower case," and the method should be called "lowercase,
" "lower," or even "toLowerCase."
Любопытно. Что автору мешает написать что-то вроде такого:
class String
def toLowerCase
downcase
end
end
И будет во всех объектах класса String ему так нужный toLowerCase. :-)
Автор говорит про хаскель, в основном верно (хотя не всё). В комментах: D, Python, C/C++, Ruby/Rails, PHP, Scheme, Objective C, F#, XSLT, Scala, SmallTalk, Erlang, Eiffel, Lisp, shell, Io, Self, OCaml, VBA, Java, в основном фигня.
> Functions in the standard library do not use consistent naming, acronym and capitalization conventions, making it hard to remember exactly what the items are called:
* java.net has URLConnection and HttpURLConnection : why not UrlConnection or HTTPURLConnection or HttpUrlConnection?
* java.util has ZipOutputBuffer and GZIPOutputBuffer : why not ZIPOutputBuffer or GnuZipOutputBuffer or GzipOutputBuffer or GZipOutputBuffer?
На сколько я знаю, code convension позволяет и так и так.
> String.downcase? Who calls it "downcase?" It's called "lower case," and the method should be called "lowercase," "lower," or even "toLowerCase." And String.upcase should have been called "uppercase," "upper," or even "toUpperCase."
Грубо. Валенок для этого не предназначен. А переназначение операторов - ещё и не для такой экзотики. Там, вообще, можно с lvalue играть - страшный сон функциональщиков :D
Проверил по ссылке один пункт. Открыл Java, прочитал первое предложение. "Exceptions as part of the type system means you have to catch every imaginable exception that might be thrown.". Откровенное 4.2 и непонимание смысле исключений. Счёл дальнейшее чтение бессмысленным. Статья sucks.
Похоже, многие люди, якобы конструктивно критикующие Java, знают о ней только со слов апологетов C#, которые, в свою очередь, знают о Java только от MS.