LINUX.ORG.RU

Помогите со сборкой Gimp-2.8 в Debian


2

2

Здравствуйте, не могу сконфигурировать Gimp-2.8 в Debian 6.0 Вот скрипт для ./configure

#!/bin/bash
export BABL_CFLAGS="-I/home/hikkikamori/.local/include/babl-0.1/"
export BABL_LIBS="-L/home/hikkikamori/.local/lib -lbabl-0.1 -lm"
export GEGL_CFLAGS="-I/home/hikkikamori/.local/include/gegl-0.2"
export GEGL_LIBS="-L/home/hikkikamori/.local/lib -lgegl-0.2"
export GTK_CFLAGS ="-I/home/hikkikamori/.local/include/gtk-2.0 -I/home/hikkikamori/.local/lib/gtk-2.0/include"
export GTK_LIBS="-L/home/hikkikamori/.local/lib -lgtk-x11-2.0 -lgdk-x11-2.0"
export CFLAGS="`pkg-config --cflags gobject-2.0 gmodule-2.0 gio-2.0 atk cairo gdk-pixbuf-2.0 gio-2.0 pangoft2`"
export LIBS="`pkg-config --libs gobject-2.0 gmodule-2.0 gio-2.0 atk cairo gdk-pixbuf-2.0 gio-2.0 pangoft2`"
export LD_LIBRARY_PATH="/home/hikkikamori/.local/lib:/home/hikkikamori/.local/lib/babl-0.1:/home/hikkikamori/.local/lib/gegl-0.2:/home/hikkikamori/.local/lib/gtk-2.0/2.10.0/engines:/home/hikkikamori/.local/lib/gtk-2.0/2.10.0/immodules:/$
export PKG_CONFIG_PATH="/home/hikkikamori/.local/lib/pkgconfig"
./configure --prefix=/home/hikkikamori/.local 
Вот, что получаю на выходе
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking for pkg-config... /usr/bin/pkg-config
checking for GTK+ - version >= 2.24.10... *** GTK+ header files (version 2.20.1) do not match
*** library (version 2.24.10)
no
configure: error: Test for GTK+ failed. See the file 'INSTALL' for help.
хотя
hikkikamori@debian:~$ ls -l  /home/hikkikamori/.local/include/gtk-2.0
итого 20
drwxr-xr-x 2 root root  4096 Май  8 19:12 gdk
drwxr-xr-x 2 root root 16384 Май  8 19:12 gtk
hikkikamori@debian:~$ ls -l  /home/hikkikamori/.local/lib/gtk-2.0/include
итого 4
-rw-r--r-- 1 root root 583 Май  8 19:09 gdkconfig.h
В чём проблема?

checking for GTK+ - version >= 2.24.10... *** GTK+ header files (version 2.20.1) do not match

судя этому, нада версию gtk помоложе

zibert ★★★ ()

В чём проблема?

Тебе написали:

checking for GTK+ - version >= 2.24.10... *** GTK+ header files (version 2.20.1) do not match
*** library (version 2.24.10)
no
configure: error: Test for GTK+ failed. See the file 'INSTALL' for help.

kitar ★★★★★ ()

Gimp-2.8

С такими запросами тестинг/сид нужен, хотя и там ещё нет 2.8 и фиг знает когда будет. Зачем стейбл ломать?
Поставь убунту уже, не стесняйся :) , там ппа есть для таких случаев.

amorpher ★★★★★ ()
Ответ на: комментарий от kitar

У меня в stable стоит 2.20.1-2. Для Gimp-2.8 нужен gtk+ версии не ниже 2.24.10 Вот, что написано в INSTALL

 4. You need to have installed GTK+ version 2.24.10 or newer.
     GIMP also need a recent versions of GLib (>= 2.30.2), GDK-Pixbuf
     (>= 2.24.1), and Pango (>= 1.29.4). Sources for these can be grabbed
     from ftp://ftp.gtk.org/.
Я установил gtk+ 2.24.10 в /home/hikkikamori/.local и хочу, чтобы при /.configure происходил поиск не в /usr/lib и /usr/include, куда установлена gtk+ 2.20.1, а в /home/hikkikamori/.local. Для этого в скрипт прописал :
export GTK_CFLAGS ="-I/home/hikkikamori/.local/include/gtk-2.0 -I/home/hikkikamori/.local/lib/gtk-2.0/include"
export GTK_LIBS="-L/home/hikkikamori/.local/lib -lgtk-x11-2.0 -lgdk-x11-2.0"

hikkikamori ()
Ответ на: комментарий от kitar

мне написали, что заголовочные файлы (версии 2.20.1) gtk+ не соответствуют версии 2.24.10, с библиотеками вроде всё хорошо.

hikkikamori ()
Ответ на: комментарий от hikkikamori

Ubuntu != Debian, хотя всё тот же Linux :)

Не соглашусь. Ubuntu тот же testing/sid (без религии FSF) только подпиленный из коробки + некоторые фишки/приложения Canonical (которые легко удаляются/не устанавливаются с того же alternate) ну и ppa до кучи (которые просто решают сабж типа твоего).
Инными словами для домашнего десктопа самое ей и место (unity можно и не пользовать, т.к. есть Xubuntu/Kubuntu).

amorpher ★★★★★ ()
Ответ на: комментарий от BMX

оно :) сначала, пробовал установить всё в /usr/local, но после того как поставил gtk и pixbuf в половине установленных приложений пропали иконки 8), всё же решил идти по пути xMad, но пока ещё не пришёл к финалу

hikkikamori ()
export LD_LIBRARY_PATH="/home/hikkikamori/.local/lib:/home/hikkikamori/.local/lib/babl-0.1:/home/hikkikamori/.local/lib/gegl-0.2:/home/hikkikamori/.local/lib/gtk-2.0/2.10.0/engines:/home/hikkikamori/.local/lib/gtk-2.0/2.10.0/immodules:/home/hikkikamori/.local/lib/gtk-2.0/2.10.0/printbackends:/home/hikkikamori/.local/lib/gtk-2.0/modules" 

там вверху эта строчка немного не до конца до печаталась, копировал из nano

hikkikamori ()
Ответ на: комментарий от amorpher

Я это как бы понимаю, тут просто в другом дело. Вот тебе предлагают поменять своего кота, на такого же, только немного полосатее. Ты поменяешь или решишь оставить старого? Я выбрал бы второй вариант, прижился же уже, родной. С Debian у меня то же самое :)

hikkikamori ()
Ответ на: комментарий от hikkikamori

Вот тебе предлагают поменять своего кота, на такого же, только немного полосатее. Ты поменяешь или решишь оставить старого?

Если он срёт меньше или в предназначенном для этого месте, то да — поменяю :)

amorpher ★★★★★ ()
Ответ на: комментарий от hikkikamori

Я тоже на squeeze в /usr/local пытался собрать. Пересобрал кучу всего, но ему все равно было мало, и я, в какой-то момент сообразив, что так можно пересобирать весь мир^W^Wвсю систему, решил не быть таким ССЗБ и установил ubuntu 12.04 и одной командой gimp из ppa (что впрочем тоже ССЗБ, но у меня все работает :)

BMX ★★☆ ()

Кстати, в арчеге уже давно 2.8. Welcome.

baverman ★★★ ()
Ответ на: комментарий от baverman

убрал, теперь и до gtk не доходит дело

checking for ATK... no
configure: error: Package requirements (atk >= 2.2.0) were not met:

Requested 'atk >= 2.2.0' but version of Atk is 1.30.0

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
С atk всё хорошо, стоит там же в /home/hikkikamori/.local

hikkikamori ()
Ответ на: комментарий от BMX

Я уже все зависимости собрал, глупо будет так отступать :)
Кстати с параметром --disable-gtktest в ./configure, дело проходит, но при компиляции выдаёт всё равно куча ошибок, это было 3 часа назад. Уже не помню, что именно, но могу попробовать ещё раз и выложить код с ошибкой сюда.

hikkikamori ()
Ответ на: комментарий от hikkikamori

Может быть просто gtk криво собралось? Помню, у меня оно собиралось, но во время сборки показывало кучу warning'ов.

BMX ★★☆ ()
Ответ на: комментарий от BMX

да же не знаю, ничего вроде подозрительного не находил
вот что выдаёт make если в ./configure прописать --disable-gtktest

In file included from gimp.c:22:
/home/hikkikamori/.local/include/gegl-0.2/gegl.h:23:23: error: babl/babl.h: Нет такого файла или каталога
In file included from /home/hikkikamori/.local/include/gegl-0.2/gegl.h:27,
                 from gimp.c:22:
/home/hikkikamori/.local/include/gegl-0.2/gegl-buffer.h:62: предупреждение: в декларации ‘Babl’ по умолчанию установлен тип ‘int’ [-Wimplicit-int]
/home/hikkikamori/.local/include/gegl-0.2/gegl-buffer.h:62: ошибка: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
/home/hikkikamori/.local/include/gegl-0.2/gegl-buffer.h:231: предупреждение: в декларации ‘Babl’ по умолчанию установлен тип ‘int’ [-Wimplicit-int]
/home/hikkikamori/.local/include/gegl-0.2/gegl-buffer.h:231: ошибка: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
/home/hikkikamori/.local/include/gegl-0.2/gegl-buffer.h:254: предупреждение: в декларации ‘Babl’ по умолчанию установлен тип ‘int’ [-Wimplicit-int]
/home/hikkikamori/.local/include/gegl-0.2/gegl-buffer.h:254: ошибка: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
/home/hikkikamori/.local/include/gegl-0.2/gegl-buffer.h:300: ошибка: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
/home/hikkikamori/.local/include/gegl-0.2/gegl-buffer.h:316: ошибка: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
/home/hikkikamori/.local/include/gegl-0.2/gegl-buffer.h:386: предупреждение: в декларации ‘Babl’ по умолчанию установлен тип ‘int’ [-Wimplicit-int]
/home/hikkikamori/.local/include/gegl-0.2/gegl-buffer.h:386: ошибка: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
/home/hikkikamori/.local/include/gegl-0.2/gegl-buffer.h:427: предупреждение: в декларации ‘Babl’ по умолчанию установлен тип ‘int’ [-Wimplicit-int]
/home/hikkikamori/.local/include/gegl-0.2/gegl-buffer.h:427: ошибка: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
/home/hikkikamori/.local/include/gegl-0.2/gegl-buffer.h:469: предупреждение: в декларации ‘Babl’ по умолчанию установлен тип ‘int’ [-Wimplicit-int]
/home/hikkikamori/.local/include/gegl-0.2/gegl-buffer.h:469: ошибка: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
/home/hikkikamori/.local/include/gegl-0.2/gegl-buffer.h:490: предупреждение: в декларации ‘Babl’ по умолчанию установлен тип ‘int’ [-Wimplicit-int]
/home/hikkikamori/.local/include/gegl-0.2/gegl-buffer.h:490: ошибка: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
/home/hikkikamori/.local/include/gegl-0.2/gegl-buffer.h:512: предупреждение: в декларации ‘Babl’ по умолчанию установлен тип ‘int’ [-Wimplicit-int]
/home/hikkikamori/.local/include/gegl-0.2/gegl-buffer.h:512: ошибка: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
In file included from /home/hikkikamori/.local/include/gegl-0.2/gegl-buffer.h:537,
                 from /home/hikkikamori/.local/include/gegl-0.2/gegl.h:27,
                 from gimp.c:22:
/home/hikkikamori/.local/include/gegl-0.2/gegl-buffer-iterator.h:60: предупреждение: в декларации ‘Babl’ по умолчанию установлен тип ‘int’ [-Wimplicit-int]
/home/hikkikamori/.local/include/gegl-0.2/gegl-buffer-iterator.h:60: ошибка: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
/home/hikkikamori/.local/include/gegl-0.2/gegl-buffer-iterator.h:85: предупреждение: в декларации ‘Babl’ по умолчанию установлен тип ‘int’ [-Wimplicit-int]
/home/hikkikamori/.local/include/gegl-0.2/gegl-buffer-iterator.h:85: ошибка: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
In file included from /home/hikkikamori/.local/include/gegl-0.2/gegl.h:28,
                 from gimp.c:22:
/home/hikkikamori/.local/include/gegl-0.2/gegl-color.h:109: предупреждение: в декларации ‘Babl’ по умолчанию установлен тип ‘int’ [-Wimplicit-int]
/home/hikkikamori/.local/include/gegl-0.2/gegl-color.h:109: ошибка: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
/home/hikkikamori/.local/include/gegl-0.2/gegl-color.h:120: предупреждение: в декларации ‘Babl’ по умолчанию установлен тип ‘int’ [-Wimplicit-int]
/home/hikkikamori/.local/include/gegl-0.2/gegl-color.h:120: ошибка: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
In file included from gimp.c:22:
/home/hikkikamori/.local/include/gegl-0.2/gegl.h:421: предупреждение: в декларации ‘Babl’ по умолчанию установлен тип ‘int’ [-Wimplicit-int]
/home/hikkikamori/.local/include/gegl-0.2/gegl.h:421: ошибка: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
make[4]: *** [gimp.o] Ошибка 1
make[4]: Leaving directory `/media/local_disk1/.install/Графика/GIMP/gimp-2.8.0-RC1/app/core'
make[3]: *** [all-recursive] Ошибка 1
make[3]: Leaving directory `/media/local_disk1/.install/Графика/GIMP/gimp-2.8.0-RC1/app'
make[2]: *** [all] Ошибка 2
make[2]: Leaving directory `/media/local_disk1/.install/Графика/GIMP/gimp-2.8.0-RC1/app'
make[1]: *** [all-recursive] Ошибка 1
make[1]: Leaving directory `/media/local_disk1/.install/Графика/GIMP/gimp-2.8.0-RC1'
make: *** [all] Ошибка 2
но
hikkikamori@debian:/media/local_disk1/.install/Графика/GIMP$ ls -l ~/.local/include/babl-0.1/babl
итого 24
-rw-r--r-- 1 root root 8508 Май  8 21:38 babl.h
-rw-r--r-- 1 root root 1144 Май  8 21:38 babl-macros.h
-rw-r--r-- 1 root root 1892 Май  8 21:38 babl-types.h
-rw-r--r-- 1 root root 1457 Май  8 21:38 babl-version.h
O_o ?

hikkikamori ()
Ответ на: комментарий от baverman
hikkikamori@debian:/media/local_disk1/.install/Графика/GIMP$ cat /home/hikkikamori/.local/lib/pkgconfig/atk.pc
prefix=/home/hikkikamori/.local
exec_prefix=${prefix}
libdir=${exec_prefix}/lib
includedir=${prefix}/include

Name: Atk
Description: Accessibility Toolkit
Version: 2.2.0
Requires: gobject-2.0
Libs: -L${libdir} -latk-1.0
Cflags: -I${includedir}/atk-1.0
hikkikamori ()
Ответ на: комментарий от hikkikamori

В 23 строчке gegl.h прописал полностью путь до babl.h. Посмотрю что выдет

hikkikamori ()
Ответ на: комментарий от baverman

Gimp 2.7 собирал в своё время, не так сложно было, а вот с 2.8.
Походу компилятор тупо не видит пути в babl и gegl в загаловках, сейчас вот правлю их постепенно, может к чему-нибудь приведёт .. :/

hikkikamori ()
Ответ на: комментарий от hikkikamori

такс ошибок всё меньше, преимущественно проблема закладывается в тех файлах, где в заголовках стоит include <babl/babl.h>, везде прописываю include «/home/hikkikamori/.local/include/babl-0.1/babl/babl.h». Только после этого приходится делать make clean, и по новой make, а gimp сколько мне помнится дооолго собирается

hikkikamori ()
Ответ на: комментарий от baverman

Ну по крайней мере установить и запустить gimp-2.8 в Debian возможно :)
http://s019.radikal.ru/i615/1205/12/350d8179c295.png
только теперь как выставить нормальный шрифт? При запуске пишет

hikkikamori@debian:~/.local/bin$ ./gimp
Error reading Pango modules file

(gimp:22705): Pango-CRITICAL **: No modules found:
No builtin or dynamically loaded modules were found.
PangoFc will not work correctly.
This probably means there was an error in the creation of:
  '/home/hikkikamori/.local/etc/pango/pango.modules'
You should create this file by running:
  pango-querymodules > '/home/hikkikamori/.local/etc/pango/pango.modules'

(gimp:22705): Pango-WARNING **: failed to choose a font, expect ugly output. engine-type='PangoRenderFc', script='cyrillic'

(gimp:22705): Pango-WARNING **: failed to choose a font, expect ugly output. engine-type='PangoRenderFc', script='common'

(gimp:22705): Pango-WARNING **: failed to choose a font, expect ugly output. engine-type='PangoRenderFc', script='latin'
явно дело в pango, буду думать

hikkikamori ()
Ответ на: комментарий от uniqwert

Это инструкция не годная для Debian 6.0, хотя бы только из-за gtk+ , ну не соберётся он со старой версией

hikkikamori ()

Для тех кто захочет установить Gimp-2.8 в Debian Squeeze и вдруг нарвётся на эту тему:
# В тексте
# $ whoami
# == username
#
1.)В процессе установки gimp-2.8 в Debian 6.0 Squeeze пришлось установить с исходников в /home/username/.local (--prefix=/home/username/.local)

atk-2.2.0
babl-0.1.10
cairo-1.10.2
gdk-pixbuf-2.24.1
gegl-0.2.0
glib-2.30.2
gtk+-2.24.10
pango-1.29.4 
pixman-0.18.4
gimp-2.8
2.)Все пакеты ставил используя checkinstall, кроме gtk+ и cairo, их ставил через make install
3.)Для atk, gdk-pixbuf, gtk+, pango создавал конфиг с опцией --enable-introspection=no
4.)скрипт для конфигурирования cairo
#!/bin/bash
export PKG_CONFIG_PATH="/home/username/.local/lib/pkgconfig"
export  pixman_CFLAGS="-I/home/username/.local/include/pixman-1"
export  pixman_LIBS="-L/home/username/.local/lib -lpixman-1"
./configure --prefix=/home/username/.local
# Все скрипты должны лежать в папке с исходником
5.)скрипт для конфигурирования gtk+
#!/bin/bash
export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/home/username/.local/lib/pkgconfig
./configure --prefix=/home/username/.local
6.)скрипт для конфигурирования gimp-2.8
#!/bin/bash
export BABL_CFLAGS="-I/home/username/.local/include/babl-0.1/"
export BABL_LIBS="-L/home/username/.local/lib -lbabl-0.1 -lm"
export GEGL_CFLAGS="-I/home/username/.local/include/gegl-0.2"
export GEGL_LIBS="-L/home/username/.local/lib -lgegl-0.2"
export GTK_CFLAGS ="-I/home/username/.local/include/gtk-2.0 -I/home/username/.local/lib/gtk-2.0/include"
export GTK_LIBS="-L/home/username/.local/lib -lgtk-x11-2.0 -lgdk-x11-2.0"
export CFLAGS="`pkg-config --cflags gobject-2.0 gmodule-2.0 gio-2.0 atk cairo gdk-pixbuf-2.0 gio-2.0 pangoft2`"
export LIBS="`pkg-config --libs gobject-2.0 gmodule-2.0 gio-2.0 atk cairo gdk-pixbuf-2.0 gio-2.0 pangoft2`"
export LD_LIBRARY_PATH="/home/username/.local/lib:/home/username/.local/lib/babl-0.1:/home/username/.local/lib/gegl-0.2:/home/username/.local/lib/gtk-2.0/2.10.0/engines:/home/username/.local/lib/gtk-2.0/2.10.0/immodules:/home/username/.local/lib/gtk-2.0/2.10.0/printbackends:/home/username/.local/lib/gtk-2.0/modules"
export PKG_CONFIG_PATH="/home/username/.local/lib/pkgconfig"
./configure --prefix=/home/username/.local  --disable-gtktest

hikkikamori ()
Ответ на: комментарий от hikkikamori

7.) В процессе компиляции gimp-2.8 выскакивали ошибки типа

In file included from gimp.c:22:
/home/username/.local/include/gegl-0.2/gegl.h:23:23: error: babl/babl.h: Нет такого файла или каталога
In file included from /home/username/.local/include/gegl-0.2/gegl.h:27,
                 from gimp.c:22:
/home/username/.local/include/gegl-0.2/gegl-buffer.h:62: предупреждение: в декларации ‘Babl’ по умолчанию установлен тип ‘int’ [-Wimplicit-int]
/home/username/.local/include/gegl-0.2/gegl-buffer.h:62: ошибка: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
/home/username/.local/include/gegl-0.2/gegl-buffer.h:231: предупреждение: в декларации ‘Babl’ по умолчанию установлен тип ‘int’ [-Wimplicit-int]
/home/username/.local/include/gegl-0.2/gegl-buffer.h:231: ошибка: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
среди всей каши выделяю
/home/username/.local/include/gegl-0.2/gegl.h:23:23: error: babl/babl.h: Нет такого файла или каталога
Ошибки связаны с тем, что компилятор не видит пути к babl/babl.h в заголовочных файлах gegl
Что делаю, в рамках данного примера - открываю gegl.h в текстовом редакторе, и на 23 строчке этого файла меняю
include <babl/babl.h>
на
include "/home/username/.local/include/babl-0.1/babl/babl.h"
дальше выполняю make clean и снова make.
make clean нужно выполнять каждый раз перед выполнением повторной компиляции.
8.) После установки gimp-2.8 и его запуска в консоле появилась ошибка
(gimp:22705): Pango-CRITICAL **: No modules found:
No builtin or dynamically loaded modules were found.
PangoFc will not work correctly.
This probably means there was an error in the creation of:
  '/home/username/.local/etc/pango/pango.modules'
You should create this file by running:
  pango-querymodules > '/home/username/.local/etc/pango/pango.modules'

(gimp:22705): Pango-WARNING **: failed to choose a font, expect ugly output. engine-type='PangoRenderFc', script='cyrillic'

(gimp:22705): Pango-WARNING **: failed to choose a font, expect ugly output. engine-type='PangoRenderFc', script='common'

(gimp:22705): Pango-WARNING **: failed to choose a font, expect ugly output. engine-type='PangoRenderFc', script='latin'
и наблюдались проблемы со шрифтом в приложении. Решил проблему очень просто: в консоле выполнил следующую команду:
/home/username/.local/binpango-querymodules > '/home/username/.local/etc/pango/pango.modules
9.) В итоге имею рабочий gimp-2.8 в /home/username/.local без ломанных зависимостей в Debian Squeeze :)
запуск /home/username/.local/bin/gimp

hikkikamori ()
Ответ на: комментарий от hikkikamori

fixed

В итоге имею рабочий gimp-2.8 в /home/username/.local без ломанных зависимостей в слаке

lazyklimm ★★★★★ ()
Ответ на: комментарий от lazyklimm

Я тоже сначала думал перейти на сид, но в конце-концов решил поставить ubuntu, т.к. там уже собрано ядро со всеми энергосберегающими фичами для моего ноута, пропатчены шрифты и другие мелкие улучшения + релиз LTS, хотя назвать его стабильным после debian stable язык не поворачивается :)

BMX ★★☆ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.