LINUX.ORG.RU

Проблемы с GCC


0

0

У меня возникла такая проблема, точно не могу сказать после чего появилась,
возможно после перхода с 2.6.1 на 2.6.3-rc2. Теперь при попытке
чтонибудь собрать выдает такую лабуду:
/var/tmp/portage/gcc-3.3.3/work/gcc-3.3.3/libiberty/fibheap.c:285:
error: `LONG_MIN' undeclared (first use in this
function)
/var/tmp/portage/gcc-3.3.3/work/gcc-3.3.3/libiberty/fibheap.c:285:
error: (Each undeclared identifier is reported only
once
/var/tmp/portage/gcc-3.3.3/work/gcc-3.3.3/libiberty/fibheap.c:285:
error: for each function it appears in.)
make[1]: *** [fibheap.o] Error 1
make[1]: *** Waiting for unfinished jobs....
gcc -c -DHAVE_CONFIG_H -march=pentium3 -pipe -O2 -I.
-I/var/tmp/portage/gcc-3.3.3/work/gcc-3.3.3/libiberty/../include
-W -Wall
-Wtraditional -pedantic
/var/tmp/portage/gcc-3.3.3/work/gcc-3.3.3/libiberty/floatformat.c -o
floatformat.o
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/var/tmp/portage/gcc-3.3.3/work/build/libiberty'
make: *** [all-libiberty] Error 2

!!! ERROR: sys-devel/gcc-3.3.3 failed.
!!! Function src_compile, Line 464, Exitcode 2
!!! (no error message)

А если в make.conf убрать MAKEOPTS="j2" и оптимизацию -О3, то выдает
следующее:
/var/tmp/portage/gcc-3.3.3/work/gcc-3.3.3/libiberty/fibheap.c: In
function `fibheap_delete_node':
/var/tmp/portage/gcc-3.3.3/work/gcc-3.3.3/libiberty/fibheap.c:285:
error: `LONG_MIN' undeclared (first use in this
function)
/var/tmp/portage/gcc-3.3.3/work/gcc-3.3.3/libiberty/fibheap.c:285:
error: (Each undeclared identifier is reported only
once
/var/tmp/portage/gcc-3.3.3/work/gcc-3.3.3/libiberty/fibheap.c:285:
error: for each function it appears in.)
make[1]: *** [fibheap.o] Error 1
make[1]: Leaving directory `/var/tmp/portage/gcc-3.3.3/work/build/libiberty'
make: *** [all-libiberty] Error 2

!!! ERROR: sys-devel/gcc-3.3.3 failed.
!!! Function src_compile, Line 464, Exitcode 2
!!! (no error message)
Что бы это могло быть?
ЗЫ! Только сильно не пинайте, я в программировании почти ничего не
панимым...
Да, еще в догонку такой вопрос: при загрузке gnome каждый раз появляется
следующая ошибка:

There was an error starting the GNOME Settings Daemon.

Some things, such as themes, sounds, or background settings may not work
correctly.

The Settings Daemon restarted too many times.

The last error message was:

Child process did not give an error message, unknown failure occurred

GNOME will still try to restart the Settings Daemon next time you log in.
Что делать?
Заранее спасибо.

Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.