LINUX.ORG.RU

Добавить ссылку на библиотеку более новой версии чем требует rpm

 ,


0

1

NAME=«openSUSE Leap» VERSION=«15.0»

Пытаюсь установить pgsql от 1с, при установки rpm получаю ничто не предоставляет libcrypto.so.10()(64bit), необходимый для postgresql10-libs-10.5-9.1C.x86_64

Данной библиотеки нигде не смог найти, но гугл говорит что это одно и то же что и libcrypto.so.1.0.0

Там же советовали создать линк ln -s libcrypto.so.1.0.0 libcrypto.so.10 но это мне ничем не помогло.

В итоге имею https://i.imgur.com/WYks5T4.png Можете подсказать куда смотреть дальше? В линуксе 8 день. Просто хотел посмотреть поведение 1с в с постгри в нем.


Ответ на: комментарий от Deleted

Установил, т.к. с подробной проблемой человека на другом форуме просили показать вывод этой команды, надеялся что это мне поможет. Устанавливаю все через яст2 Какую команду мне следовало использовать?

ksen ()
Ответ на: комментарий от ksen

Человек на другом форуме проблему решал в centos/redhat, поэтому использовал yum. Для Suse родной пакетный менеджер - zypper, для него в дистрибутиве прописаны репозитории. Yum, вполне вероятно, вообще поставился без реп и неудивительно, что он ничего не может найти.
Тебе нуженг zypper search, zypper install, zypper wp. Либо, если насущной необходимости использовать Suse нет - взять тот же центос. На мой вкус, зюзя не самый подходящий дистрибутив для новичка, по крайней мере ответов на вопросы по ней в интернетах определенно меньше.

Deleted ()
Ответ на: комментарий от ksen

А партнер сказал ставить это на Suse 15? В 9 из 10 таких случаев подразумевается редхат и его клоны. А Suse 15 - это вообще довольно недавняя поделка, там действительно могут быть не те либы, на которые рассчитывает пакет.
rpm.tar.bz2 - это клиника какая- то.

Deleted ()
Последнее исправление: Deleted (всего исправлений: 1)
Ответ на: комментарий от ksen

У разных дистрибутивов Linux плохо с двоичной совместимостью. Читай внимательно на сайте 1с, под какие дистрибутивы оно рассчитано. Если отсылают к RHEL - может подойти CentOS аналогичной версии.

Да, можно потрясти бубном, но если 8 день в линуксе — лучше сразу накатить подходящий дистрибутив.

hobbit ★★★★★ ()
Ответ на: комментарий от Deleted

Это реальная информация или предположение? Наш 1с парнер вообще не знает на чем работает пг от 1с, написали в 1с, ждем ответа.

На всякий случай сращу спрошу, сам сейчас изучаю этот вопрос, что лучше для файлового сервера Debian или CentOS?

ksen ()
Ответ на: комментарий от mos

Прям как на форум 1с вернулся, ностальгия, столько же желчи и сарказма. Согласно информации найденной в интернете обычные пг не работает с 1с, нужны патчи, был выбор между пг от 1с и пг с сайта постгри про, для теста решили взять от самих эсников чтобы посмотреть как оно. z/OS наверное какая-то профессиональная шутка?

ksen ()
Ответ на: комментарий от ksen

вы хотите использовать серьёзный движок БД в производственных целях?

я просто уточнаю, поскольку ваши действия больше напоминают манипуляции какой-нибудь фитоняшки с целью установки нового фильтра в инстаграмме.

результат может разочаровать...

mos ★★☆☆☆ ()
Ответ на: комментарий от mos

Хотим посмотреть как оно, надеемся в будущем полностью перейти на связку линукс+пг+1с. Просто новый сервер уже есть в руках, а переход на новое по запланирован летом, есть время поиграться.

ksen ()
Ответ на: комментарий от ksen

Если делается самостоятельно то из реп (если вы конечно точно знаете что и зачем делаете, тогда не из реп можно)
Либо
В соотв. С тем что написано в вашем договоре с поддержкой БД

mos ★★☆☆☆ ()
Последнее исправление: mos (всего исправлений: 1)
Ответ на: комментарий от ksen

Возьмите centos или Debian. Ставить надо то, что лучше знает ваш админ. А партнёр просто не компетентен. Я знаю, что там поддерживается только rhel и debian, остальное - как повезёт.

Deleted ()
Ответ на: комментарий от mos

Им из реп pgsql не нужен. Пусть ставят центос и ставят тот самый пакет и работают. Там постгря с патчиком, который или ручками накладывать надо, или готовый у 1С брать. Иначе не взлетит.

Deleted ()
Ответ на: комментарий от Deleted

бэкдорчиком?)))

да понятно что нужно понимать что делаешь, и понятно что ТС не очень понимает)))

ты в курсе замуток 1С с постгресом, а они там уже свой линакс ломают.))

Установил, т.к. с подробной проблемой человека на другом форуме просили показать вывод этой команды, надеялся что это мне поможет.

при таком уровне ничего боюсь не поможет))

mos ★★☆☆☆ ()