LINUX.ORG.RU
ФорумGames

Так L4D2 вышло или нет?

 ,


0

2

Купил на распродаже, машинально ткнул установить, а оно таки начало устанавливаться. Так и качается не значась в списке игр на онтопик.

Обратное было с Cave Story и DD: они сначала появились в списке, но не качались (от кейв стори качалось всё кроме бинарников).

Ответ на: комментарий от anonymous

нет. я про то что нельзя ли собрать игру со всеми зависимостями в один пакет? что бы сделать боль минимальной.
Все очень плохо (С) Долан

actics ()
Ответ на: комментарий от actics

нет. я про то что нельзя ли собрать игру со всеми зависимостями в один пакет? что бы сделать боль минимальной.

Вместе с иксами и ядром от которого зависят иксы и драйвера?Это будет дистрибутив с профилем для виртуалки.Но во времена когда 10Гб-размер казуалки с двухмерной графикой,какойто +полгигабайта образ виртуалки с самой виртуалкой-незаметно будет.

anonymous ()

гм

~/Steam/SteamApps/common/Left 4 Dead 2$ ls
bin/  left4dead2/       left4dead2_dlc2/  left4dead2.exe  platform/
hl2/  left4dead2_dlc1/  left4dead2_dlc3/  left4dead2.ico  update/

~/Steam/SteamApps/common/Left 4 Dead 2$ ls bin
addoninstaller.app/       maplist_terror.txt      steam_appid.txt
addoninstaller_osx        materialsystem.dll      studiorender.dll
adminserver.dll           mdllib.dll              tier0_s.dll
bsppack.dll               mss32.dll               unicode.dll
bugreporter.dll           mssdolby.flt            unicows.dll
bugreporter_public.dll    mssds3d.flt             unitlib.dll
crashhandler.dll          mssdsp.flt              valve_avi.dll
datacache.dll             msseax.flt              vaudio_miles.dll
dxsupport.cfg             mssmp3.asi              vaudio_speex.dll
dxsupport_episodic.cfg    mssvoice.asi            vgui2.dll
filesystemopendialog.dll  msvcr71.dll             vidcfg.bin
filesystem_stdio.dll      parsifal.dll            vphysics.dll
gameui.dll                scenefilecache.dll      vscript.dll
inputsystem.dll           serverplugin_empty.dll  vstdlib.dll
launcher.dll              shaderapidx10.dll       vstdlib_s.dll
libcef.dll                stdshader_dx9.dll       vtex_dll.dll
libstdc++.so.6            steam_api.dll           xinput1_3.dll
Kalashnikov ★★★ ()
Последнее исправление: Kalashnikov (всего исправлений: 1)
Ответ на: комментарий от Kalashnikov

Что то у них не срослось. Откатили обратно. Но будем надеяться, что скоро появятся.

kilolife ★★★★★ ()
Ответ на: комментарий от actics

у тебя сверхважный сервер на десктопе?

У меня привычка, которую я не буду менять из-за игрушек. А повышение скила отладки лишним не будет.

router ★★★★★ ()
Ответ на: комментарий от vovans

ну, если бы мне за сие платили, может и я бы хвалил, но так как

Я что-то не понял, или ты сказал что мне за дебиан на десктопе платят? Где мне забрать свои деньги?

мне никто не платит за используемый мной дистрибутив, я просто использую то, что мне удобнее.

см. выше ответ actics'у

А стейблы дебианов и rhel пускай остаются для серверов.

+1. Но если ты про мой десктоп, там обычно debian testing

router ★★★★★ ()
Ответ на: комментарий от actics

Скорее всего - запустятся. В библиотеках нечасто ломают зависимости. Наоборот, сложности бывают с старыми библиотеками. Старые бинарные игрушки, собранные loki под старый libc6, до сих пор работают

Если всё же случится - придётся искать старый дистрибутив.

router ★★★★★ ()

Не запустицца - так же скачал второй халфлайф и производные от первого - подожди до офанонса.

bender ★★★★★ ()
Ответ на: комментарий от router

если проприетарщина так сильно попрет в линуксы, придется просто дулать аналог вайна для совместимости со старыми версиями линуксов. Как-то так. Собственно в этих ващих оффтопиках тоже не гарантируют запускабельность прог, написаных ещё под хп. Вроде как.

actics ()
Ответ на: комментарий от punya

ты гуглил и про STEAM_RUNTIME не слышал?

С чего ты взял?

router ★★★★★ ()
Ответ на: комментарий от actics

придется просто дулать аналог вайна для совместимости со старыми версиями линуксов.

В rhel это пакеты, в имени которых есть compat. В debian - принципиально разные версии библиотек входят в разные пакеты, можно устанавливать.

Говорю ж, старые игры loki под ЕМНИП libc6 2.1 спокойно запускаются

router ★★★★★ ()
Ответ на: комментарий от lexxus-lex

все, чего нет тут: http://steamdb.info/linux/

не запустится ни при каких обстоятельствах.

А вот Day of Defeat появился, кстати. Надо будет накатать новость

pashazz ★★★★ ()
Ответ на: комментарий от anonymous

anonymous> В каждой новой минорной версии ЛЮБОГО софта на линуксе-ломают ВСЕ АПИ.

В убунте это может и так. Но не в линуксе.

Quasar ★★★★★ ()
Ответ на: комментарий от actics

Игроделы нынче не такие компетентные пошли. Они обычно пользуют готовый движок, либо на скорую руку быдлокодят. И собирают абы как даже на венде.

Quasar ★★★★★ ()
Ответ на: комментарий от actics

Наоборот - если проприетарщина полным ходом попрёт на линукс, то о совместимости не надо будет думать, так как проприетарщики позаботятся о том, чтобы совместимость была. Они же криворукие и не умеют пересобирать программы.

Quasar ★★★★★ ()
Ответ на: комментарий от router

если у тебя стал последний видео драйвер то стим рантайм тоже попрет без багов

punya ★★ ()
Ответ на: комментарий от Quasar

В убунте это может и так. Но не в линуксе.

ой...ДАТЫШТО!!!!!!

QT4-В КАЖДОЙ МИНОРНОЙ ВЕРСИИ половину структур переименовывают или изменяют до несовместимости с предыдущей версией,часть функций выкидывают,на сайте в доках с АПИ QT-НА КАЖДУЮ МИНОРНУЮ ВЕРСИЮ СВОЕ АПИ(со своими ссылками на документацию для каждой версии).Если скажешь что это не так-ты ниразу не работал с QT.
Они даже ХЕЛОВОРДЫ в примерах стандартных-ПЕРЕПИСЫВАЮТ НА КАЖДУЮ ВЕРСИЮ.

библиотека openssl-несовместима с новыми и старыми версиями,также glut,также xulrunner,также всякие библиотеки работы с графикой-tiff jpeg png tga...все они не обладают совместимости со своимиже версиями...

Это краткий список того с чем лично сталкивался и слал лучи добра девелоперам.

(виндузятникам-имея свой фреймворк рендеринга GUI для винды,который естственно привязан к ВИНАПИ,и который ВНЕЗАПНО перестает компиляться из за переименований функций винами в висте,потом вин7,а щас вин8 где вообще перевернули весь процесс рендеринга GUI,инвалиды как все криво)

anonymous ()

Лучше бы Dota 2 портировали.

z00ke ()
Ответ на: комментарий от anonymous

Выдыхай. Кьют совместим снизу вверх в пределах мажорной версии. И можно хоть один пример переписанного хелло-ворлда?

Tweaker ★★★★ ()
Последнее исправление: Tweaker (всего исправлений: 1)
Ответ на: комментарий от anonymous

L2D2 портирована если не с самого выхода,так уже два года точно...где вы такие криокамеры достаете-фороникс играл более года назад в нативный Л4Д2 в офисе вальва....дауж вот они-потребители стимбокса

Понимаешь анончик, игра бывает портирована и «портирована». Например Team Fortress 2 - портирована, а Dungeon Defenders - «портирована». То, что представители фороникса играли два года назад - это совсем не показатель. Кто их знает, может они только скриншоты могли вменяемо делать, а не играть.

siphonops ★★★ ()
Ответ на: комментарий от router

А стейблы дебианов и rhel пускай остаются для серверов.

+1. Но если ты про мой десктоп, там обычно debian testing

ну так речь-то шла о Стиме и допотоптом глибце в rhel и стейбл дебе.

vovans ★★★★★ ()
Ответ на: комментарий от bsdfun

Добавь меня в стим, может как-нибудь сыграем =3 А, ты же у меня в жабире вроде есть..

z00ke ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.