LINUX.ORG.RU

Монтирование NTFS Debian Squeeze


1

1

Доброго времени суток. Вопрос такой - при попытке монтирования NTFS-раздела от обычного пользователя вылетает вот такое:

Error opening '/dev/sdb1': Permission denied
Failed to mount '/dev/sdb1': Permission denied
Please check '/dev/sdb1' and the ntfs-3g binary permissions,
and the mounting user ID. More explanation is provided at 
http://ntfs-3g.org/support.html#unprivileged

По ссылке ходил, сделал, как там сказано, но увы... Из-под рута монтируется прекрасно. Подскажите пожалуйста, что сделать, чтобы ntfs-разделы монтировались автоматически при подключении винта.

★★★★

Ответ на: комментарий от AITap

Автоматическое монтирование при подключении жесткого диска такое пишет, если mount -t ntfs-3g /dev/sdb /mnt/disk, пишет mount: only root can do that

PaRuSoft ★★★★ ()
Ответ на: комментарий от PaRuSoft

Автоматическое монтирование ... такое пишет, если mount -t ntfs-3g /dev/sdb /mnt/disk, пишет mount: only root can do that

Так, вы уж определитесь, оно автоматическое или нет ?

При автоматическом монтировании вам не нужно вручную писать какие-либо команды, за его работу отвечает udisk, dbus и consolekit. Возможно у вас что-то из этого не запущено, или нет разрешений в consolekit для монтирования съёмных накопителей для учётной записи, под которой вы работаете в DE, не знаю как в Debian настраиваются разрешения для consolekit, попробуйте добавить пользователя в указанную выше группу.

Если же вы монтируете вручную то либо от root либо через sudo, либо с помощью скрипта и бита suid.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Если не найдёте группу можете отредактировать файл политик consolekit /usr/share/polkit-1/actions/org.freedesktop.udisks.policy для udisks.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Спасибо большое, добавил в закладки на будущее, но проблему решил другим способом, установкой прав 775 на /media (куда по умолчанию всё монтируется). Возможно костыль, но всё же

PaRuSoft ★★★★ ()
Ответ на: комментарий от PaRuSoft
$ stat /media
  Файл: «/media»
  Размер: 4096      	Блоков: 8          Блок В/В: 4096   каталог

Доступ: (0755/drwxr-xr-x)  Uid: (    0/    root)   Gid: (    0/    root)

Ну вообще-то так и должно быть, только для root.

Если у вас было не так, значит вы сами что-то намудрили.

kostik87 ★★★★★ ()

Подскажите пожалуйста, что сделать, чтобы ntfs-разделы монтировались автоматически при подключении винта.

/etc/fstab

OvO ()
Ответ на: комментарий от PaRuSoft

установкой прав 775 на /media

Для доступа ко всем каталогам, кроме $HOME, нужны права суперпользователя.

OvO ()
Ответ на: комментарий от AITap

Попробуйте группы plugdev, disk, floppy.

Никакие группы не нужны.

OvO ()
Ответ на: комментарий от baaba

сам монтирую через судо руками:
/dev/sda2 /mnt/win ntfs-3g noauto,noatime,users,fmask=111,dmask=000 0 0

baaba ★★ ()
Ответ на: комментарий от baaba

По ссылке туксера, я с веб архива брал эту страницу, сделал то что там сказано, не помогало. по поводу монтирования руками - нафига, если можно автоматически?

PaRuSoft ★★★★ ()

usbmount монтирует автоматически.

neo@nvh:~$ grep -v ^# /etc/usbmount/usbmount.conf

ENABLED=1

MOUNTPOINTS="/media/flash0 /media/flash1 /media/flash2 /media/flash3 /media/flash4 /media/flash5 /media/flash6 /media/flash7"

FILESYSTEMS="vfat ext2 ext3 ext4 ntfs"

MOUNTOPTIONS="noexec,nodev,noatime,nodiratime"

FS_MOUNTOPTIONS="-fstype=vfat,uid=neo,gid=neo -fstype=ntfs-3g,uid=neo,gid=neo"

VERBOSE=yes

Для размонтирования pumount.

LinuxUser ★★ ()
Ответ на: комментарий от LinuxUser
"/media/flash0 /media/flash1 /media/flash2 /media/flash3 /media/flash4 /media/flash5 /media/flash6 /media/flash7"

А это в виде маски можно записать? например, /media/flash*

PaRuSoft ★★★★ ()
Ответ на: комментарий от PaRuSoft

Только эти директории должны быть заранее созданы. Например так:

mkdir /media/flash[0-7]

LinuxUser ★★ ()

чтобы ntfs-разделы монтировались автоматически при подключении винта.

В fstab и права на каталог.

amorpher ★★★★★ ()
Ответ на: комментарий от amorpher

Сам наступил на эти грабли, повторяю:
судо mount руками, других вариантов нет.
Правда на одном компьютере у меня таки получилось, но я не помню что сделал -)

baaba ★★ ()
Ответ на: комментарий от baaba
ivan@lenovo:~ $ sudo chmod +rw /mnt/win
ivan@lenovo:~ $ mount /mnt/win
Error opening '/dev/sda2': Permission denied
Failed to mount '/dev/sda2': Permission denied
Please check '/dev/sda2' and the ntfs-3g binary permissions,
and the mounting user ID. More explanation is provided at
http://ntfs-3g.org/support.html#unprivileged
ivan@lenovo:/tmp $ cat /etc/fstab|grep win
/dev/sda2   /mnt/win    ntfs-3g     noauto,noatime,users,fmask=111,dmask=000 0 0
baaba ★★ ()
Ответ на: комментарий от baaba
ivan@lenovo:/tmp $ ls -lhd /mnt/win
drwxrwxr-x 2 root ntfsuser 48 Мар 29  2010 /mnt/win

ivan@lenovo:/tmp $ cat /etc/group|grep ntfsu
ntfsuser:x:83:ivan

Ничего неподелать, пичалька

baaba ★★ ()
Ответ на: комментарий от baaba

Вариант есть!

Такая же проблема была. Решение возможно не очень правильное, но работает :)

Собственно на данном этапе проблема заключается в том, что у обычного пользователя нет доступа к файлам /dev/sd**, что логично. Более того, по умолчанию доступа нет и у группы, которая указана для этих файлов (в моем случае это группа disk, возможно на каких-то дистрах может быть другая):

anna@anna-desktop:~$ sudo ls -la /dev/sda1 
brw-rw---- 1 root disk 8, 1 2012-04-07 20:06 /dev/sda1
Решить это можно путем создания специальных правил для устройств в /etc/udev/rules.d/ Делаем файл 81-mount.rules (или редактируем что есть подходящего в этой директории). В нем прописываем что-то вроде:
KERNEL=="sd?1", ENV{ID_MODEL}=="ST1000LM010-9YH146", ACTION=="add", MODE="0666"
KERNEL=="sd?1", ENV{ID_MODEL}=="ST1000LM010-9YH146", ACTION=="change", MODE="0666" 
Комментарии: Первые три параметра в строке - условия, при которых должно выполнятся действие MODE=«0666». У меня внешние диски всегда определяются как sd[c-f]1, поэтому условие KERNEL==«sd?1», если устройство всегда sda2, то можно указать KERNEL==«sda2». Далее, чтобы исключить вероятность повышения прав на другие диски, в качестве условия жестко указывается модель моего внешника ENV{ID_MODEL}==«ST1000LM010-9YH146». Найти этот параметр можно, выполнив команду
~# udevadm info --query=all --path=/sys/block/sde/sde1/ | grep MODEL
E: ID_MODEL=ST1500LM003-9YH148
ACTION==«add» и ACTION==«change» соответственно событие добавления или изменения устройства в системе. Сохраняем, переподключаем устройство. В итоге получим уже такую картину:
# ls -la /dev/sde1 
brw-rw-rw- 1 root disk 8, 65 2012-04-07 20:08 /dev/sde1

Дальше все просто. Добавляем пользователя, от имени которого мы хотим монтировать диск в группу disk, проверяем наличие в fstab параметров монтирования user (разрешает обычному пользователю mount) и users (разрешает обычному пользователю umount), перелогиниваемся и все. У меня так работает, во всяком случае.

bloodwin ()
Ответ на: Вариант есть! от bloodwin

Сделал так, как ты написал. Теперь пишет

ntfs-3g-mount: failed to open /dev/fuse: Permission denied

DinoAsm ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.