LINUX.ORG.RU
решено ФорумAdmin

bacula не видит postgresql

 ,


0

1

Всем доброго времени суток , пытаюсь установить bacula на CentOS 7 . Столкнулся с проблемой что при проверке выдает : ./bacula-dir -f -c ./bacula-dir.conf -d 200

bacula-dir: postgresql.c:1126-0 db_init_database first time
bacula-dir: postgresql.c:241-0 pg_real_connect done
bacula-dir: postgresql.c:243-0 db_user=bacula db_name=bacula db_password=bacula
bacula-dir: dird.c:1015-0 Could not open Catalog "MyCatalog", database "bacula".
bacula-dir: dird.c:1020-0 postgresql.c:248 Unable to connect to PostgreSQL server. Database=bacula User=bacula
Possible causes: SQL server not running; password incorrect; max_connections exceeded.
15-Oct 00:21 bacula-dir ERROR TERMINATION
Please correct configuration file: /etc/bacula/bacula-dir.conf
При чем сам postgresql запущен и юзер bacula есть .
[root@bacula bacula]# psql -U bacula
Password for user bacula:
psql (9.6.5)
Type "help" for help.

bacula=# \l
                                  List of databases
   Name    |  Owner   | Encoding  |   Collate   |    Ctype    |   Access privileges
-----------+----------+-----------+-------------+-------------+-----------------------
 bacula    | bacula   | SQL_ASCII | C           | C           | =Tc/bacula           +
           |          |           |             |             | bacula=CTc/bacula
 postgres  | postgres | UTF8      | en_US.UTF-8 | en_US.UTF-8 |
 template0 | postgres | UTF8      | en_US.UTF-8 | en_US.UTF-8 | =c/postgres          +
           |          |           |             |             | postgres=CTc/postgres
 template1 | postgres | UTF8      | en_US.UTF-8 | en_US.UTF-8 | =c/postgres          +
           |          |           |             |             | postgres=CTc/postgres
(4 rows)

bacula=# \q
Можете подсказать в какую сторону копать?

Покажите описание «MyCatalog» и pg_hba.conf, а также часть postgresql.conf, где про сетевое соединение. Вероятно psql подключается, например, по unix сокетам, а бакула так не может по каким-то причинам.

gvtlor ()
Ответ на: комментарий от gvtlor
Catalog {
  Name = MyCatalog
# Uncomment the following line if you want the dbi driver
dbdriver = "dbi:postgresql"; dbaddress = 127.0.0.1; dbport = 5432
  dbname = "bacula"; dbuser = "bacula"; dbpassword = "bacula";
}

pg_hba.conf

local   all             all                                     md5
# IPv4 local connections:
host    all             all             127.0.0.1/32            ident
postgresql.conf
# - Connection Settings -

#listen_addresses = 'localhost'         # what IP address(es) to listen on;
                                        # comma-separated list of addresses;
                                        # defaults to 'localhost'; use '*' for all
                                        # (change requires restart)
#port = 5432                            # (change requires restart)
max_connections = 100                   # (change requires restart)
#superuser_reserved_connections = 3     # (change requires restart)
#unix_socket_directories = '/var/run/postgresql, /tmp'  # comma-separated list of directories
                                        # (change requires restart)
#unix_socket_group = ''                 # (change requires restart)
#unix_socket_permissions = 0777         # begin with 0 to use octal notation
                                        # (change requires restart)
#bonjour = off                          # advertise server via Bonjour
                                        # (change requires restart)
#bonjour_name = ''                      # defaults to the computer name
                                        # (change requires restart)

nobunaga161rus ()
Ответ на: комментарий от nobunaga161rus

Все спасибо, разобрался. Bacula подключалась не к локал хосту а через 127.0.0.1 и в pg_hba надо было выставить в

host    all             all             127.0.0.1/32            ident
вместо ident md5 и все взлетело.

nobunaga161rus ()
Ответ на: комментарий от nobunaga161rus

Да вроде нет, наоборот «psql -U» подключается через Unix domain socket. Надо было пробовать «psql -h 127.0.0.1 -U ...».

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.