LINUX.ORG.RU

pppoe траблы (+)


0

0

Думаю вопрос уже не раз подымался
но с ходу не нашел... а инет поднять срочно надо
В общем схема такая
есть модем Zyxel 645R
он бриджом повешен на сетевуху eth2 c IP 192.168.0.1
через него подымаю pppoe соединение
с провом.....
вопрос номер один по дефолту ppp0 mtu почему-то
1472 байта когда должно быть 1492
как сделать что правильно mtu выставлялось
при старте соединения, а то ifconfig ppp0 mtu 1492
выход но не красивый.....
дальше есть интерфейс eth0 172.16.0.254
смотрящий в локалку
на нем делается SNAT на IP ppp0 интерфейса
чтоб пустить юзеров в нет...
mtu на нем как обычно 1500
так вот пакеты с нета и в нет небольшого размера
летают нормально а вот максимального что-то никак
такая проблема у меня как-то возникала, и как-то я ее решил
правда вот как непомню в общем NEED HELP
да и еще если локально с этой тачки что-то качать все путем
проблема проявляется только с тачек в сети.....


anonymous

Re: pppoe траблы (+)

>повешен на сетевуху eth2 c IP 192.168.0.1

На шиша там вообще IP.

>1472 байта когда должно быть 1492

Совсем не обязательно, например при MPPE шифровании меньше. Скорее всего этот MTU выдаёт pppd провайдера, не меняйте его, провайдеру виднее что там у него.

qwe ★★ ()
Ответ на: Re: pppoe траблы (+) от qwe

Re: pppoe траблы (+)

Не должно быть 1492
с провом общался......
Но это ладно, а вот почему народ из сетки ходить не может
а локально все нормально ?

anonymous ()
Ответ на: Re: pppoe траблы (+) от anonymous

Re: pppoe траблы (+)

Если кому интересно
то проблема оказалась в конченом провайдере
Вот эта приблуда помогла
TCPMSS
This target allows to alter the MSS value of TCP SYN packets, to control the maximum size for that connec-
tion (usually limiting it to your outgoing interface's MTU minus 40). Of course, it can only be used in
conjunction with -p tcp.
This target is used to overcome criminally braindead ISPs or servers which block ICMP Fragmentation Needed
packets. The symptoms of this problem are that everything works fine from your Linux firewall/router, but
machines behind it can never exchange large packets:
1) Web browsers connect, then hang with no data received.
2) Small mail works fine, but large emails hang.
3) ssh works fine, but scp hangs after initial handshaking.
Workaround: activate this option and add a rule to your firewall configuration like:
iptables -A FORWARD -p tcp --tcp-flags SYN,RST SYN \
-j TCPMSS --clamp-mss-to-pmtu

--set-mss value
Explicitly set MSS option to specified value.

--clamp-mss-to-pmtu
Automatically clamp MSS value to (path_MTU - 40).

These options are mutually exclusive.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.