LINUX.ORG.RU

0
Всего сообщений: 30

Нет интернета с родным MAC адресом роутера

Проблема старая, неактуальная, но хочу развеять неувязочки в этой ситуации. Интернет дома билайн, роутер Tp-link AX50, купил в том году, и были проблемы с подключением после установки - айпи не брал. Как помню, билайн не смог помочь, а поддержка tp-link подсказала включить клонирование MAC адреса устройства, и заработало.

Вопрос: почему? Билайн не любит мой роутер, или вопрос технический? Могу ли я это исправить? И есть ли огрехи в моей текущей настройки (на работу интернета не жалуюсь, но все вышеперечисленные вопросы не отменяются)?

 ,

xt1zer ()

systemd изменить мак адрес eth0 и eth1

создал 2 файла

# cat /lib/systemd/network/10-eth0.link 
[Match]
PermanentMACAddress=50:2d:f4:14:14:6b
[Link]
Name=eth0
MACAddress=00:04:70:b3:d5:b6

и

# cat 11-eth1.link 
[Match]
PermanentMACAddress=50:2d:f4:14:14:6c
[Link]
Name=eth1
MACAddress=00:04:71:b3:d5:b6

с мак адресами не ошибся, без этих файлов вот такой вывод ifconfig

eth0      Link encap:Ethernet  HWaddr 50:2D:F4:14:14:6B  
          inet addr:10.162.1.2  Bcast:10.162.1.255  Mask:255.255.255.0
          inet6 addr: fe80::522d:f4ff:fe14:146b%lo/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:60 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:516 (516.0 B)  TX bytes:11517 (11.2 KiB)

eth1      Link encap:Ethernet  HWaddr 50:2D:F4:14:14:6C  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

после перезагрузки

eth0      Link encap:Ethernet  HWaddr 00:04:70:B3:D5:B6  
          inet addr:10.162.1.2  Bcast:10.162.1.255  Mask:255.255.255.0
          inet6 addr: fe80::204:70ff:feb3:d5b6%lo/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:33 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:344 (344.0 B)  TX bytes:6434 (6.2 KiB)

eth1      Link encap:Ethernet  HWaddr 00:04:70:B3:D5:B6  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

как видно, мак адреса одинаковые, подскажите, как поправить?

 , ,

IvanR ()

Определение модели девайса в wifi по bssid

Здравствуйте,и у меня снова возникла проблема. Допустим у меня есть mac-адрес устройства в сети wifi,но сам я туда не подключен. Вопрос - как узнать производителя и модель устройства через mac или другими способами не подключаясь к wifi? Я видел сайты которые определяют производителя,но…это неудобно,не определяет модель и через браузер.Есть ли какие-то консольные утилиты,которые я мог бы использовать,чтобы идентифицировать любое устройство,чтобы понять кто есть кто? Надеюсь на вашу помощь. P.S.Если я задал глупый вопрос или где-то не разбираюсь имейте ввиду,что я не так давно работаю в этой области и в процессе изучения. Используемые мною команды:

airmon-ng check kill
airmon-ng start wlp3s0
airodump-ng wlp3s0mon
aireplay-ng --deauth 0 -a xx:xx:xx:xx:xx:8D wlp3s0mon
airodump-ng --bssid (target bssid value) -c 11 wlan1

 , , ,

Kirilus3000 ()

Не меняет mac адрес wlan0

Я пытался вот так поменять мак адрес: 1# ifconfig wlan0 down | 2# ifconfig wlan0 hw ether 00:11:22:33:44:55 | 3# ifconfig wlan0 up |

Мак адрес после второй команды меняется, но после поднятия wlan0 всё сбрасывается :( С eth0 такой проблемы нет, а с wlan0 почему то есть

 , ,

nin922 ()

Вуйфуй радары или что у телефонов другая модель osi?

Не корысти ради, а из зоолюбопытства как то забрел на сайт продающий вуйфуй радары. Думаю неужели из обычного роутера можно радар уже сделать да еще и софтварно. Все оказалось куда проще и скучнее. Это обычный роутер настроеный на скрытый ssid, который просто собирает маки всех проходящих мимо, у которых лопата хватается за любые точки в округе и постоянно сканирует. Интересно, подумал я, а какой в этом прок (еще и за деньги это покупать ведь)? Внизу сайта было прикреплено видево, где мальчег в нерозовой рубашке объяснял, что собранные таким образом мак-адреса телефонов, скармливаются яндексу. А вот дальше самое интересное. Допустим Вася несколько раз в неделю проходит мимо смузярни «у Ашота» и его мак в логах появлется несколько раз. Яндекс узнает об этом и начинает бомбить Васю рекламой как раз этой смузярни (имплаинг раз он ходит рядом то шанс что зайдет выше чем что специально поедет). А самому Ашоту, Яндекс делает потом красивую табличку сколько мимокрокодилов за месяц я сконвертил в твоих посетителей. И вот тут у меня возникли вопросы, на которые мальчик из видева ответа не дал (а зрители в зале и не спрашивали), так что может быть тут подскажут.

1. У меня на ноуте например мак адрес проводного порта и фуйфуя отличаются настолько что и не скажешь что это вообще один комп. А на лопатах что, мак вуйфуя совпадает полностью с маком 3-4-5-же адаптера?

2. И самое главное - Вот допустим Яндекс знает Васин мак, но Вася никогда не присоединяется к Яндексу напрямую, всегда через какой то роутер(а скорее цепочку из них, иначе как). А маки действуют в пределах одной подсети. Если ты со своего компа попингаешь yandex.ru а потом наберешь arp -a то напротив адреса яндекса ты увидишь лишь мак ближайшего роутера и все. Вопрос - Как Яндекс даже зная мак Васи определит что это именно Вася, у телефонов что другая модель OSI и маки передаются до конечной точки, сохраняясь на каждом роутере (это даже на IPV6 не всегда есть)?

 , , ,

justin_case ()

Сгенерировать валидные mac адреса android

Приветствую!

Для генерации mac-адресов использую такую команду, найденную в интернете od /dev/urandom -w6 -tx1 -An|sed -e 's/ //' -e 's/ /:/g'|head -n 1 Сгенерированный таким образом mac-адрес не найден в базах вендоров, мне же нужно, чтобы сгенерированные mac-адреса определялись как какие-нибудь производители смартфонов. Как это накостылять на bash/sh?

Благодарю.

 

D3306 ()

Atheros и MAC адрес - проблемки на ровном месте

Всем доброго времени суток. Есть один интересный кейс, суть вот в чем: посмотрев на мать своего ноута, обнаружил, что сетевку AR8152 можно заменить на AR8151, при условии добавления мелочевки вокруг. Заменил, добавил, все работет. Но есть нюанс: MAC адрес на ней рандомно меняется, на старой такого не было.

Есть момент: я могу прописать адрес руками в софт, но не хочу, нужно от этого аппарата более устойчивое положение в сети при замене софта

На реалтеке я менял адрес, зашив в сетевку спец утилитой, а на сайте Qualcomm я чуть ноги не сломав так и не нашел куда им писать вопросы подобного характера.

Может кто знает, можно ли чем-нибудь вшить адрес в сетевуху? Не важно каким софтом и под какую платформу.

 , ,

lord_iu ()

Одновременно несколько модемов не работают в Debian

del, т.к. все было написано неправильно и практической смысловой нагрузки не несет, а только запутает тех, кто будет читать.

 ,

neuro75 ()

Определить MAC адрес WAN интерфейса роутера

Привет!

А можно каким-то способом определить MAC адрес, принадлежащий именно WAN порту на роутере? Если в админке ничего нет. И наклейки на роутере с такими данными тоже нет.

В админке роутера есть мак адреса интерфейсов в сторону локальной сети, но не WAN. Т.е. если адрес обоих Wifi 2,4 и 5 ГГц. Есть адрес Ethernet порта, к которому компьютер подключен. Но эти адреса я и без админки могу посмотреть. Например, командой arp.

А вот как посмотреть адрес именно WAN - загадка.

Еще я пробовал поглядеть через WireShark. Но там тоже только адрес компа и порта роутера в сторону компа. Адреса порта во внешку нету.

 ,

hibou ()

Смена mac-адреса на NetBSD

Всем привет. Юзаю Apple Time Capsule четвёртого поколения. Есть необходимость сменить на нём мак-адрес Ethernet-порта, по которому поступает инет в роутер. Погуглив, становится ясно, что в таких роутерах мак-адрес не меняется смертными. Подключился к капсуле по ssh, а там NetBSD стоит. Выхлоп uname -a:

NetBSD airport-time-capsule 4.0_STABLE NetBSD 4.0_STABLE #0: Fri May 24 20:57:25 PDT 2019  root@xapp190.apple.com:/BuildRoot/Library/Caches/com.apple.xbs/Sources/K30B/AirPortFW-78100.3/Embedded/Firmware/NetBSD/Targets/K30B/release/obj/build.kernel-target.conf evbarm

Список сетевых интерфейсов ifconfig:

airport-time-capsule# ifconfig
mgi0: flags=e943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,LINK1,LINK2,MULTICAST> metric 0 mtu 1500
        options=83f80<TSO4,IP4CSUM_Rx,IP4CSUM_Tx,TCP4CSUM_Rx,TCP4CSUM_Tx,UDP4CSUM_Rx,UDP4CSUM_Tx,LRO4>
        extra flag=1<NOINET6>
        ether 70:73:cb:b3:61:2a
        media: none (none)
mgi1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=83f80<TSO4,IP4CSUM_Rx,IP4CSUM_Tx,TCP4CSUM_Rx,TCP4CSUM_Tx,UDP4CSUM_Rx,UDP4CSUM_Tx,LRO4>
        extra flag=0<>
        ether 70:73:cb:b3:61:2a
        inet6 fe80::7273:cbff:feb3:612a%mgi1 prefixlen 64 scopeid 0x2
        inet 192.168.0.9 netmask 0xffffff00 broadcast 192.168.0.255
        inet 169.254.232.77 netmask 0xffff0000 broadcast 169.254.255.255
        media: none (none)
bwl0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 2290
        options=80000<LRO4>
        extra flag=0<>
        ether 70:73:cb:b8:59:55
        media: autoselect mode 11ng hostap
        status: running
bwl1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 2290
        options=80000<LRO4>
        extra flag=0<>
        ether 70:73:cb:b8:59:56
        media: autoselect mode 11na hostap
        status: running
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 33172
        extra flag=0<>
        inet 127.0.0.1 netmask 0xff000000
        inet6 ::1 prefixlen 128
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5
        inet 127.0.0.2 netmask 0xff000000
wlan0: flags=e943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,LINK1,LINK2,MULTICAST> metric 0 mtu 1500
        options=80000<LRO4>
        extra flag=1<NOINET6>
        ether 70:73:cb:b8:59:55
        media: autoselect mode 11ng hostap
        status: running
        ssid "AirPort Time Capsule" channel 1 (2412 Mhz 11g ht/20) bssid 70:73:cb:b8:59:55
        authmode WPA2/802.11i privacy ON deftxkey 2 AES-CCM 2:128-bit
        txpower 11 dotd mcastrate 2 scanvalid 60 protmode CTS ht20 -htcompat
        ampdulimit 64k ampdudensity 8 -amsdutx amsdurx shortgi stbc ldpc wme
        burst dwds dtimperiod 3 -dfs -inact rrm
wlan1: flags=e943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,LINK1,LINK2,MULTICAST> metric 0 mtu 1500
        options=80000<LRO4>
        extra flag=1<NOINET6>
        ether 70:73:cb:b8:59:56
        media: autoselect mode 11na hostap
        status: running
        ssid "AirPort Time Capsule" channel 100 (5500 Mhz 11a ht/40+) bssid 70:73:cb:b8:59:56
        authmode WPA2/802.11i privacy ON deftxkey 2 AES-CCM 2:128-bit
        txpower 17.5 dotd mcastrate 6 mgmtrate 6 scanvalid 60 -htcompat
        ampdulimit 64k ampdudensity 8 -amsdutx amsdurx shortgi stbc ldpc wme
        burst dwds dtimperiod 3 -inact rrm
bridge0: flags=8043<UP,BROADCAST,RUNNING,MULTICAST> metric 0 mtu 1500
        options=83f80<TSO4,IP4CSUM_Rx,IP4CSUM_Tx,TCP4CSUM_Rx,TCP4CSUM_Tx,UDP4CSUM_Rx,UDP4CSUM_Tx,LRO4>
        extra flag=2<PFQUICKPASS>
        ether 70:73:cb:b3:61:2a
        inet6 fe80::7273:cbff:feb3:612a%bridge0 prefixlen 64 scopeid 0x8
        inet 192.168.1.1 netmask 0xffffff00 broadcast 192.168.1.255
        priority 32768 hellotime 2 fwddelay 15
        maxage 20 holdcnt 6 proto stp maxaddr 100 timeout 1200
        member: wlan1 flags=3<LEARNING,DISCOVER>
        member: wlan0 flags=3<LEARNING,DISCOVER>
        member: mgi0 flags=3<LEARNING,DISCOVER>

На корпусе указан мак адрес тот же, что и у устройств mgi0, mgi1 и bridge0. Я так понимаю, что менять его надо именно у bridge0. Вопрос: как ему сменить мак-адрес? При попытке изменения получаю ошибку:

airport-time-capsule# ifconfig bridge0 ether d4:3d:7d:2d:80:d0
ifconfig: ioctl (SIOCAIFADDR): Inappropriate ioctl for device

Для mgi0 и mgi1 то же самое.

 , ,

mrmilesprower ()

входящий трафик посмотреть mac адрес

как посмотреть mac адреса на входящий трафик?

 

kommersant ()

Ошибка при смене mac адреса (macchanger)

Пытаюсь зарандомить mac адрес через macchanger

Запускаю так: sudo macchanger -r <интерфейс> Получаю ответ: [ERROR] Could not change MAC: interface up or insufficient permissions: Too many open files in system

Сначала думал, что дело в открытых файловых дескрипторах, пытался ковырять через ulimit и в конфигах limit.conf - не помогло (либо руки кривые, либо ошибка не совсем в этом)

Пробовал ложить интерфейс и менять мак, ничего не помогает Может кто сталкивался с этим или подскажет, что еще можно попробовать?

если меняю руками: ip link set dev, то так же выводит

RTNETLINK answers: Too many open files in system

 ,

mrostrich ()

Ограничение скорости клиентам по MAC

У меня есть маршрутизатор с ОС OpenWRT. Как ограничить скорость клиентам по MAC? Клиенты подключены по WIFI

 , ,

Caesium137 ()

смена мас адреса

Если я поменяю мас адрес с помощью macchanger на одной ос,то будет ли корректно wifi работать на другой ос?обе ос линукс, стоят на ноутбуке

 ,

xxx228 ()

Как узнать mac адрес на машине при помощи Python

Подскажите как определить (любой) из мак адресов на машине, мне нужно каким-нибудь образом получить уникальный номер машины. Смотрел примеры, но там все зависит от сетевого интерфейса, а я в принципе не знаю какой у машины будет интерфейс, мне бы хоть какой.

 

da17 ()

Здравствуйте. Помогите решить проблему с NetworkManager и Openwrt.

Здравствуйте. Поставил на роутер от мэйзу (r3) openwrt, он не хотел менять свой мак из под граффона, сменил через конфиг, инет зарботал, но почему то ноутбуки на arch linux перестали подключаться через NetworkManager а через dhcpcd нормально идёт, смартфонам пофиг они и так и сяк подключаются. В чём проблема? Как исправить? cat /etc/config/network

  • config interface 'loopback'
  • option ifname 'lo'
  • option proto 'static'
  • option ipaddr '127.0.0.1'
  • option netmask '255.0.0.0'
  • config globals 'globals'
  • option ula_prefix 'fd04:323e:6bab::/48'
  • config interface 'lan'
  • option type 'bridge'
  • option ifname 'eth0.1'
  • option proto 'static'
  • option ipaddr '192.168.1.1'
  • option netmask '255.255.255.0'
  • option ip6assign '60'
  • option macaddr '28:10:7B:EC:90:08'
  • config device 'lan_dev'
  • option name 'eth0.1'
  • option macaddr '28:10:7B:EC:90:08'
  • config interface 'wan'
  • option ifname 'eth0.2'
  • option proto 'dhcp'
  • option macaddr '50:64:2B:C6:6B:B5'
  • config device 'wan_dev'
  • option name 'eth0.2'
  • option macaddr '28:10:7B:EC:90:08'
  • config interface 'wan6'
  • option ifname 'eth0.2'
  • option proto 'dhcpv6'
  • option reqaddress 'try'
  • option reqprefix 'auto'
  • option macaddr '50:64:2B:C6:6B:B6'
  • config switch
  • option name 'switch0'
  • option reset '1'
  • option enable_vlan '1'
  • config switch_vlan
  • option device 'switch0'
  • option vlan '1'
  • option ports '1 4 6t'
  • config switch_vlan
  • option device 'switch0'
  • option vlan '2'
  • option ports '0 6t' На вот этот мак 28:10:7B:EC:90:08 я менял

 , , , ,

MIISHA ()

Как изменить MAC Bluetooth ?

Как можно из терминала поменять MAC bluetooth и заодно подскажите как сделать так чтобы после перезагрузки он сбрасывался на родной.

 , ,

Saltas768 ()

Как менять физический адрес с macchange и как делать это автоматически?

Ноут с Линукс минт, подключен к Wi-fi роутеру.

Пробую сделать смену адреса сетевому интерфейсу ноута:

sudo ifconfig wlan0 down

sudo macchanger -r wlan0

sudo ifconfig wlan0 up

Проверяю - ifconfig

Адрес сменился на рандомный, но сеть не работает.

Выключаю и включаю менеджер соединений sudo service network-manager stop

sudo service network-manager restart

сеть опять работает, но адрес восстановился к первоначальному.

1. Почему не работает сеть при смене (у роутера нет ограничений по МАКам)?

2. Почему МАК сбрасывается при любом действии - отключение/включение менеджера сетей, перезагрузка?

3. Можно ли сделать смену МАК-адреса автоматически, при каждой новой загрузке? Пробовал /etc/network/if-pre-up.d/macchanger:

#!/bin/sh

/usr/bin/macchanger -r «$IFACE», но не работает :(

Заранее спасибо за помощь.

P.S. Пробовал macchanger-gtk, так он вообще ничего не меняет. Что старый, что новый адрес отображает первоначальный.

 

Bedator ()

Блокировка сайта/определенной страницы OpenWRT LEDE LuCI

Всем привет, вопрос остаётся открытым, так как читал старые темы, и ничего не получается, да и вообще в настройках LuCI особенно в Межсетевом экране трудновато.

Хотелось бы все же увидеть ответ: 1. Как заблокировать сайт или определенную страницу ? -Возможно в LuCI есть какие то модули, которой будет просто управлять. 2. Как заблокировать сайт определенному ИП\МАК сайт ? 3. Как сделать «Блэк лист» плохих сайтов, чтобы выше п.1 или 2 парсили этот «Блэк лист» ?

С ув. Иван.

 , , , ,

L4D2 ()

Смена mac-a

Если сменю mac на kali данным способом http://www.thecurrent.ru/entry/kak-pomenyat-mac-adres-v-kali-linux-ispolzovan... То после перезагрузки у меня будет мой реальный мак или уже смененный?

 , ,

topkek ()