LINUX.ORG.RU

TP-Link WR1043ND с OpenWRT нет линка на WAN


0

4

есть новый TP-Link WR1043ND. С ним происходят довольно странные вещи - при установке на него OpenWRT или DDWRT не поднимается линк на WAN порту, хотя в заводской прошивке этот порт работает без проблем. В чем может быть причина? В openwrt заходил по ssh смотрел вывод swconfig - no link.

К порту подключал разные кабели - от провайдера, от компьютера, от другого маршрутизатора - физический линк никак не поднимается, но стоит залить заводскую прошивку и сразу есть линк.

На коробке написана ревизия 1.8.

openwrt пробовал stable 10.03 и 10.03-1-rc6, результат одинаков

HighwayStar ★★★★★ ()
Ответ на: комментарий от unikum

а как он должен определяться? там switch определяется. swconfig сам порт видит

стальные порты в свитче работают нормально

HighwayStar ★★★★★ ()

Буквально позавчера купил этот роутер. На OpenWRT не мог поднять т.н. Dual Access. Поставил DD-WRT, Все ок. Ревизия та же. Какие билды заливал и как?

N1ghtmare ★★ ()
Ответ на: комментарий от inoremap

да, симптомы очень похоже, перед openwrt ставил последнюю бету от tp-link, потом правда откатывался, но не на совсем старые. сейчас попробую ту, которая вроде бы была искаропки

HighwayStar ★★★★★ ()
Ответ на: комментарий от N1ghtmare

я выше писал, openwrt ставил все билды и стабильный, и development и сборку с хобота и снапшот транка от 16 декабря, везде линка не было. dd-wrt тоже пробовал, точно так же линк не поднимался. Заливал через веб-интерфейс официальной прошивки, и из вебинтерфейса openwrt

HighwayStar ★★★★★ ()
Ответ на: комментарий от HighwayStar

так, залил прошивку 100609 - получил кирпич, но бутлоадер вроде живой, завтра доберусь до UART кабеля продолжу процесс.

Такая же история с кирпичом была когда я из последней беты заводской прошивки прошил Openwrt, так что похоже я на правильном пути. Первый раз из кирпича восстанавливал - заливал сразу обновленную заводскую, потом openwrt, с тех пор WAN порт в openwrt не работал

HighwayStar ★★★★★ ()
Ответ на: комментарий от N1ghtmare

На OpenWRT не мог поднять т.н. Dual Access. Поставил DD-WRT, Все ок.

а доступ в интернет через что? у меня l2tp от билайна, ddwrt же вроде искаропки не умеет? для openwrt вроде легко прикручивается руками по инструкциям с хобота. хотя мне бы WAN порт оживить, дальше уже попробую что лучше пойдет dd или open

HighwayStar ★★★★★ ()

для протокола:

[искаропки 100609] -> [wr1043nv1_en_3_13_4_up(110429).bin] -> [wr1043nv1_en_3_13_5_up_boot(111122).bin] -> [сборка openwrt с хобота] -> [кирпич] -> [wr1043nv1_en_3_13_4_up(110429).bin] -> [различные версии openwrt и ddwrt] -> [WAN работает только в стоковой 110429]

[wr1043nv1_en_3_13_4_up(110429).bin] -> [100609] - > [кирпич]

to be continued...

HighwayStar ★★★★★ ()
Ответ на: комментарий от HighwayStar

Доступ в интернет через PPPoE, Не смог настроить маршруты в локальную сеть.

N1ghtmare ★★ ()

из кирпича поднял, попробовал заливать старые прошивки, но пока WAN порт оживить не удалось.

dmesg после загрузки в openwrt с подключенным кабелем толкьо на WAN порту

http://pastebin.com/wjPUcJBh

HighwayStar ★★★★★ ()
Ответ на: комментарий от HighwayStar

видимо в прошивках с сайта нет caldata, который мог быть испорчен и нужно чтобы кто-то слил прошивку с другого 1043, где WAN порт еще работает?

HighwayStar ★★★★★ ()

если кто может сделать бэкап u-boot с устройства на которое не ставилась прошивка бета 111122. буду очень балгодарен

инструкция как это сделать на сайте openwrt

HighwayStar ★★★★★ ()
Ответ на: комментарий от inoremap

и что блджад произойдет? МАГИЯ? ппц просто поражают такие инструкции.

parrot ()
Ответ на: комментарий от HighwayStar

http://rghost.ru/35502936
open@sentinels:~/tplinkbackupmtd$ md5sum uboot
4666bf48005c5672977a085ef7388f90 uboot держи братюнь с изкарапочного tp-link rev1.8(dd if=/dev/mtdblock0)

хотя в вашу магию прошивок не верю - выложи дифф юбутов

parrot ()
Ответ на: комментарий от HighwayStar

Вообще, очень странная ситуация, т.к. я на аналогичном девайсе пробовал все доступные для него прошивки. Описанных вами проблем не наблюдал. Может имеет место брак устройства. Если брали недавно, может изменилась версия.

unikum ★★★★★ ()
Ответ на: комментарий от parrot

спасибо, сейчас собираю прошивку с разрешением на запись в uboot

магия там простая, в бете от tp-link 111122 обновили не толкьо прошивку, но и uboot. прошивка называется «против свечения клиентских маков на WAN» видимо во время загрузки WAN отключается физически, а потом в заводской прошивке каким-то образом включается после загрузки

дифф убута можно посмотреть скачав эту прошивку http://forum.tp-linkru.com/fws/wr1043nv1_en_3_13_5_up_boot(111122).bin

HighwayStar ★★★★★ ()

а может что со встроенным свичом намутили? там сам интерфес то взлетает?
у меня прекрасно работает опенврт на 941 и 1043.

ktk ★★★ ()
Ответ на: комментарий от ktk

именно, физически WAN порт отключается и после загрузки в openwrt не включается

HighwayStar ★★★★★ ()
Ответ на: комментарий от HighwayStar

хм. сегодня вечером сделаю дамп своей прошивки и попробую накатить последнюю от tp-link.
и посмотрю как себя транк openwrt поведет.

ktk ★★★ ()
Ответ на: комментарий от ktk

проблемы начинаются не от последней, а тольк от беты 111122, которая заменяет и загрузчик

HighwayStar ★★★★★ ()

все починил, после сборки openwrt trunk с патчем для разрешения записи в u-boot (mtd0) залил старый u-boot и после перезагрузки WAN порт заработал. Уже настроил интернет через openwrt

HighwayStar ★★★★★ ()
Ответ на: комментарий от HighwayStar

Доброго времение суток. Не могли бы выложить прошивку и старый бут? Сам поймался на такую же засаду :( И если не сложно инструкцию по замене бута на более старый.

anonymous ()
Ответ на: комментарий от anonymous

на ixbt пишут что помогает заводская прошивка 10033, которую можно найти на немецком сайте TP-link В нее включен старый загрузчик, который не отключает WAN порт при загрузке

HighwayStar ★★★★★ ()
Ответ на: комментарий от anonymous

только 100331 нужно шить из под заводской прошивки, а не из под openwrt, иначе получится кирпич. при откате с беты на стабильные заводские у меня тоже кирпич получался и требовалось восстановление через uart.

лучше всего с нерабочей openwrt залить любую стабильную заводскую без загрузчика, и потом из нее прошивку с немецкого сайта

HighwayStar ★★★★★ ()
Ответ на: комментарий от HighwayStar

Спасибо за ответ. Но я уже нашел wr1043nv1_en_3_9_17_up_boot(091118).bin Естественно сначала вернул с оперврт на сток, потом залил wr1043nv1_en_3_9_17_up_boot(091118).bin, потом снова опенврт - и ван порт работает.

anonymous ()
Ответ на: комментарий от anonymous

О всезнающие ГУРУ! Дайте пожалуйста ссылочку на эту магическую прошивку (wr1043nv1_en_3_9_17_up_boot(091118).bin). Ибо не могу я нее найти на просторах Инета. :-( А без нее ну никак WAN не поднимается на OPENWRT.

anonymous ()
Ответ на: комментарий от pekmop1024

На него лучше транк.

Угу. Поставил - отвалился wifi. Через неделю обновился - отказался загруаться. Теперь кабель для прошивки ищу(

anonymous ()
Ответ на: комментарий от anonymous

вот 100331 с немецкого сайта TP-Link, он тоже со старым бутлоадером(Прошивать только из под заводской прошивки!). Почему-то с немецкого сайта уже старые версии поудаляли, хорошо что все сохранил у себя.

de_20104195585311.zip

HighwayStar ★★★★★ ()
Ответ на: комментарий от anonymous

это же транк, читай багтрекер... там аккуратно надо.

pekmop1024 ★★★★☆ ()
Ответ на: комментарий от anonymous

Как поднять WAN без прошивки

Отключается только 0 порт, так что поправив конфиг и переткнув WAN в другой порт, решаем проблему. Мне все равно 5 портов не нужны.

uci set network.@switch_vlan[0].ports=«2 3 4 5t» uci set network.@switch_vlan[1].ports=«1 5t» reboot

anonymous ()
Ответ на: комментарий от HighwayStar

=(

все зделал как вы написали ван засветился смотрю дают мне айпишник провайдер (внетриняя сеть вроде работает с ноутом) а в инет не подключается через пппое..=(

hall4 ()
Ответ на: вот фото настроек которые наклацал от hall4

так на картинке 1jpg_1622803_4031454.jpg написано же «Подключено».

кроме выбора типа соединение pppoe и ввода логина и пароля никаких настроек делать ненужно. можно попробовать еще удалить «Имя службы» на первом скриншоте, если провайдер явно не требует его указывать

HighwayStar ★★★★★ ()

Дело в ревизии, DD-WRT поддерживает только 1.1 и 1.4, OpenWRT тоже не поддерживает 1.8. Релиз ожидается февраль-март.

anonymous ()
Ответ на: комментарий от HighwayStar

спасибо

два дня мучался, тыркал альтернативные прошивки туда-сюда, линка на wan порту не было. Наткнулся на эту ветку, залил официальную со старым uboot (немецкая 100331). И WAN поднялся. огромное спасибо!!! А то уже думал, что порт спалил. Сейчас залита openwrt, wan порт работает.

anonymous ()
Ответ на: спасибо от anonymous

СПАСИБО

Так же мучались, не работал wan на openwrt.

сделал ка вы советывали 1. Откатили по этой инструкции http://forum.ixbt.com/topic.cgi?id=14:51517:2131#2131 Скачать официальную прошивку: -------------------------------------------------------------------------------- wget http://www.tp-link.com/english/soft/201082817292310.zip -O fw.zip 2. Заливаем немца http://rghost.ru/36040799 прошивка wr1043nv1_de_3_9_17_up_boot(100331).bin 3. прошивка openwrt

Все работает

anonymous ()

Да будет WAN!

Модель TP-LINK TL-WR1043ND. Новый. Боролся я с этим WAN портом почти два дня... Не светится, и всё тут. Все перепробовал. Перечитал все форумы... Попил крови у оператора (они мне даже в подъезде кабеля переложили...), проконсультировался в представительстве TP-LINK, перепрошивал... Один роутер даже сдал в магазин. На выходе - НОЛЬ. Никто ничего не знает... И это при том, что роутер новый и WAN-порт рабочий (это можно проверить, соединив WAN-порт с компьютером или соединив WAN-порт с WLAN-портом) и в сети другого оператора - тоже светится.... Помогла прошивка от 10 февраля 2012 г. с англоязычной страницы официального сайта (прошивки с российского и украинского сайтов TP-LINK - почему-то оказались дохлыми). Качайте и наслаждайтесь: http://www.tplink.com/en/support/download/?model=TL-WR1043ND

Processor ()

Добавлю мини-историю успеха

Время: позавчера.

Дано: tp-link 1073nd v1 - прошивка заводская. Потом ставил от 10/02/12 (последнюю, какую смог найти).

Проблема: при пропадании провайдерского линка на время более нескольких минут не происходило автоматического переподключения pppoe соединения при восстановлении провайдерского линка. Хотя в настройках стояло «держать постоянное подключение pppoe».

Ход событий: прочитал данную ветку. Уже готовился преодолевать разные проблемы после прошивки на Openwrt. Но.

  • Скачал Openwrt trunk.
  • Запустил обновление через web interface.
  • Reboot.
  • ???
  • Установил пакеты для pppoe и luci.
  • Настроил Dual / Russian PPPoE.
  • Всё работает.

Инфо с работающего роутера:

Status
System
Router Name	OpenWrt
Router Model	TP-Link TL-WR1043N/ND v1 
Firmware Version	 OpenWrt Attitude Adjustment r31340 / LuCI Trunk (trunk+svn8588) 
Kernel Version	3.2.15 
Local Time	Mon Apr 23 20:05:09 2012
Uptime	22h 20m 22s
Load Average
Проблему с настройкой Dual / Russian PPPoE в OpenWrt решил следующим образом. Вручную поправил файл /etc/system/network
config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'
config interface 'server'
	option proto 'pppoe'
	option ifname 'eth0.2'
	option username 'login123'
	option password 'passw123'
И добавил интерфейс server в зону wan в /etc/system/firewall
config zone
	option name 'wan'
	option output 'ACCEPT'
	option masq '1'
	option mtu_fix '1'
	option input 'REJECT'
	option forward 'REJECT'
	option network 'wan server'

Для того, чтобы всё это правильно срабатывало, добавил в /etc/rc.local рестарт сети

# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.

/etc/init.d/network restart
exit 0

justAmoment ★★★★ ()

WR1043ND версии (RU) Ver 1.0 После перехода на openwrt, обнаружив отвал WAN-а , полез погуглить :-) Нарыл этот топик, прошил последнюю свежую прошивку производителя, потом немца, потом openwrt. WAN ожил, но проблемы с просачиванием мультикастов из портов LAN при загрузке остались.

anonymous ()

Такая же ревизия - dd-wrt завелся с полпинка.

devl547 ★★★★★ ()
Ответ на: СПАСИБО от anonymous

Re: СПАСИБО

Спасибо. Очень была полезна ваша инструкция!

anonymous ()

дополнение к настройке

Чтение данной ветки очень помогло мне разобрался с нуля часа за три. Но дабы облегчить жизнь остальным пишу, чтобы wan заработал действительно надо сначала поставить стандартную прошивку, потом немецкую старую и лишь потом openwrt. Но кто поторопился им необходимо вернуть заводскую прошивку. Пишу как это сделал я: - скачать программу PuTTY, WinSCP и оригинальную прошивку с оф.сайта - перезагрузить роутер и зайти на него 192.168.1.1 поменять пароль я поставил admin - запустить программу WinSCP и ввести данные ( хост 192.168.1.1, пользователь root, пароль admin, протокол я выбрал SCP) - когда откроется файловый менеджер скопировать оф. прошивку в папку tmp - затем запускаем PuTTY пишем хост 192.168.1.1, вводим имя пользователя и пароль когда попросят root, admin и далее пишем: cd /tmp mtd -e firmware -r write wr104nv1_en_3_13_12_up.bin firmware - все ждем пока не напишет rebooting... да кстати у меня почему-то ругался когда в имени были скобки(), так что лучше их убрать из имени прошивки. Надеюсь поможет, так как нигде такой инструкции не нашел голову сломал основательно))))))

pimkov ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.