LINUX.ORG.RU

intel hd graphics, xorg memory usage

 ,


0

1

так и должно быть?

84184 /usr/bin/X :0 vt7 -br -nolisten tcp -auth /var/run/xauth/A:0-jcam7a
при этом если закрывать всякие окошки/етс, то оно может скакать от 30мб до 200мб
вроде все говорили, что на интелях постоянно 30мб расход...
вот что менял из конфигов:
neko@nowhere ~ $ cat /etc/X11/xorg.conf.d/20-intel.conf 
Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   Option       "TearFree"      "true"
EndSection
neko@nowhere ~ $ cat ~/.drirc
<driconf>
    <device screen="0" driver="i965">
        <application name="Default">
            <option name="force_s3tc_enable" value="true" />
        </application>
    </device>
</driconf>
алсо,
neko@nowhere ~ $ apt-cache policy xserver-xorg-video-intel
xserver-xorg-video-intel:
  Установлен: 2:2.19.0-5
  Кандидат:   2:2.19.0-5
  Таблица версий:
 *** 2:2.19.0-5 0
        500 http://ftp.ru.debian.org/debian/ testing/main i386 Packages
        100 /var/lib/dpkg/status
neko@nowhere ~ $ 


upd: да, как я и думал - без SNA всё ок

★★★★★

Было такое, но очень давно. Я даже баг репортил. Пофиксили в гите где-то в районе нового года :)

madgnu ★★★★★ ()
Ответ на: комментарий от madgnu

щас

27832 /usr/bin/X :0 vt8 -br -nolisten tcp -auth /var/run/xauth/A:0-jniyRa
и увеличиваться не хочет
но это без SNA в конфиге:)
у меня щас версия мая 2012 вроде.. 2.19 хотя в чейндж логах 2.20.4 есть что-то про «sna/glyphs: fixed potential memory leaks» - тык
только вот что это — я хз

snoopcat ★★★★★ ()
Ответ на: комментарий от madgnu

поставил последнюю версию драйвера - 20 фпс в glxgears (вместо 60), 1 фпс в WoW, квин тормозит
снёс нафиг :3

snoopcat ★★★★★ ()
Ответ на: комментарий от snoopcat
>>-----Цитата---->>

20 фпс в glxgears

<<-----Цитата----<<

Похоже на softpipe.

madgnu ★★★★★ ()

сегодня вообщем проснулся от жужжания кулера нетбука. 100% cpu - kswapd0
система ушла в swap, процесс Xorg занимал 2 с лишним гигабайта.
нагуглил на гентуфорумах, что память жрёт psi+ при включенной анимации трея. отключил анимацию, щас всё равно жрёт...


neko@nowhere ~ $ ps -CXorg -orss
RSS
47984

xrestop показывает, что 44 мб скушали ресурсы. (firefox, amarok..)

snoopcat ★★★★★ ()
Последнее исправление: snoopcat (всего исправлений: 1)
Ответ на: комментарий от snoopcat

закрыл всё, жрущее ресурсы - потребление памяти хоргом не изменилось (внезапно)

snoopcat ★★★★★ ()
Ответ на: комментарий от snoopcat

хм, пооткрывал опять firefox, kde, amarok, и т.п. — потребление стоит на планке 40мб, странно оно как-то с ресурсами работает -.-

snoopcat ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.