LINUX.ORG.RU

0
Всего сообщений: 24

Установка драйвера в tails

Изменил репозитории в tails добавив в конце contrib non-free и установил broadcom-sta-dkms(т.к. у меня broadcom bcm43142), сохранил в persistent,интерфейс для подключегия к wifi не появился.Перезагрузил tails, репозитории стали прежними,пакет из persistent не загрузился.Снова проделал то же самое,но wifi не появился,а после перезагрузки думаю то же самое будет.Подскажите,пожалуйста,как решить проблему

 , , ,

rstm ()

Заметные тормоза при активном использовании сети (wifi)

Доброго времени суток! Появилась интересная проблема: ставлю торрент на закачку (или на раздачу), и система начинает активно лагать. Та же фигня происходит и с большим видео с youtube, пока оно целиком не прогрузится. Пробовал Ubuntu 19.04 и manjaro, менял версию ядра - все безрезультатно. Под окнами все отлично работало. Конфигурация: manjaro x-64, gnome, linux 5.0, Pentium G5400, 4Gb DDR-4, ssd, wifi адаптер RTL8188CE.

 , , ,

Agent008 ()

установка драйверов на broadcom limited bcm43142 в linux mint

Установил linux mint а он не видит wifi wlan0 интерфейс отсутствует и в параметрах wifi найти не могу.Думаю причина отсутствие драйверов.Подскажите пожалуйста как установить драйвера на broadcom bcm43142?

 , ,

nemo0000 ()

Debian 8.1 на Ryzen 7 1700

Здравствуйте. Xeon(R) X3430 @ 2.40GHz перестал справляться со своей задачей. Переполнились очереди обработки трафика (сетевые Intel Corporation 82574L). Нужно больше ядер.

Хочу перенести машину на Ryzen 7 1700X или Ryzen 7 1700. Поделитесь своими мыслями по этому поводу, а точнее получится ли у меня увеличить производительность.

И порекомендуйте пожалуйста материнскую плату подешевле (или хотябы чипсет) под этот процессор. Особых требований нет. Видео нужно встроенное, лишь бы консоль была. Ну а пара PCI-e слотов под сетевые, наверное, на любой плате найдется. Под память (ECC) слотов лучше 4, чтобы если что добавить. Пока с запасом хватит 8Гб.

Ну и главное, чтобы все это завелось под Debian GNU/Linux 8.1 (jessie) 3.16.0-4-amd64.

 , , ,

aleksey808 ()

Настройка области Wacom

Добрый день.

Не могу сказать про себя, что я продвинутый юзер линукс, поэтому пишу сюда.

В общем меня интересует то, как можно настроить рабочую область планшета One by Wacom (small) на Ubuntu Budgie?

Я уже установил: Kernel Driver X Driver libwacom

 , ,

Toster-Braun ()

Где найти драйвера для моего WIFI адаптера

не могу найти драйвера для своей вафли: где их можно найти у меня стоит кали линукс, в идеале еще бы и инструкцию как их устанавливать

root@kali:~# lspci -vnn -d 14e4:

03:00.0 Network controller [0280]: Broadcom Limited Device [14e4:4464] (rev 03)

Subsystem: Apple Inc. Device [106b:07bf]

Flags: fast devsel, IRQ 255

Memory at 81400000 (64-bit, non-prefetchable[disabled] [size=32K]
Memory at 81000000 (64-bit, non-prefetchable) [disabled] [size=4M]
Capabilities: [48] Power Management version 3
Capabilities: [58] MSI: Enable- Count=1/16 Maskable- 64bit+
Capabilities: [68] Vendor Specific Information: Len=44 <?>
Capabilities: [ac] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [13c] Device Serial Number **-06-**-ff-ff-**-f0-**
Capabilities: [150] Power Budgeting <?>
Capabilities: [160] Virtual Channel
Capabilities: [1b0] Latency Tolerance Reporting
Capabilities: [220] #15
Capabilities: [240] L1 PM Substates

root@kali:~#

 , , ,

evgeniykas ()

debian 9 проблемы с масштабом элементов приложений

после установки не свободных драйверов nvidia все стало маленькое элементы управление частично то что я мог исправил но не все в чем может быть проблема ? http://imgur.com/wq1lsPdl.png

 , ,

KOZA_ ()

Драйвер или демон?

Есть RaspberryPi к которому нужно подключить сложное устройство по spi. С этим устройством должны взаимодействовать несколько разных программ с пользовательского уровня. И есть два варианта контроллера - драйвер и демон. Драйвер очевидно управляется через пространство ядра, демон через доменный сокет.

Я вижу очень весомые преимущества демона: 1. Он работает со стандартным и очень удобным драйвером spi linux 2. Он имеет очень гибко настраиваемый интерфейс контроля в виде сокета. 3. В случае критических ошибок в коде демона, система останется работоспособной, а с драйвером все рухнет в тартарары.

Преимущества демона для меня очевидны. Я писал такие программы много раз и вполне успешно. Ну суть в том, что написание драйверов это для меня своего рода личный возов как для программиста (так как я это никогда не делал). Но поскольку задача вполне себе рабочая, я пытаюсь найти рациональные аргументы за написание именно драйвера. Вопрос - какие есть плюсы у драйвера относительно демона в срезе данной задачи?

 ,

Serbis ()

AMD vs Nvidia выбор

В конце-концов, выбирая под новый год себе небольшой подарочек, снова подниму тему выбора видеокарты

Правда по деньгам, похоже, что я не потяну ни Amd Vega 56(64), ни GF 1080 ti. Ну то есть, формально мог бы потянуть, но это как-то получится чересчур дорого для меня, не куплю ряд действительно нужных вещей, а главное, что не очень понятно зачем нужно. Программирование на GPU я еще только собираюсь освоить и если бы мне четко нужно было бы для каких-то вычислений взять топовую карту, тем более, если для работы, то все понятно было бы. Сейчас же просто хочется старую обновить.

Поэтому сейчас выбор поскромнее в итоге: между Radeon RX580 8Гб и Nvidia GTX 1060 6Гб. За RX580: +2Гб, скорость в GFlops заметно выше, особенно для типа double так вообще разница почти 3-кратная.

Но я не столько об этом (хотя советы готов почитать), сколько о ситуации с драйверами. Не в последнюю очередь хотелось взять AMD из-за вроде как OpenSource драйверов.

И вот тут странный парадокс, но получается, что вроде как на практике и именно под Linux намного беспроблемнее Nvidia!!! Их драйвера, хотя и проприетарные, но имеются под все более-менее распространенные дистрибутивы. Для AMD же для ускорения OpenCL все равно нужны проприетарные драйверы. Но при этом они выпускаются только для Ubuntu (и вроде RedHat), к тому же они еще и проверяют, чтобы их не запустили на других дистрах! И вот нафиг?

Люди правда расковыривают вроде как, но что-то непонятно насколько успешно.

Короче, как ни странно, но получается, что именно с AMD (по крайней мере для современных карточек) под Linux больше траха с драйверами. Как выразился один человек: http://forums.debian.net/viewtopic.php?f=6&t=135330#p659418

Unfortunately, and after all these years (near 15 now), AMD still sucks a lot with their drivers on Linux: you never know what to install, not install, which version, for which card, for which linux kernel, which linux distribution.

И это признаться отпугивает. Получается, что AMD чтобы брать надо хорошо понимать зачем брать, например, реально есть вычислительная задача под которую критично, что в FP64 у AMD скорость выше в три раза за теже деньги. Тогда можно даже вообще на отдельный винчестер поставить нужную ОС (даже винду, если на то пошло) ради вычислений.

Или я все преувеличиваю и цена вопроса просто немного поковыряться в конфигах. Но тут важно еще, чтобы после каждого апдейта системы ковыряться не пришлось. С nvidia в этом смысле хотя и не очень хорошо дела обстоят, но все же, не так и плохо, если не увлекаться кастомными ядрами, но с ними это и не должно тревожить.

 , ,

praseodim ()

Помогите удовлетворить зависимости

Установлен серверный дистр Ubuntu 16.04. Сверху поставил xfce4. Хочу поставить драйвер на AMD Radeon HD7850, скачал с оф сайта сами драйвера, после распаковки и запуска скрипта просит зависимости. А как их удовлетворить ума не приложу
-> Скришот <-

 , ,

Shprot ()

Arch Аппаратное ускорение AMD

Видео карта обнаруживается но аппартное ускорение не включено. Использую драйвер radeon. vdpauinfo и vainfo выдают ошибки.

➜  iliayar LIBGL_DEBUG=verbose glxinfo > /dev/null
libGL: screen 0 does not appear to be DRI2 capable
libGL: OpenDriver: trying /usr/lib/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/dri/swrast_dri.so
libGL: Can't open configuration file /etc/drirc: No such file or directory.
libGL: Can't open configuration file /root/.drirc: No such file or directory.
libGL: Can't open configuration file /etc/drirc: No such file or directory.
libGL: Can't open configuration file /root/.drirc: No such file or directory.
glxinfo:
➜  iliayar glxinfo
name of display: :0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
    ...
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: VMware, Inc. (0xffffffff)
    Device: llvmpipe (LLVM 7.0, 256 bits) (0xffffffff)
    Version: 18.3.1
    Accelerated: no
    Video memory: 7864MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 3.3
    Max compat profile version: 3.1
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.0
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 7.0, 256 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 18.3.1
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
    ...
OpenGL version string: 3.1 Mesa 18.3.1
OpenGL shading language version string: 1.40
OpenGL context flags: (none)
OpenGL extensions:
    ...
vainfo и vdpauinfo:
➜  iliayar vainfo
vaInitialize failed with error code 2 (resource allocation failed),exit
➜  iliayar vdpauinfo
display: :0   screen: 0
Error creating VDPAU device: 23
lspci:
➜  iliayar lspci -knnn | grep vga -i -A 3  
00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06)
	Subsystem: Gigabyte Technology Co., Ltd Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [1458:d000]
	Kernel driver in use: i915
	Kernel modules: i915
--
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] [1002:665f] (rev 81)
	Subsystem: Gigabyte Technology Co., Ltd Tobago PRO [Radeon R7 360 / R9 360 OEM] [1458:22ba]
	Kernel driver in use: radeon
	Kernel modules: radeon, amdgpu
При запуске прописано VDPAU_DRIVER=radeonsi LIBVA_DRIVER_NAME=radeonsi

Конфиги Xorg:

Section "Device"
    Identifier "Radeon"
    Driver "radeon"
    Option "SwapbuffersWait" "off"
    Option "ColorTiling" "on"
    Option "ColorTiling2D" "on"
    Option "EnablePageFlip" "on"
    Option "AccelDFS" "on"
    Option "XV_VSYNC" "on
    Option "AccelMethod" "glamor"
    #Option "AccelMethod" "EXA"
EndSection

Section "Module"
    Load "dri2"
    Load "glamoregl"
EndSection

Как я понял это OpenGL vendor string: VMware, Inc. значит что аппаратное ускорение не включено. Как следствие всякие WebGL и игры подтармаживают.

➜  iliayar glmark2 --fullscreen
** GLX does not support GLX_EXT_swap_control or GLX_MESA_swap_control!
** Failed to set swap interval. Results may be bounded above by refresh rate.
=======================================================
    glmark2 2017.07
=======================================================
    OpenGL Information
    GL_VENDOR:     VMware, Inc.
    GL_RENDERER:   llvmpipe (LLVM 7.0, 256 bits)
    GL_VERSION:    3.1 Mesa 18.3.1
=======================================================
** GLX does not support GLX_EXT_swap_control or GLX_MESA_swap_control!
** Failed to set swap interval. Results may be bounded above by refresh rate.
[build] use-vbo=false: FPS: 121 FrameTime: 8.264 ms
=======================================================
                                  glmark2 Score: 121 
=======================================================
На ноуте где вроде как используется интегрированная видюха Intel около 300

 , ,

iliayar ()

Какой дистрибутив поставить?

Имеется древний Немецкий ноут Medion MD 9373 На Celeron 500MHz И 192mb Ram С 6гб хардом Драйвера уже не достанешь для винды и думаю линукс подойдет ( консольный ) ну и иногда icewm Какой бы дистр поставить на столь слабую машинку

 , ,

Kyrtovich ()

Проблема использования проприетарного софта

Все чаще и чаще встречаю фанатиков, помешанных на этой вашей свободе. Они готовы бороться с бесконечными ошибками, страдать от недостатки специфичного софта, лишь бы только посвободнее было. Возможно, я немного преувеличил. ЛОРе такие люди должны быть. Не изволите рассказать, что движет вами? Почему вы выбираете свободные драйвера?

 , , , ,

time_LORd ()

Срочно помочь с драйверами Wi-Fi на Elementary OS

Всем привет! Установил Elementary OS, после чего обнаружил, что вверху на панели в разделе «Интернет» нет беспроводного подключения и WiFi, только проводное. Модель адаптера RTL8821CE 802.11ac PCIe. Ноутбук Lenovo IdeaPad 330

 , , , ,

BroncosInc ()

Ubuntu 18.04 nvidia optimus определить работает ли nvidia карта

Добрый день. Система kde.neon (на основе ubuntu 18.04) Как понять, что работает nvidia карта. Использую nvidia-prime. При выборе и intel и nvidia, glxgears показывает одинаковый результат ~60fps (если задавать vbalnk_mode=0 то примерно ~8000-9000fps и на intel и на nvidia).

 , , ,

rumgot ()

Не работает клавиатура на archlinux (Archman) после установки драйверов

Не работает клавиатура после установки NVIDIA драйверов (390xx). Когда появляется окно входа не могу ввести пароль из-за этого. Я пробовал не только Archman, но и Anarchy, Antergos, RebornOS, SwagArch, Arch XFerience и у всех них после установки драйверов не работает клавиатура (Мышка работает). Как решить эту проблему?

 , , , ,

D4zzly ()

Install WIFI Driver in kali linux 2017.3

Ребята нужна помощь не могу установить драва, в нете гуглил нет подходящей инфы. Кто знает помогите как решить такую проблему? Пишет:

E: Не удалось найти пакет linux-headers-686-pae
E: Не удалось найти пакет broadcom-sta-dkms




After Installing Your Machine is Going to REBOOT
Чтение списков пакетов… Готово
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
E: Не удалось найти пакет linux-headers-686-pae
E: Не удалось найти пакет broadcom-sta-dkms
modprobe: FATAL: Module wl not found in directory /lib/modules/4.15.0-kali2-686-pae

 ,

daniel965_7 ()

Проблема с разрешением Ubuntu

В общем,я установил драйвер от nvidia вроде правильно - все работает, но, после перезагрузки системы, пропадает настройка разрешения. Что делать?

 , ,

linuxboy ()

Сбросилось разрешение экрана в Xubuntu 18.04/ Проблема с драйвером NVidia

Разрешение экрана сбросилось на 640x480, после того, как я вернул настройку на стандартный непроприетарный драйвер с проприетароного NVidia 340.106. Монитор ViewSonic (Optiquest) Q201wb 1680х1050 60, карта GeForce 8600 GT . После установки системы работал стандартный драйвер и он спокойно определял монитор. Драйвер NVidia передаёт изображение побитым - нижняя часть немного отстаёт. Прошу помочь либо с разрешением, либо с драйвером. P.S. Драйвер NVidia спокойно определяет монитор и выставляет правильное разрешение.

 , , ,

RutileGryphon ()

Fujitsu Lifebook T904, поддержка в Linux

Собираюсь брать бэушный, интересует совместимость с онтопиком.

В машинке есть сканер отпечатков и два «дигитайзера» (слово «цифрователь» в русском языке допустимо? Или сюда и «оцифровщик» подходит?): один обычный ёмкостный, а другой - понтовый Wacom-овский. В одном из тредов когда-то читал, что если лин-драйвера под сканер нет, то его можно выкорчевать из msi файла (вот тут хотелось бы по-подробнее). А с тачами как? Определятся как «обычные HID-устройства» или надо будет так же, как и со сканером заморачиваться? А то какая-то бабулька в одном треде тут упоминала о каком-то проприетарном интерфейсе на фуджиках...

А брать буду именно такой, т. к. из до30к нормальных трансформеров с хоть сколько-то хорошими экранами (и не полным г на матплате) больше нет: либо новый T938 за 250 косых, либо гробы с ещё более отсталым железом, либо дурацкие 360ники-йоги, экраны до 12 и прочее неподходящее.

PS Запостил на Чепде (похоже, зря) следующую темку: хттпс 4пда ру/forum/index.php?showtopic=903949 Вообще, оно не так уж и дорого, но сейчас вынужденно тратятся средства на другое, посему на ноут смогу выделить максимум тысяч 20-25, и перерыв всё, до чего докопался в интернетах, остановился на вот этом вот.

Заранее спасибо за ответы.

 , , , ,

VanillaLex ()