LINUX.ORG.RU

Пользуетесь ли вы OS X?

 , ,


0

2

По мотивам треда. Много ли тех, кому мог бы быть полезен такой раздел?

  1. Нет и не собираюсь.980 (63%)

    ********************************************************************************************************************************************************************************************************************************************************************************************************************************

  2. Нет, но в будущем, возможно, куплю мак.266 (17%)

    **************************************************************************************

  3. Да, всем доволен.162 (10%)

    ****************************************************

  4. Нет, когда-то пользовался, но уже отказался.128 (8%)

    *****************************************

  5. Да, но в дальнейшем откажусь от использования.32 (2%)

    **********

Всего голосов: 1568

★★★★

Проверено: beastie ()

Ответ на: комментарий от annulen

Она и так нормальная, а полноценных WM с вяленым не будет.

с полноценностью WM можно что-то придумать - опенсорц ведь. а графика тормозит.

waker ★★★★★ ()

Нет, но в будущем, возможно, куплю мак

если Эппл (внезапно) перейдёт на нон-Intel архитектуру. И не факт, что стерплю дефолтную OS X

drSchur ★★★ ()

Не хватает варианта «да, но стесняюсь об этом сказать» %)

darkenshvein ★★★★★ ()

я пользовался маком за неимением компа с линуксом

Mr_Gentoo ()
Ответ на: комментарий от drSchur

И не факт, что стерплю дефолтную OS X

недефолтной не существует, not customizable at all

Mr_Gentoo ()

Пользуюсь. Жду того момента, когда появится ноут с гарантированной поддержкой железа Linux - как в железках на Android. Сама макось неосновательно сделана, если смотреть на неё «под капотом» - отсутствие полноценного пакетного менеджера для системы (я не говорю о пользовательских приложениях) после линукса выглядит как-то совсем несерьезно. А если смотреть на неё с точки зрения пользователя, то Finder идеологически убог, а spotlight просто достает тем, что везде норовит создать свои метафайлы.

asaw ★★★★★ ()
Ответ на: комментарий от waker

проблему dependency hell никто кроме каноникал даже не признает проблемой, а решат ли ее когда-либо в убунте — в данный момент неясно.

Это примечательный момент. Ибо как эта проблема решена в винде или макоси? Да никак. Вышла новая мажорная версия оси - будьте добры разработчики переписать свои поделки так, чтобы они работали, ибо полной обратной совместимости никто не гарантирует. В макоси так и вообще с этим швах, учитывая частоту релизов и то, как брутально они ломают совместимость. Поэтому, хоть маковские приложения и таскают свои зависимости с собой в App Bundles, их это не спасает. В линуксе хотя бы думают о таких вещах, как LSB.

asaw ★★★★★ ()

А где вариант - «у меня нет макбука»?

ViTeX ★★★★ ()
Ответ на: комментарий от asaw

Это примечательный момент. Ибо как эта проблема решена в винде или макоси?

парадигмой распространения софта «все свое ношу с собой».

Вышла новая мажорная версия оси - будьте добры разработчики переписать свои поделки так, чтобы они работали, ибо полной обратной совместимости никто не гарантирует.

ломаются в основном кривые поделки, запускал кучу древнючего софта написанного еще до появления tiger — работает на 10.9.

макоси так и вообще с этим швах, учитывая частоту релизов и то, как брутально они ломают совместимость. Поэтому, хоть маковские приложения и таскают свои зависимости с собой в App Bundles, их это не спасает.

можно пример того, где это не спасает, и совместимость чего с чем сломалась? не флейма ради, действительно интересно, т.к. хочу быть готовым к подобному в будущем, как разработчик.

В линуксе хотя бы думают о таких вещах, как LSB.

в линуксе самособранные пакеты не принимают в репы (за исключением проприетарщины), стандартного формата пакетов нет, а мантейнеры почему-то собирают софт не соблюдая lsb.

waker ★★★★★ ()
Ответ на: комментарий от waker

ломаются в основном кривые поделки

А вот один упоротый эплофил, коего в этих ваших интернетах кличут wylsacom, хотел постримить с новой mavericks что-то ненужное, но облажался из-за софта. Пришлось ему даунгрейдиться :)

cipher ★★★★★ ()

когда-то пользовался, отказался(линукс удобнее), но возможно в будущем вернусь

lazyklimm ★★★★★ ()
Ответ на: комментарий от cetjs2

значит попутал версии. таки они интелевые (я вообще только щас узнал, что в lion уже выпилили розетту).

upd: понял где я попутал, там внутри universal binary, который работает и на ppc, и на интелях. я такие даже сам делал, когда под тайгером программил в 2006м.

waker ★★★★★ ()
Последнее исправление: waker (всего исправлений: 1)

Я бы проголосовал за вариант «да, но доволен не всем».

sT331h0rs3 ★★★★★ ()
Ответ на: комментарий от cipher

мне это ни о чем не говорит. что за wylsacom, и почему вы его проблемы приравняли к ломанию совместимости ябблами?

waker ★★★★★ ()

Нет, но в будущем, возможно, куплю мак.

Правда, непонятно, когда это будущее наступит ;)

Lothlorien ★★★ ()
Ответ на: комментарий от waker

ломаются в основном кривые поделки, запускал кучу древнючего софта написанного еще до появления tiger — работает на 10.9.

розетту в 10.7 выпилили, так что про «кривые поделки» неправда.

anc ★★★★★ ()
Ответ на: комментарий от waker

парадигмой распространения софта «все свое ношу с собой».

для этого большого ума не надо :) в линуксе - тем более. у libc ABI стабилен, у X11 - тоже. можно делать так же. да так, в принципе, проприетарный софт и распространяется.

можно пример того, где это не спасает, и совместимость чего с чем сломалась? не флейма ради, действительно интересно, т.к. хочу быть готовым к подобному в будущем, как разработчик.

Навскидку: Tunnelblick, CoRD, VirtualBox, NeoOffice. Это то, чем я непосредственно пользуюсь часто. Можно ещё припомнить разные низкоуровневые тулзы вроде Valgrind. Собственно, переход на Mavericks я пока отложил на неопределенный срок по этой причине.

в линуксе самособранные пакеты не принимают в репы (за исключением проприетарщины), стандартного формата пакетов нет, а мантейнеры почему-то собирают софт не соблюдая lsb.

Тут проблема больше идеологическая. Дистрибутив — вещь в себе. Что, впрочем, не мешает создавать свои собственные репозитории для самосборных пакетов. В убунте, например, очень популярны разные PPA.

asaw ★★★★★ ()
Ответ на: комментарий от waker

почему вы его проблемы приравняли к ломанию совместимости ябблами?

Потому что на предыдущей версии у него все работало, а на новой не работает. Может уже девелоперы его любимого софта для стрима пофиксили, но факт - поломалось.

что за wylsacom

Краткую характеристику я уже дал, он действительно такой.

cipher ★★★★★ ()

Нет. Но если мне вдруг подарят мак...

morse ★★★★★ ()

Много ли тех, кому мог бы быть полезен такой раздел?

Полезен? Чем полезен? Маководческих сайтов пруд пруди. Зачем на LORе-то еще это разводить?

void_ptr ★★★★ ()
Ответ на: комментарий от asaw

для этого большого ума не надо :) в линуксе - тем более. у libc ABI стабилен, у X11 - тоже. можно делать так же. да так, в принципе, проприетарный софт и распространяется.

в линуксе софт собранный таким образом не принимают ни в репы, ни в USC, а универсального формата пакетов нету. и это, в частности, одно из препятствий решения проблемы dependency hell.

Навскидку: Tunnelblick, CoRD, VirtualBox, NeoOffice. Это то, чем я непосредственно пользуюсь часто. Можно ещё припомнить разные низкоуровневые тулзы вроде Valgrind. Собственно, переход на Mavericks я пока отложил на неопределенный срок по этой причине.

эти проблемы как-то связаны с поломками совместимости API/ABI? или все-таки перечисленные тулзы дергали недокументированные API, и парсили форматы, которые не менять никто не обещал?

в общем, к dependency hell как-то слабо отношение имеет. такие тулзы работают с низкоуровневыми вещами, которые не менять никак нельзя. думаю, сделать операционку, в которой такое будет стабильно на 20 лет вперед, просто невозможно. разве что не обновлять ее.

waker ★★★★★ ()
Ответ на: комментарий от cipher

Потому что на предыдущей версии у него все работало, а на новой не работает. Может уже девелоперы его любимого софта для стрима пофиксили, но факт - поломалось.

так может, дело было именно в том, что его любимый софт был криво написан?

waker ★★★★★ ()
Ответ на: комментарий от asaw

Тут проблема больше идеологическая. Дистрибутив — вещь в себе. Что, впрочем, не мешает создавать свои собственные репозитории для самосборных пакетов. В убунте, например, очень популярны разные PPA.

угу, только в этих репозиториях будет все тот же dependency hell, и проблему общесистемного dh не решит вообще никак. а решать ее надо разделением на базовую систему и приложения, и устанавливать и обновлять их раздельно, и различными методами. как раз на примере макоси можно легко посмотреть, как это должно работать.

waker ★★★★★ ()
Ответ на: комментарий от alex-w

Не спасет, т.к
1. Компеляние
2. Он автомаом мне не обновит мне весь устаревший опенсорсный софт, а точный список того что устарело я не знаю.
3. В системе останентся две версии одного и того же софта.

Andrew ★★★ ()
Ответ на: комментарий от waker

эти проблемы как-то связаны с поломками совместимости API/ABI? или все-таки перечисленные тулзы дергали недокументированные API, и парсили форматы, которые не менять никто не обещал?

в случае с VirtualBox - там понятно, что ломаются ядерные модули. но всё равно результат один. Tunnelblick - не вникал. что в корде и неоофисе ломалось — тоже не знаю, но CoRD в mavericks пока не работает - на офсайте написано. да, и вот тоже примечательно: я должен сам как-то (?) узнавать работает ли конкретная софтина в следующей версии оси. а с линуксами всё просто: есть в дистрибутиве, значит, скорее всего, работает.

в общем, к dependency hell как-то слабо отношение имеет.

а я считаю прямое. просто в линуксе эта проблема становится очевидной - её таковой делают менеджеры пакетов, а в макоси и в винде - пока приложение не упадет, не узнаешь есть там проблемы или нет :)

asaw ★★★★★ ()
Ответ на: комментарий от waker

на примере макоси можно легко посмотреть, как это должно работать.

ломать софт на минорных обновлениях и просить за это денюжку? ну арчемышам наверное понравится. вот только даже убунтушники смотрят на такую систему, как на говно.

Ford_Focus ★★★★★ ()
Последнее исправление: Ford_Focus (всего исправлений: 1)
Ответ на: комментарий от anc

Вопрос: Не работает в 10.9 ?

Про 10.9 не знаю, если честно. 10.8 довольно долго не поддерживалась стабильной версией - я про это.

asaw ★★★★★ ()
Ответ на: комментарий от waker

Что такое этот 'dependency hell'? У меня кубунту, в ней включены все стандартные репы и добавлена куча ппа. Куда смотреть, чтобы его увидеть?

prischeyadro ★★★☆☆ ()
Ответ на: комментарий от Andrew

1. Поставь fink - и будет у тебя apt для макоси 2. Обновит - ключик ему сказать просто надо. 3. Ты хочешь угробить систему, а потом плакаться об этом?

alex-w ★★★★★ ()
Ответ на: комментарий от Ford_Focus

ломать софт на минорных обновлениях и просить за это денюжку?

10.9 минорное обновление? а какое не минорное тогда? в убунте 13.10 сломали гораздо больше всего, btw.

ну арчемышам наверное понравится. вот только даже убунтушники смотрят на такую систему, как на говно.

я как раз убунтушник. выше писал, ага.

waker ★★★★★ ()
Ответ на: комментарий от prischeyadro

Что такое этот 'dependency hell'? У меня кубунту, в ней включены все стандартные репы и добавлена куча ппа. Куда смотреть, чтобы его увидеть?

я тут могу предположить, что в данном контексте к DH можно отнести следующую ситуацию. приложение, допустим, зависит от gtk+ 2. в версии X дистрибутива D соответствующий пакет называется gtk. в версии X+1 выходит версия 3 gtk+, которая и начинает называться gtk, а предыдущая переименовывается в gtk2. ты пытаешься поставить пакет, созданный для D версии X в версии X+1 и закономерно обламываешься с адовыми сообщениями об ошибках зависимостей.

asaw ★★★★★ ()
Ответ на: комментарий от asaw

Тогда да, такая проблема возникает постоянно при смене мажорной версии, но бэты работают. И то проблема ЕМНИП только в установке днс.

anc ★★★★★ ()
Ответ на: комментарий от asaw

я должен сам как-то (?) узнавать работает ли конкретная софтина в следующей версии оси.

а что, бывает иначе?

а с линуксами всё просто: есть в дистрибутиве, значит, скорее всего, работает.

ой как не факт.

а я считаю прямое. просто в линуксе эта проблема становится очевидной - её таковой делают менеджеры пакетов, а в макоси и в винде - пока приложение не упадет, не узнаешь есть там проблемы или нет :)

пока что не доказано, что в вышеперечисленных проблемах виноват апгрейд оси, а не кривые лапки девелоперов. есть >9000 способов сделать программу, которая по определению не будет работать после апгрейда оси. самый популярный способ - использование недокументированных/нестабильных API. но далеко не единственный.

waker ★★★★★ ()
Ответ на: комментарий от asaw

как раз в случае с GTK такой проблемы нет. есть, например, с libpng.

приложение линкуется с libpng.so.4, после апдейта .so.4 сносится, и ставится .so.5, приложение перестало работать.

waker ★★★★★ ()
Ответ на: комментарий от waker

пока что не доказано, что в вышеперечисленных проблемах виноват апгрейд оси, а не кривые лапки девелоперов. есть >9000 способов сделать программу, которая по определению не будет работать после апгрейда оси. самый популярный способ - использование недокументированных/нестабильных API. но далеко не единственный.

Допустим, но тогда возникает вопрос: а почему способ действительно популярен? И вообще, как бы, что всегда виноваты кривые лапки девелоперов - само собой очевидно. Вопрос в том, что делает ОС для упрощения их жизни. Винда вот просто делает релизы раз в 5 лет (утрирую конечно) и всё. Макось - чаще, из-за чего и софта ломается больше.

asaw ★★★★★ ()
Последнее исправление: asaw (всего исправлений: 1)
Ответ на: комментарий от alex-w

1, 2 - Спасибо, гляну.
3. Нет, просто мне не нравится когда в системе 2 и более версий одного, ведь во первых это не нужно (к тому же я считаю это не нормально), во вторых тебя все еще могут поиметь через уязвимости старых версий.

Andrew ★★★ ()
Ответ на: комментарий от waker

это, кстати, легко решается: просто ставишь пакет, который предоставляет .so.4, и живешь спокойно. проблема в том, что в реальной жизни либо автор пакета добавит какую-нибудь лишнюю зависимость на уровне пакетов, а не на уровне библиотек, либо libpng.so.4 из пакета в новом дистрибутиве сломает ABI, либо произойдет ещё что-нибудь, чего происходить не должно и что вызовет конфликт. но, всё же, по-моему с каждым годом количество подобных проблем снижается, а не растет.

asaw ★★★★★ ()
Ответ на: комментарий от asaw

ну, если сравнивать с вендой - то макось однозначно делает на порядок меньше, чем венда, для обеспечения обратной совместимости. мелкомягкие вообще на крайности идут, чтобы запускать софт доисторических времен. вплоть до реализации багов win95 в win8 при детекции определенных приложений.

способ популярен, потому что так проще всего. вспомним хотя бы не столь далекие времена, когда сломался firefox, если ничего не путаю, потому что в freetype поменяли какие-то private API. по правилам, должны были тащить фритайп с собой в этом случае.

теперь они конечно осознали свою ошибку, поэтому, например, таскают свой форк cairo :)

waker ★★★★★ ()
Ответ на: комментарий от asaw

это, кстати, легко решается: просто ставишь пакет, который предоставляет .so.4

ага, только вот придется его компилять. и это даже сработает. но это простой пример, просто для понимания проблемы.

но давай представим, что вместо libpng другая библиотека, у которой помимо *.so в /usr/share хранятся какие-то конфиги или данные, которые не версионированы. тут уже придется ставить в другой префикс. пакеты такое типично не поддерживают. мудотня с LD_LIBRARY_PATH, и т.п.

waker ★★★★★ ()

Буду лишь в виртуалке, и то лишь для тестов своего ПО на другой ОС, сборки под мак, не более того. Может приложение какой-нибудь Qt-шное под iOS соберу. Но чтоб постоянно - ненене.

I-Love-Microsoft ★★★★★ ()
Ответ на: комментарий от waker

в убунте 13.10 сломали гораздо больше всего

13.10 не является стабильным релизом. о количестве сломанного можно будет говорить после апдейта 12.04 на 14.04. 10.04 обновлялась до 12.04 без проблем. обновлять 8.04 до 10.04 не доводилось.

я как раз убунтушник. выше писал, ага.

видимо что-то осталось в душе от прошлой системы

//раз произошёл такой благодатный свитч - ppa не планируется? =)

Ford_Focus ★★★★★ ()
Последнее исправление: Ford_Focus (всего исправлений: 1)
Ответ на: комментарий от waker

по уму в системе должен быть линк «libpng.so», который ссылается на актуальную либу

Ford_Focus ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.