LINUX.ORG.RU

Избранные сообщения postman_

Горшочек, не вари!

Форум — Talks

Хейл Розенталь, котаны.

В общем, у меня всегда было неплохое чувство языка и, соответственно, грамотность на уровне. Но недавно я стал замечать, что ставлю слишком много запятых. Т.е., сначала мне казалось, что я все правильно делаю, а вокруг неграмотное быдло. Но потом начали закрадываться сомнения. Вижу две причины чрезмерного использования запятых:

1. Предложения строятся и произносятся в голове с каким-то перманентным сарказмом и попыткой подъе.. подколоть собеседника, поэтому часто делаются интонационные паузы, что воспринимается как необходимость поставить запятую;

2. В мозгу поселилась идея, что если какой-то оборот или что-то типа того, можно безболезненно выкинуть, значит его надо выделить запятыми. И, банально, (вот один из таких случаев лол), в некоторых предложениях, чуть ли не после каждого слова оказывается запятая!

Правила русского языка я никогда не учил и не знал, потому что грамотность больше зависит от того, как человек чувствует, и банальное зубрение тут не поможет. Мне даже иногда кажется, что некоторые люди IRL могут посчитать меня неграмотным.. Думаете это проблема?

 

Deleted ()

ленивым понихейтерам

Форум — Talks

подписка adblock для скрытия аватарок с пони
новые ссылки на пони-авы можете слать в issues (у кого нет аккаунта на гитхабе - на мыло «мой ник @ гмыло.ком»)

batekman ()

Разработка GUI для Python 3

Форум — Development

Python 3.1.3, Linux crunchbang 3.2.0-0.bpo.4-686-pae #1 SMP Debian 3.2.41-2+deb7u2~bpo60+1 i686 GNU/Linux (основан на debian squeeze). Не могу установить и запустить хоть что-нибудь, предназначенное для разработки GUI (не считая Tkinter).

1) wx

wxglade и PythonCards зависят от wx, но Python 3 просто не импортирует модуль wx. Почитал, что wx можно заставить работать с помощью Phoenix, скачал его исходники, sudo python3 setup.py install выдает:

running install
running build
running build_py
running install_lib
byte-compiling /usr/local/lib/python3.1/dist-packages/phoenix/__init__.py to __init__.pyc
  File "/usr/local/lib/python3.1/dist-packages/phoenix/__init__.py", line 56
    except PhoenixError, e:
                       ^
SyntaxError: invalid syntax

running install_data
running install_egg_info
Removing /usr/local/lib/python3.1/dist-packages/phoenix-0.9.1.egg-info
Writing /usr/local/lib/python3.1/dist-packages/phoenix-0.9.1.egg-info
Вроде как что-то и поставилось, но что с этим дальше делать? import wx ведет к сообщению об отсутствующем модуле.

2) gtk

Понравился glade, скачал образец программы (http://code.google.com/p/calculator-python-glade/), фрагмент кода

#!/usr/bin/python3
import sys
try:
        import pygtk
        pygtk.require('2.0')
except:
        pass
try:
        import gtk
        import gtk.glade
except:
        print('GTK not available')
        sys.exit(1)
Выдает 'GTK not available'. python-gobject уже установлен. Я так понимаю, не работает из-за того, что основной питон в системе - 2.6.6, в то время как, видимо, требуется python3-gobject (виртуальный пакет в репах sid, ссылается на python3-gi). Пакет из sid не устанавливается - слишком много зависимостей надо вручную компилить.

3) pyqt

В качестве hello_world взял пример с wiki. В результате «No module named PyQt4.QtGui», пакета python3-qt4 в репах Squeeze нет, есть только python-qt4.

Что с этим всем делать? Есть ли какая-нибудь возможность добавлять модули Python 3 в Debian Squeeze через репы?

 , ,

denton ()