LINUX.ORG.RU

Поддержка Direct3D 9 добавлена в Gallium3D

 , , ,


4

4

Представлена рабочая реализация трекера состояний Direct3D 9 для Linux, реализованная через Gallium3D, что даёт возможность прямого обращения к драйверам, без прослойки, транслирующей вызовы Direct3D в вызовы OpenGL. Благодаря этому удалось достигнуть боле чем двухкратного увеличения FPS в таких играх, как Skyrim, Civilization 5, Anno 1404 и Starcraft 2.

В отличие от ранее существовавших решений, данная реализация является полностью работоспособной и ориентированной на 9-ую версию API.

Для работы данного прототипа требуется изменённая версия Wine (инструкции можно найти здесь).

Разработчик верит, что эта реализация будет жизнеспособной, так как активно поддерживается, написана на языке C (а не C++). Также отмечается, что Gallium3D в его нынешнем состоянии гораздо более пригоден для реализации Direct3D 9, чем последующих версий.

>>> Подробности

★★★★★

Проверено: JB ()

Где можно найти список графических процессоров с которыми корректно работает этот самый Gallium3D?

Lorence ()
Ответ на: комментарий от Lorence

с которыми корректно работает этот самый Gallium3D?

Radeon >= 9500

onon ★★★ ()
Ответ на: комментарий от onon

с HD5000/6000 серий разве научили уже работать? Просто одно время читал, что понимает оно только чипы r600g

Lorence ()

ну теперь точно игровую консоль на онтопике сделают.

splinter ★★★★★ ()
Ответ на: комментарий от Lorence

Где можно найти список графических процессоров с которыми корректно работает этот самый Gallium3D?


Работает это только с Gallium3D-драйверами nouveau (nvc0, NVIDIA), r600g (AMD), swrast и, возможно, i915g.

vtVitus ★★★★★ ()

Кто нить разжуйте по нормальному мануал.

А то, я ни [censored] не понял, что откуда брать.

lexxus-lex ★★★ ()

будет жизнеспособной, так как активно поддерживается, написана на языке C (а не C++)

Ну неприкрытый вброс же! :)

pihter ★★ ()
Ответ на: комментарий от splinter

ну теперь точно игровую консоль на онтопике сделают.

Я, конечно, неграмотный... но а на чем до этого делали? На винде тока?

pihter ★★ ()

Также отмечается, что Gallium3D в его нынешнем состоянии гораздо более пригоден для реализации Direct3D 9, чем последующих версий.

Более новые галлиумы не пригодны или ничего выше 9-ки Direct3D нельзя реализовать?

alex-w ★★★★★ ()

А я еще помню те времена, когда словосочетание «директикс для линукса» могло считаться шуткой.

anonymous ()
Ответ на: комментарий от alex-w

Ничего выше 9-ки Direct3D нельзя реализовать. Точнее - вменяемо реализовать.

Falcon-peregrinus ★★★★★ ()

Я надеюсь, все пользуются только опенсорсный софтом и играми под вайном?

anonymous ()
Ответ на: комментарий от anonymous

какие-то дурацкие у вас надежды, коллега.

anonymous ()

Жаль только, что выигрыш от этого гораздо меньше, чем проигрыш от перехода с блоба на nouveau.

Да и интел же тоже не поддерживается.

franchukroman ★★☆ ()

да не нужно уже скоро будет, уже почти все под линуксу начинают делать игрушки

init_ ★★★ ()

хм наверное некоректно писать добавлена до тех пор пока она собственно не добавлена в апстрим...

вроде в таких случаях пишут для проекта 1 подготовлены патчи для поддержки 2

Thero ★★★★★ ()
Последнее исправление: Thero (всего исправлений: 1)
Ответ на: комментарий от beresk_let

а старые я думаю итак почти все идут под текущим вайном, да и там особо производительности не надо

init_ ★★★ ()
Ответ на: комментарий от init_

А теперь они будут идти лучше. Разве плохо? В новые-то активно пихают 10 и 11.

beresk_let ★★★★ ()
Ответ на: комментарий от alex-w

ничего выше 9-ки Direct3D нельзя реализовать?

http://cgit.freedesktop.org/mesa/mesa/commit/?id=92617aeac109481258f0c3863d09...

НО!

http://cgit.freedesktop.org/mesa/mesa/commit/?id=44a8e5135470fa51ae36b304f3c5...

По причине:

Слова автора Direct3D 9 state tracker'а

gallium wasn't ready for D3D11, and still isn't (at least the pipe drivers aren't), but it is ready for D3D9, and all the features required from the pipe drivers are well tested via OpenGL

Behem0th ★★★★★ ()
Ответ на: комментарий от Thero

пока она собственно не добавлена в апстрим

Собственно решения насчет стоит принимать или нет в апстрим, еще нет.

Behem0th ★★★★★ ()
Ответ на: комментарий от alex-w

Более новые галлиумы не пригодны или ничего выше 9-ки Direct3D нельзя реализовать?

DX10 можно вполне, а DX11 пока не хватает расширений.

steemandlinux ★★★★★ ()
Ответ на: комментарий от init_

да не нужно уже скоро будет, уже почти все под линуксу начинают делать игрушки

Старые ж никто не будет переделывать, а старые - теплее

pihter ★★ ()

Luca Barbieri made a rather significant commit today that adds a state tracker dubbed «d3d1x», which implements the Direct3D 10/11 API in Gallium3D.
Luca says this is just the initial version, but it's already working and can run a few DirectX 10/11 texturing demos on Linux at the moment. This is not a matter of simply translating the Direct3D calls and converting them to OpenGL like how Wine currently handles it, but is natively implemented within Gallium3D and TGSI to speak directly to the underlying graphics

driver and hardware.

Published on September 21, 2010

Где подвох?

Barracuda72 ()

Разработчик верит

believe в данном контексте следует переводить, как «считает», «полагает». В худшем случае «уверен в том, что».

anonymous ()
Ответ на: комментарий от alex-w

Direct3D 10 сильно отличается от 9, поэтому сей код не получится использоваться, чтобы запилить и поддержку DirectX 10. Пока что желающих реализовывать 10 нет.

anonymous ()
Ответ на: комментарий от pihter

Для старых есть dosbox, в котором 98 венда уже заводится. (Правда, пока со скрипом и только в svn-версии, но уже.)

atrus ★★★★★ ()

Кто нибудь смог собрать сабж и что нибудь с ним запустить?

winddos ★★★ ()
Ответ на: комментарий от atrus

Для старых есть dosbox, в котором 98 венда уже заводится. (Правда, пока со скрипом и только в svn-версии, но уже.)

Это, конечно, прекрасно, но:

Direct3D 9

dosbox, в котором 98 венда

/0

Под словом «старые» я имел в виду игры, писанные во времена D3D 9 для ХРюшки, в этом контексте

pihter ★★ ()
Ответ на: комментарий от Tweaker

Ога, и как загрузчик там GRUB под GPLv3, на игровой консоли, лол.
Это вероятно топорный фейк.

winddos ★★★ ()
Ответ на: комментарий от anonymous

Я могу ошибаться, но часть DX10 игр на wine идёт. Dishonored и XCOM: Enemy Unknown например.

anonymous ()
Ответ на: комментарий от Tweaker

На фряхе же.

Ну да, на этой можели я слыхал, а вообще?

Я думал там линь давно, ибо а что еще? Не винда же? Как она без монитора... Фря... Да не так хорошо с дровами, как у нас...

pihter ★★ ()
Ответ на: комментарий от pihter

Я думал там линь давно, ибо а что еще?

В PS3 была кучка маленьких огрызков из NetBSD. Я очень сомневаюсь, что Sony зачем то нужна фряха или её ядро. У японцев обычно очень много своего кода и все очень огорожено, в GRUB на девкитах я никогда в жизни не поверю.

winddos ★★★ ()
Ответ на: комментарий от pihter

но а на чем до этого делали? На винде тока?

В Microsoft, понятное дело, на винде, _все_ остальные на юниксообразных. Это если не считать 16-разрядное старьё, конечно.

Aceler ★★★★★ ()

Нет повода не выпить. Надеюсь, репы запилят в ближайшем будущем, чтоб не красноглазить?

corvuscor ()
Ответ на: комментарий от Lorence

HD5000 отлично работает. Вот только fps в играх ниже, чем с блобом. И декодирование видео через UVD работает только в экспериментальной версии драйвера(и то, на HD5450 местами тормозит).

lucentcode ★★★★★ ()
Ответ на: комментарий от Falcon-peregrinus

что за бряд. DX11 даже проще реализовать благодаря отсутствию fixed-function pipeline

x4DA ★★★★★ ()
Ответ на: комментарий от x4DA

ОК, в следующий раз буду добавлять - по мнению автора оригинальной новости. Я лишь разъяснил возможную непонятку перевода, а не высказал мнение.

Falcon-peregrinus ★★★★★ ()
Ответ на: комментарий от pihter

/0

Шутки шутками, но всё серьёзно. :) Ибо dosbox эмулитрует не только процессор, но и игровое железо, включая звуковые карты, видеокарту. В том же svn есть эмулятор voodoo.

Под словом «старые» я имел в виду

Ну, у нас разные представления о старых. :)

atrus ★★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

увидел тебя и вспомнил, есть пара вопросов:

1. АМД блоб 13.4 не умеет дружить с ядром 3.11?

2. radeosi как можно попробовать на моей 7750?

Kompilainenn ★★★★★ ()
Ответ на: комментарий от Kompilainenn

2. radeosi как можно попробовать на моей 7750?

Не стоит, сиди пока на блобе.

Behem0th ★★★★★ ()
Последнее исправление: Behem0th (всего исправлений: 1)
Ответ на: комментарий от Behem0th

И еще небольшой бонус, просто зверски медленная перерисовка при ресайзе окон.

Behem0th ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.