LINUX.ORG.RU

Выпущена версия Gajim 1.0

 , , ,


1

3

17 марта 2018 года вышла новая версия клиента обмена мгновенными сообщениями Gajim.
Цель Gajim — предоставить полнофункциональный и простой в использовании jabber-клиент.

Версия 1.0 принесла с собой важные изменения, среди которых:

  • Осуществлен переход к использованию GTK3 / Python 3.
  • Добавлены кнопки навигации в окне истории.
  • Улучшена поддержка экранов с высоким разрешением.
  • Поддержка распространения в формате пакетов Flatpak.
  • Кодовая база претерпела значительные изменения.
  • Изменен дизайн некоторых частей интерфейса.
  • Часть кода, связанного с шифрованием, вынесена в дополнения (PGP Plugin, Esessions Plugin).
  • Дополнение для OTR не портировано, вместо него рекомендуется использовать OMEMO.
  • Добавлена поддержка новых XMPP-расширений (список по ссылке в конце новости).
  • Множество мелких исправлений.

>>> Полный список изменений

>>> Подробности



Проверено: leave ()
Ответ на: комментарий от Clayman

В мацапе можно сидеть в на десктопе? Ну вот так что бы прям без браузера (или хотя бы, чтобы не иметь включенный телефон)? А то эта параша вывалится же, если телефон разрядится, надо выключить (да что угодно).

Этот верх удобства - не для меня.

gutaper ()

Tkabber + Xchat

Привет говноедам-хипстерам на выбирах/снапзондах и прочих поделках для слива инфы с телефона продаванам и спецслужбам, да и любой дворовой шлюхе (привет Cambridge Analytica, кстати).

FiXer ★★☆☆☆ ()
Ответ на: комментарий от Clayman

Tkabber + Xchat

Давай, рассказывай как мне с учеткой на сервере jabber.ru поговорить с человеком в воцапе.

Никак, попросить петуха на почту. Зоопарк сервисов никто держать не будет.

FiXer ★★☆☆☆ ()
Ответ на: комментарий от gutaper

Недолго пытался пользоваться утсапом, браузер меня особо не смущает, добило меня другое.

Мой основной девайс дома — планшет, хотел поставить уотсап из play store, но устройства без радимодуля не поддерживаются, ну ладно, пошел в веб версию, веб-версия отправила ставить в плей, ну ладно, поставил в хроме галочку «Request desktop site», оно почти загрузилось, но я всё же был отправлен в плей стор.

Можно было бы это, конечно, и обойти, но ну его к чертям, джаббер у меня прекрасно работает везде.

WitcherGeralt ()
Ответ на: комментарий от WitcherGeralt

но устройства без радимодуля не поддерживаются

Официально не поддерживаются. Тем не менее, ватсап можно без проблем установить и работает на планшете он безукоризненно.

Heretique ()
Ответ на: комментарий от a1batross

Так я им на форуме запостил, мне посыпались отказы.

Им решать, что на их сервере размещать. И это всё равно никак не мешает в f-droid закидывать вообще любой софт.

А всякие говнофдроиды и без меня проживут.

Странно, что ты на APT, RPM, портежи и т.д. с такой позицией ещё не наехал.

Quasar ★★★★★ ()
Ответ на: комментарий от Quasar

Как раз пока всё, что надо в Gajim 1.x не завезут, лучше на старой ветке и оставаться. Тем более, что GTK3 автоматически уродует весь интерфейс.

ну меня устраивает старый, новый просто интерестно на посмотреть в плане уродования интерфейса посредством gtk3.

alwayslate ()
Ответ на: комментарий от Quasar

Так я о чём. Да, это их дело. Но не стоит от этого играть на чувствах любителей швабодки, раз уж они сами ею пренебрегают. :)

Странно, что ты на APT, RPM, портежи и т.д. с такой позицией ещё не наехал.

Для APT у меня свои репозитории есть. И оверлей для Portage был. RPM не нужен.

a1batross ★★★★★ ()
Ответ на: комментарий от a1batross

Я фигею с тебя. Ты до сих пор не понял, что f-droid - это система управления пакетами на базе существующего пакетного менеджера андроида. Ты сам ни разу не пытался разобраться, но лезешь писать чушь.

Quasar ★★★★★ ()
Ответ на: комментарий от Quasar

Как система она неплоха. А у руля стоят идиоты, которые сами не знают что такое СПО. Возможно мне стоило вместо поста на их форуме сразу кинуть готовый патч, но какая уже сейчас разница? Я больше не нуждаюсь в главном репозитории фдроида как площадке. А из софта там только одно говно.

a1batross ★★★★★ ()
Ответ на: комментарий от Quasar

Как раз пока всё, что надо в Gajim 1.x не завезут, лучше на старой ветке и оставаться. Тем более, что GTK3 автоматически уродует весь интерфейс.

попробовал вечерком. с некоторыми переписываюсь кирилицей, так вот новая версия выводит входящие на кирилице крякозяблами, если это другой клиент или старая версия, между новыми версиями нет проблем. pgp теперь как то там отдельно включается и надо явно указывать.

итог - не удобно, откатываюсь на старую версию.

alwayslate ()
Ответ на: комментарий от anonymous

Нужно or ненужно?
Дополнение для OTR не портировано, вместо него рекомендуется использовать OMEMO.

Даб щас бы все контакты на непонятный плагин пересаживать... Ненужно!

anonymous ()