LINUX.ORG.RU

Gentoo анонсировали бинарную сборку gentoo-kernel-bin

 , ,


0

2

Проект Gentoo Distribution Kernel опубликовал новые пакеты Linux-ядра. Конфигурация ядер взята из Fedora Linux (до версии 5.7.9 использовался Arch Linux).

  1. Ядро с примененными genpatches, построенное с использованием менеджера пакетов, с настройками по умолчанию, либо пользовательской конфигурацией
sys-kernel/gentoo-kernel
  1. Предварительно собранная (бинарная) версия gentoo-kernel
sys-kernel/gentoo-kernel-bin
  1. Немодифицированное «ванильное» ядро
sys-kernel/vanilla-kernel

Главным отличием использования Distribution Kernels является возможность обновления до новых версий в процессе общего обновления «мира», без дополнительных ручных действий.

По умолчанию эти ядра поддерживают большинство оборудования, но они могут быть дополнительно сконфигурированы в /etc/portage/savedconfig.

>>> Подробности

★★★★

Проверено: alpha ()

Ответ на: комментарий от grem

Нет. Не так.

А переписывателей portage с питона на C++ в каждой пчихлечебнице уже чуть меньше чем Наполеонов.

Я не вижу смысла тупо переписывать одно на другое. Профита это не даст.

Тут нужно изменение подходов и (для начала) анализ. Даст ли выигрыш замена текстовых файлов на встраиваемую БД по времени исполнения/ресурсам. По идее, должно. Вопрос на сколько.

Ну и всё остальное так же.

UPD. Правда, это уже не к питонофилам вопросы. Если бы они были в состоянии их решать, то не кодерасили бы на питоне. Ну и говно софта на Этой Планете(tm) было бы меньше.

Moisha_Liberman ()
Последнее исправление: Moisha_Liberman (всего исправлений: 1)
Ответ на: Re: Дык! от anonymous

Потому, что мне это было нужно только для отдельных пакетов в целях тестирования сборки и прогонки их тестов определённых ebuild’ов, которые требуют упомянутые зависимости.

Сейчас то python_targets_python3_7 оттуда можно удалить, т.к. его я добавлял во времена 3.6 по умолчанию, но уже ожидался переход на 3.7

grem ★★★★★ ()
Последнее исправление: grem (всего исправлений: 1)
Ответ на: комментарий от grem

я не об этом. почему ты используешь длинный синтаксис вместо сокращённого? в package.use переменные USE_EXPAND можно прописывать сокращённо. например так:

x11-base/xorg-drivers VIDEO_CARDS: nvidia intel

вместо

x11-base/xorg-drivers video_cards_nvidia video_cards_intel
anonymous ()
Ответ на: комментарий от grem

Версию 2.7 уже сейчас очень активно выпиливают из gentoo и если у тебя нет пакетов, которые от него зависят (таких почти не осталось), то от него можно избавиться при желании.

Как? Подскажи, если нетрудно.

LongLiveUbuntu ★★★★★ ()
Ответ на: комментарий от LongLiveUbuntu

Предположу, что удалить.

Я об этой новости: https://www.gentoo.org/support/news-items/2020-09-28-python-2-7-cleanup.html

У меня пока не удалился. Предположу, что что-то его всё ещё тянет в системе, так как основная её часть у меня из stable.

grem ★★★★★ ()