LINUX.ORG.RU

Xvid и x264 добавлены в Debian

 , , , ,


0

1

Стараниями команды Debian Multimedia, после долгих разборок с патентами и авторскими правами на отдельные файлы, в дистрибутиве появились кодеки Xvid и x264, реализующие стандарты MPEG-4 ASP и H.264/MPEG-4 AVC. До этого пользователям Debian приходилось подключать сторонние репозитории.

Новые пакеты станут доступны в unstable уже в ближайшие часы, вместе с версией медиапроигрывателя VLC, собранной с поддержкой x264. В ближайших планах команды Debian Multimedia фигурирует пересборка MPlayer и libav (форка ffmpeg, заменившего в цикле wheezy собственно ffmpeg) с поддержкой новых кодеков.

>>> Подробности

libav с x264 из коробки? Здорово!

adepto ()

поздравляю дебианщиков.

uju ★★ ()

НАКОНЕЦ-ТО!!!111 истинная радость

pyometra ★★★★★ ()

патентные троли дали слабину?))

ждём mplayer =)

qbbr ★★★★★ ()

ну наконец-то Debian Multimedia не нужны :)

Jetty ★★★★★ ()

А что изменилось-то с патентами? Интересно же! Почему сейчас можно стало?

XVilka ★★★★★ ()
Ответ на: комментарий от AEP

Мейнтейнер лейма забухал - празнует ДМа :)

Jetty ★★★★★ ()

> в дистрибутиве появились кодеки Xvid и x264, реализующие стандарты MPEG-4 ASP и H.264/MPEG-4 AVC. До этого пользователям Debian приходилось подключать сторонние репозитории.

Алилуйя, здравый смысл восторжествовал.

webhamster ()

новость положительная, только вот как они разрулили ситуацию с патентами?

nevar ★★ ()

>(форка ffmpeg, заменившего в цикле wheezy собственно ffmpeg)

я не в теме всей этой кухни, но действительно интересно - зачем?

mikhalich ★★ ()

> в дистрибутиве появились кодеки Xvid и x264, реализующие стандарты MPEG-4 ASP и H.264/MPEG-4

зачем оно нужно?

anonymous ()
Ответ на: комментарий от Deleted

Debian Multimedia я подключал сразу после установки. И вообще, пофиг.

P.S. Кстате, в тестинге пакет libreoffice'a называется случайно не openoffice? Просто я не помню, я ж со сквиза обновлялся и особо не смотрел, что да как...

Urchin ★★★ ()
Ответ на: комментарий от Urchin

Там все пакеты openoffice всего лишь пустышки с зависимостями от libreoffice версии пакета.

This is a transitional package, replacing the OpenOffice.org packaging with the LibreOffice packaging.

Deleted ()

Ну наконец то! Теперь чутка подождать и можно будет шантажировать один из столпов линукса этой бомбой замедленного действия. Молодцы.

anonymous ()
Ответ на: комментарий от anonymous

>после долгих разборок с патентами и авторскими правами на отдельные файлы

Тащем-то думаю что они не просто так лясы точили на тему «какая глупость эти патенты на алгоритмы» и «как-бы было здорово включить эти кодеки в основной репозиторий».

MrClon ★★★★★ ()
Ответ на: комментарий от Urchin

> Эх... мог я и не уходить с Дебиана... Ну да ладно. За остальных порадуюсь.

Неужели такая проблема поставить пакеты с дебиан-мультимедия?

provaton ★★★★★ ()

УРРРРРААААААААА!!!!!!!!!!!

Deleted ()

отлично, пакеты из Multimedia конечно были выходом, но часто возникали траблы с тотемом и тп

slav0nic ()
Ответ на: комментарий от argin

и в подробностях нет ни какой дополнительной информации к тексту новости.

argin ★★★★★ ()

Ну всё, теперь лет через 5 добавят ЭмПэТри и шрифты со сглаживанием из Убунты - и сразу вендекапец.

Alve ★★★★★ ()

MPEG-4 ASP добавили, а MP3 нет? Как же теперь смотреть пиратские фильмы, скачанные из интернета?

zenden ()
Ответ на: комментарий от Alve

>Ну всё, теперь лет через 5 добавят ЭмПэТри и шрифты со сглаживанием из Убунты - и сразу получится убунта.

fixed

rain87 ()
Ответ на: комментарий от LongLiveUbuntu

> А у нас сто лет как было.

Тогда у меня 200. Вопрос тут не в софте, он собирается на автомате и цепляется локальным репом. Вопрос в патентах.

iBliss ()
Ответ на: комментарий от zenden

Ты для просмотра фильма MP3 кодируешь что ли?

Deleted ()
Ответ на: комментарий от Alve

>лет через 5 добавят ЭмПэТри

Это вы Debian с убантой перепутали - там как раз эмпетри не играет.

Polugnom ★★★★★ ()

Дебиан «Отмороженный» стал заметно тормознее, по сравнению с Etch. Секунд 20 думает, что выдать на команду aptitude install `packagename`, разучился добавлять дополнительные диски `apt-cdrom add` (выдаёт фигню вида «не могу смонтировать cdrom»), оказались исходно сбиты настройки часового пояса (починено по нарытым мануалам). Фигею с такой сборки.

anonymous ()
Ответ на: комментарий от tailgunner

> Например, для Lenny там пакеты кривые и убогие.

Имей совесть, ленни это уже олдстейбл давно.

provaton ★★★★★ ()

наконец то до разработчиков debian дошло, что удаление любого не GPL софта - это путь в тупик

anonymous ()
Ответ на: комментарий от anonymous

Неужто эти вредные разработчики Debian и из других дистрибутивов удаляют? Или вас тогда это каким боком касается?

Причём здесь GPL? У Debian только один ориентир и один принцип для добавления - это DFSG. И в DFSG всё чётко и понятно написано - что, зачем и почему.

kid_lester ()
Ответ на: комментарий от tailgunner

> Например, для Lenny там пакеты кривые и убогие.

Так новость-то Lenny никаким боком не касается. Изменения в sid, максимум, куда они попадут - это wheezy, возможно ещё и в squeeze-backports. Крайне сомнительно, что в lenny-backports-sloppy.

kid_lester ()
Ответ на: комментарий от registrant

У нас в Арче давно есть, в Убунту вроде тоже... Дебиан — один из немногих дистрибутивов, где так строго с патентами.

Dmitry_Sokolowsky ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.