LINUX.ORG.RU

Debian 9 «Stretch»

 ,


3

2

После 26 месяцев разработки представлен стабильный выпуск Debian 9 с кодовым именем «Stretch», который будет поддерживаться в течение следующих 5 лет.

Релиз посвящён памяти основателя проекта Иана Мёрдока, который ушёл из жизни 28 декабря 2015 года.

Основные изменения:

  • Вариантом MySQL по умолчанию теперь является MariaDB.
  • Firefox и Thunderbird заменили Iceweasel и Icedove, поставлявшиеся в течение более чем 10 лет.
  • Команда dmesg теперь требует права root.
  • Для запуска дисплейной системы X более не требуются права root.
  • Пакеты отладки перенесены в новый репозиторий и имеют окончание -dbgsym вместо -dbg. Репозиторий можно добавить в список источников APT:
    deb http://deb.debian.org/debian-debug/ stretch-debug main
    

Новые версии ПО:

  • Apache 2.4.25;
  • Asterisk 13.14.1;
  • Chromium 59.0.3071.86;
  • Firefox 45.9 (в пакете firefox-esr);
  • GIMP 2.8.18;
  • GNOME 3.22;
  • GCC 6.3;
  • GnuPG 2.1;
  • Golang 1.7;
  • KDE Frameworks 5.28, KDE Plasma 5.8, KDE Applications 16.08 и PIM-компоненты 16.04;
  • LibreOffice 5.2;
  • Linux 4.9;
  • MariaDB 10.1;
  • MATE 1.16;
  • OpenJDK 8;
  • Perl 5.24;
  • PHP 7.0;
  • PostgreSQL 9.6;
  • Python 2.7.13 и 3.5.3;
  • Ruby 2.3;
  • Samba 4.5;
  • systemd 232;
  • Thunderbird 45.8;
  • Tomcat 8.5;
  • Xen Hypervisor;
  • Xfce 4.12.

Debian «Stretch» содержит более 51 000 других готовых к использованию пакетов ПО, собранных из немногим более 25 000 пакетов с исходным кодом.

Всего поддерживается десять архитектур: amd64, i386, ppc64el, s390x, armel, armhf, arm64, mips, mipsel, mips64el. Поддержка powerpc в «Stretch» прекращена.

>>> Подробности

★★★★★

Проверено: Klymedy ()
Ответ на: комментарий от buratino

они сделали nonfree DVD1!!! то-то мне вчера казалось, что рак на горе рассвистелся.

С разморозкой, бро. Они давно существуют. Представь, есть даже non-free .net install...

Odalist ★★★★★ ()
Ответ на: комментарий от Odalist

В wheezy есть. https://packages.debian.org/wheezy/openoffice.org

Знаю, что dummy пакет. Но когда я пишу, apt-get install k3b, я ожидаю установки k3b, а не brasero. Так и здесь. В gentoo хотя бы имена виртуальных пакетов не пересекаются с именами реально существующих приложений.

grem ★★★★★ ()
Последнее исправление: grem (всего исправлений: 2)
Ответ на: комментарий от grem

Так и здесь.

Чего то я не понял. Они ведь пишут

This is a transitional package, replacing the OpenOffice.org packaging with the LibreOffice packaging.

Так в чем проблема то?

Odalist ★★★★★ ()
Ответ на: комментарий от Odalist

Проблема в том, что я, как пользователь, хочу установить определённое приложение, а они подсовывают вместо него другое.

Поэтому, когда я пишу apt-get install mplayer, я хочу видеть в jessie именно mplayer, а не mplayer2. А если пакета нет, то он должен мне выдать ошибку.

Вот отводишь ты утром в детский сад мальчика Мишу, а вечером тебе возвращают Петю - «Извините, 'Мишей' в нашем детском саду мы называем transitional мальчика, а вашего мы выгнали куда-то»

grem ★★★★★ ()
Последнее исправление: grem (всего исправлений: 2)
Ответ на: комментарий от buratino

А зачем они оба могут понадобиться одновременно?

templarrr ★★★★★ ()
Ответ на: комментарий от h578b1bde

Обычно такое используют для замены одних пакетов на другие. Когда-то был iceweasel стал firefox.

NextGenenration ()
Ответ на: комментарий от grem

Вот такой у них странный подход «мы этот пакет из репозитория удаляем, но вот вам вместо него другой, который вы, возможно, не и хотите».

Я уже не помню что там apt пишет, но dnf при обновлении разделяет пакеты на группы: установить, обновить, удалить... И пропустить замену одного пакета на другой случайно не заметив сложно. Другое дело если не читаю согласится...

NextGenenration ()
Ответ на: комментарий от grem

Поэтому, когда я пишу apt-get install mplayer, я хочу видеть в jessie именно mplayer, а не mplayer2. А если пакета нет, то он должен мне выдать ошибку.

Вот отводишь ты утром в детский сад мальчика Мишу, а вечером тебе возвращают Петю - «Извините, 'Мишей' в нашем детском саду мы называем transitional мальчика, а вашего мы выгнали куда-то»

apt разучился показывать список устанавливаемых пакетов?

NextGenenration ()
Ответ на: комментарий от NextGenenration

В простых случаях он просто ставит без подтверждения.

grem ★★★★★ ()
Ответ на: комментарий от buratino

mplayer2 давно умер. По сути это это пре-пре-пре-альфа первого публичного выпуска mpv (когда у него версии ещё были «git<дата>»).

anonymous ()
Ответ на: комментарий от buratino

ссылку на jessie dvd1 non-free или ...добол

Мамке своей указывай что делать, а ни мне, понял?

Odalist ★★★★★ ()
Ответ на: комментарий от grem

Эти простые случаи — это когда устанавливаются только пакеты, указанные в параметрах. Если же установка подразумевает какие-либо дополнительные действия, подтверждение запрашивается.

В случае с переходными пакетами они устанавливают по зависимостям замещающие пакеты, поэтому предупреждение показывается всегда. Так что случайно пропустить нельзя, можно только не обратить внимание.

anonymous ()
Ответ на: комментарий от buratino

DVD таки нет, но есть CD. Этого тебе недостаточно?

Gonzo ★★★★ ()
Ответ на: комментарий от Gonzo

вот именно, что DVD не было. ты либо записываешь CD, но с фирмварью, но там нет даже десктопа, либо записываешь DVD, но без фирмвари. в 9.0.0 наконец-то появился DVD с фирмварью

buratino ★★★ ()
Ответ на: комментарий от buratino

Кстати, кто-то жаловался на живые образы. 20-го уже запилили 9.0.1 Live, может быть, проблемы с установкою уже решены. У меня самого с MATE Live 9.0.0 установилось.

Vudod ★★★★★ ()
Ответ на: комментарий от Vudod

У меня самого с MATE Live 9.0.0 установилось.

Там были проблемы с Kde live. Весь англоязычный дебиановский форум бурлил...

Odalist ★★★★★ ()
Ответ на: комментарий от watsoon

Поздравляю.

Вот сейчас занят апдейтом основного рабочего места. dist-upgrade падал уже трижды.
Не помню про первый раз, но последние два при попытке обновить mysql и mpd.
Пока просто удалил их.

aidaho ★★★★★ ()
Ответ на: комментарий от Odalist

Там были проблемы с Kde live.

Не только. На ливке с XFCE та же байда была.

anonymous ()
Ответ на: комментарий от aidaho

Squid'у поменяли везде в путях 'squid3' на 'squid', но что-то пошло не так и бобик сдох во время миграции.

Прежнее мнение остаётся в силе: это самое безобразное обновление на моей памяти.

aidaho ★★★★★ ()

Релиз посвящён памяти основателя проекта Иана Мёрдока

Что уже выпилили systemd протиа которого он был?

quester ()
Ответ на: комментарий от Gonzo

non free только 1 двд, а хотелосб как в «оригинале» 3 (их конечно больше, но дляч скачки 3 стоит).

а тут только 1 диск. Посему мне легче установить сначало несколько дисков двд, а потом лишь поставить нужные драйвера-пакеты из firmware

maslakovvi ()
Ответ на: комментарий от quester

посвящён памяти основателя проекта Иана Мёрдока

!=

саботирован ретроградами-неосиляторами

t184256 ★★★★★ ()
Ответ на: комментарий от t184256

саботирован ретроградами-неосиляторами

Раз Иан Мёрдок был против сыстемд, то по вашей логике он ретроград и неосилятор.

quester ()
Ответ на: комментарий от quester

Я смотрю ты иногда можешь в логику, молодец.

t184256 ★★★★★ ()
Ответ на: комментарий от t184256

1) те кто против сыстемд «ретрограды-неосиляторы» 2) Иан Мёрдок был против сыстемд значит он «ретроград-неосилятор» 3) когда что-то кому-то посвящают это выражение уважения 4) посвящение релиза «ретрограду-неосилятору» означает что пункт первый не соответствует действительности и те кто его форсят тупые ушлепки и культ их обожания системд нужно удалить до выпуска релиза

quester ()
Ответ на: комментарий от quester

1-3

да

4) посвящение релиза «ретрограду-неосилятору» означает что пункт первый не соответствует действительности

проиграл, давай заново.

t184256 ★★★★★ ()
Ответ на: комментарий от aidaho

Пробовали вот это?

sudo apt-get -o Dpkg::Options::="--force-confnew" --force-yes -fuy dist-upgrade

denton ★★★★★ ()
Ответ на: комментарий от denton

Да я обновился уже давно, с помощью dist-upgrade.
Но осадок от общей кривизны апдейта в этот раз остался.

aidaho ★★★★★ ()

А systemd не выпилили, если нет то не надо

gtk3 ()

В debian 9 (установлен с нуля) с xfce на борту крашится xarchiver при попытке перетащить файлы из архива на рабочий стол. Штабильность.

cheshire_cat ()
Ответ на: комментарий от quester

перечитал, противоречия все еще нет. посвящение чего угодно чему угодно непосредственных последствий не несет, так что изволь сам раскрывать тему.

t184256 ★★★★★ ()
Ответ на: комментарий от Odalist

Мамке своей указывай что делать, а ни мне, понял?

Вместо того чтобы изображать агрошкольника мог бы написать в некорректные.

anonymous ()
Ответ на: комментарий от cheshire_cat

В debian 9 (установлен с нуля) с xfce на борту крашится xarchiver при попытке перетащить файлы из архива на рабочий стол. Штабильность.

Зато швабодка!

anonymous ()
Ответ на: комментарий от cheshire_cat

крашится xarchiver

Запилил багрепорт, надеюсь?

Gonzo ★★★★ ()
Ответ на: комментарий от anonymous

И установщик больше не розовый.

никогда в жизни не был розовым в Debian - всегда только синий, начиная с 3.0, где впервые появился прообраз нынешнего d-i (сам d-i - в 3.1)

buratino ★★★ ()
Ответ на: комментарий от h578b1bde

Кстати, напомни мне, пожалуйста, сроки поддержки хрюши и семёрочки чтобы сравнить их с дебовскими LTS.

напомни мне количество поддерживаемых пакетов и стоимость этой поддержки. если найдёшь тыщу таких же желающих и вы заплатите, для вас могут хоть базовые вещи в Debian Sarge поддерживать - тем более, все сырцы открыты, этим может заняться любой желающий.

но смысла особого нет - в Debian ты можешь обновиться до новой версии, абсолютно бесплатно и с помощью удобных и наглядных механизмов.

старого дебиана тебя тоже никто не лишает - я вот вчера поставил себе Debian Woody и Debian Lenny, и даже пользовался ими - могу прямо сюда написать

а вот ключ моей Windows XP превратился в тыкву - ещё несколько лет назад активация проходила, то сейчас вылетает ошибка даже на стадии попытаться проверить активацию. и SP3 оно качать не хочет (там дистрибутив с SP2), поэтому надо лазить по каким-то свалкам и искать это обновление вручную. про другие обновления я уже молчу. а в Debian с помощью archive.debian.org ты можешь поставить любую версию Debian, начиная с самых первых, со всеми обновлениями

ps. где-то валяется usb тюнер от авермедиа, который работал в XP, но нигде больше не работает. могу подарить.

ps2. помню, как при обновлении XP SP1 до XP SP2 все форумы в округе были забиты тем, как поломался практически весь софт

buratino ★★★ ()
Ответ на: комментарий от h578b1bde

Хотя как поставить пыху 5.3 на девятый дебиан без пердолинга не из официального репозитария дебиана тоже интересно было бы послушать.

взять спеку и собрать пакет

ps. поставить-то оно можно, а вот за качество работы отвечать сложнее. это я про венду.

buratino ★★★ ()
Ответ на: комментарий от h578b1bde

Действительно, зачем пользователю сторонний софт. Пусть кушает что дают и не выёживается.

круто. прямо как на айфонах. говорят, их бизнес-модель уже развалилась. или нет?

а вообще, когда у юзера есть каталог готового проверенного софта, которое ставится без проблем и по первому желанию - юзеру это удобно. лично я сторонний софт ставлю раз в пятилетку - я вполне доверяю разработчикам Debian и их гарантиям, взамен избавляя себя от многих проблем.

я уж молчу о том, что в aptitude ui софт искать намного проще, чем в вебе. когда мне раз в несколько лет требуется виртуалка с вендой, то поставив венду я теряюсь - куда бежать, куда податься? там даже архиватора нет. затем начинается поиск последней версии конкретного софта, который работает в XP только до определённой версии. в общем, убивается полдня на то, что в Debian делается за пару минут. и для меня, как для пользователя, выбор очевиден. для всех владельцев айфонов, кстати - тоже.

buratino ★★★ ()
Ответ на: комментарий от h578b1bde

вебмакаки?

Ога

если они смогли вкорячить на сервер php 5.2, то и на десктоп смогут

а вообще - странно говорить про разницу моделей. я также могу спросить, почему я в 50 нажатий клавиш сразу, на месте, за пару минут, не отвлекаясь, не могу поставить в венду архиваторы, смотрелки, читалки и пищалки. лично мне удобнее нажать и сразу получить. если кому-то удобно где-то лазить и что-то собирать - так это не сложнее, чем менять что-то в ветках реестра и накликивать в твикерах.

buratino ★★★ ()
Ответ на: комментарий от mandala

кстати, а в венде уже есть докер или хотя бы чрут, для нормальной изоляции приложений?

в дебиане я могу хоть третий дебиан зачрутить и гонять там всё, что мне нужно.

buratino ★★★ ()
Ответ на: комментарий от h578b1bde

Это ты разработчикам Devuan расскажи, которые после длительного пердолинга с этой твоей свободой отвязать популярные DE от systemd так и не смогли.

в OpenBSD есть KDE 4 (и в портах KDE5), Gnome 3.24, XFCE, Mate. и нет НИ ЕДИНОГО systemd

buratino ★★★ ()
Ответ на: комментарий от h578b1bde

Если в винде заявлена поддержка — оно работает.

кем заявлена? кто вообще гарантирует? тот мой тюнер, который я так и не выкинул, имел три версии драйверов, которые я в итоге собрал с трёх разных мест. и в каждом не работало что-то своё - где-то даже каналы нельзя было переключать :) приходилось иногда гвоздодёром выбивать одни, а втыкать другие

что касается вай-фая - помнится, как у меня ноутбук в произвольное время просто вырубал вай-фай как сетевую службу, и только перевключением это решалось.

а уж как я ставил драйвера ati mobility на win 7 - это просто песня...

buratino ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.